?
Solved

Outbound Email not Sending - Sitting in Outbound Queue

Posted on 2004-10-06
11
Medium Priority
?
569 Views
Last Modified: 2010-08-05
hi

Exchange 5.5 running on NT 4 has following problem.

All outgoing Email sits in the Outbound Queue.  If I open any of the Queued messages [Host Unreachable] is the reason given.  I need to get this resolved real fast ;-).  The machine has IP Connectivity on the LAN.  From the Command Line I can ping and resolve Apple.com  I am however unable to telnet on port 25 to the Exchange machines IP address from a LAN PC or even when tried on the Exchange Server.

Port 25 is open on the firewall. Please help :-(
0
Comment
Question by:robjeeves
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 3
11 Comments
 
LVL 3

Expert Comment

by:jasef
ID: 12245467
Hi robjeeves,
Either the server isn't up, or you're firewalled somewhere along the line.
First, can you ping the server? Do you know the difference between the MX records and the domain name?

Cheers!
0
 
LVL 3

Expert Comment

by:jasef
ID: 12245476
A good test is to go to network-tools.com or dnsreport.com and enter the username you want to send mail to and run the mail tests.  If that works you're issue is most likely local.
Try telnetting port 25 to another mail server you know works (note this is usually different to apple.com; you need to do an mx record.  A DNSreport.Com on the domain will show you the MX records to try).
0
 
LVL 10

Expert Comment

by:anupnellip
ID: 12245843
this could be a dns issue or ayour outbound port 25 is blocked . use nslookup  at the command prompt .  then type
> set type =mx
not put in the doamin name e.g hotmail.com or yahoo.com etc .
if you get the correct output then your dns is ok .

try to check with your network admin if your filrewall or router has port 25 closed . you can check this by telnenng some mail server at port 25 . many mail server dont let you telnet , but is u get an error that unable  to connect at port 25 then probably it is a firewall issue .  
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 3

Expert Comment

by:jasef
ID: 12245951
Anupnellip,
Doesn't sound like a DNS issue, but I would usually do an nslookup myself. DNSReport just makes this a little easier (and shows a lot of other potentially useful info)... You can then ping the resulting name or just try telnetting to it as I have advised.
In my experience (and I've tried hunderds or thousands by now) every mail server accept port 25 requests from telnet. Some will not send an echo response, but if you know what you are typing is correct, they will respond to the commands.
The only exception for a working public mailserver could possibly be a firewall filtering layer 7 traffic (something such as Cisco's CBACS).  If you really want, I can teach you how to use telnet properly as it is a wonderful tool.  Give me a server you don't believe responds to telnet and I'll help :)
0
 
LVL 3

Expert Comment

by:jasef
ID: 12246852
So hows it going there?  Can you telnet externally to a mail server?
After just re-reading your post, it looks like you cannot telnet to your OWN mail server on the LAN from a client PC on the LAN (ie: telnet lanmailservername 25)??
If the SMTP protocol is not configured correctly on your server mail will not go out. There are many options and or reasons why this can be the case, so before I go on, please confirm whether this is an issue.
Rgds,
Jason
0
 
LVL 9

Author Comment

by:robjeeves
ID: 12246874
hi - That is correct - I am unable to telnet to port 25 on the local exchange box.  . The internet Messace connector starts with no problem.

THanks
0
 
LVL 3

Expert Comment

by:jasef
ID: 12247549
Do you receive mail directly to that box from the net? Or do you pickup POP3 from a server elsewhere (like your ISP?).
Unfortunately I'm rusty on Exchange 5.5, lets see how we go.
You might be able to cut to a solution by forwarding your emails to your ISPs SMTP Server (Usually called a smarthost but it might be 'Forward All Messages To Host:'.
At this point we should probably check to see if your ISP will allow you to relay. You can do this by telnetting to the isps provided SMTP server (port 25 of course) then type as follows:
helo your.external.ip.address
mail from: user@yourdomain.com
rcpt to: user@somewhereelse.com
If you get an error relaying denied, you may need a username/pass - it is often the same as the POP3 pickup). If that doesn't work, you may need to call your ISP to continue with that option. If the username/pass thing works, you'll need to find where to enter this authentication into Exchange... Of course if it was already using this option you should try changing it to using DNS.
Still stuck?
Try the following (including the nslookup/telnet etc.)
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/dnexch55/html/msdn_exchsrvinet.asp
Sorry, wish I could give you a step-by-step guide, but it's been too long & I don't have a server handy.  Hope this nails your solution.  I'll check again in the next 24 hrs or so. :)
0
 
LVL 9

Author Comment

by:robjeeves
ID: 12255642
hi - I actually had an Exchange Guru called out and we built a new Exchange Box (Same organisation) and setup a new IMC.  I've moved all the mail boxes off the original Server onto the New Server.  I have followed the instructions in

http://support.microsoft.com/default.aspx?kbid=152959

Trouble is soon as I power of the Original Server (as a test before I format and re-install) No one can access the Address Book.  The Message is "Network Problems are preventing Access . . . . ." Clearly the Clients are looking for the original Server. This is now the problem. I'm happy to leave the points available if we can get to a point where I delete the original Server so I can begin a rebuild.

p.s The instances for Public folders appear to work fine with the Original Server powered off
0
 
LVL 3

Accepted Solution

by:
jasef earned 2000 total points
ID: 12256112
As your old server is still available, you could compare your new setup to the old one and see if it saves you a reload.

The address book in the Outlook Mail Profile my still be looking for the old GAL from the other server. In the Outlook client, you should be able to select which GAL or addressbook to use as default.

http://www.windowsitlibrary.com/Content/191/04/1.html
0
 
LVL 9

Author Comment

by:robjeeves
ID: 12256329
Hi - I actutually worked it out as the Clients held on to the old Servers name. A quick close/reopen Outlook of Outlook and everything was fine.  I'm now well on the way to rebuilding the new box.  Thanks everyone for input.
0
 
LVL 3

Expert Comment

by:jasef
ID: 12259660
Glad to hear it.  Hope all goes well :)
0

Featured Post

Is Your AD Toolbox Looking More Like a Toybox?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Lotus Notes – formerly IBM Notes – is an email client application, while IBM Domino (earlier Lotus Domino) is an email server. The client possesses a set of features that are even more advanced as compared to that of Outlook. Likewise, IBM Domino is…
MS Outlook is a world-class email client application that is mainly used for e-communication globally.  In this article, we will discuss the basic idea about MS Outlook, its advanced features, and types of MS Outlook File formats.
In this video we show how to create a Resource Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: Navigate to the Recipients >> Resources tab.: "Recipients" is our default selection …
This video shows how to quickly and easily add an email signature for all users on Exchange 2016. The resulting signature is applied on a server level by Exchange Online. The email signature template has been downloaded from: www.mail-signatures…
Suggested Courses

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question