Improve company productivity with a Business Account.Sign Up

  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 474
  • Last Modified:

Paradoxically slow loading sites

I have four computers in myhouse. One is connected by wire through a wireless router (D-link DI-614+) to my ADSL modem; the other three are connected wirelessly.  Two of the computers are communicating perfectly and receiving web pages at great knots.

The remaining wireless-connected computer can get onto the ABC (Australian Braodcasting Commission) site at great speed I can click on the latest news, etc. so it is downloading current material; not stored material.  It can also get onto at least one other Australian site with ease.

However, if I try to get onto Google or Yahoo seems to half load and then stop.

I have encountered difficulties with loading particular sites using a computer connected directly to an ADSL modem.  These difficulties were fixed by altering the packet size to the maximum that could be sent with 0% loss plus 28.  That worked well (using the advice from DSLREPORTS.COM).

However, that does not work with the wireless connected computers.  Or it does not seem to.  With the prolem computer I can ping any sites I want to and adjust the packet size in the CMD window.  I get good returns with 0% loss.  However, setting the packet size plus 28 does not seem to affect things.  Nothing seems to affect it.

The only solution my ISP could offer was to go into connections in Internet Explorer, click on LAN, and blank out the automatically detect settings box.  Actually that slowed things down.  

Note: although this computer is wirelessly connected it is only 1.5 metres from the wireless router.
I am running Windows XP on it without the service pack 2.
The PC wireless card is a D-ling DWL-G520+
The ASDL modem is a Dynalink RTA 300.
It has  0.5 mB of RAM and a 30 mB hard disk; these are probably not relevant.

Any ideas?  

2 Solutions
First, I would hardwire the PC into the router, just to take the Wifi out of the mix, and determine if it is still happening.

Also, feel free to visit my pages on Broadband (MTU size, etc..) for additional help.  You may even want to look over the Troubleshooting flowchart that I have available...

Let us know if there is a change after you connect directly..

Just out of curiousity...  are either of the other two wireless computers using 802.11b adapters, or is everything on 802.11g?  The reason I ask is there are known problems with running a mixed environment.  802.11g really suffers when you have 802.11b clients on the network.  This could be one possible reason.

If you go to and check out their speed test tools, how does it differ between the various computers?  You may need to install Java ( for the tools to work.  Does this one computer score really low?

Wiring it up for a test like Fatal_Exception mentioned is also a great way to rule out wireless problems.  He's right on the money with that.

Thanks master....  I just noticed I did not place a link to my website above...

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

LeonthewolfAuthor Commented:
Thank you for your comments as above.  I have been away on business and have not yet been able to put the direct wiring idea into action.  So don't think I don't appreciate your comments; I do.

Masterbaker's idea is an interesting one.  Again there was a delay while I came back home here to see just what the other computers are running.  I am afraid I am rather network illiterate.  I just plug the cards in and hope they work.  Both the other computers are connected to Netcom PCI wireless network adaptors which are 802.11g.  

The D-link DWL-G520+ booklet is rather tight-lipped about which wireless standard it uses.  In the front of the booklet it says that it needs at 802.11g or 802.11b access point.

The wirelss router box itself says it is enhanced 802.11b and, elsewhere on the same box, 802.11b compatible.  This does not quite fit with Masterbaker's scenario.

The G and B wifi standards are compatible, whereas A is not.  g and b run on the 2.4 ghz band, whereas a runs on the 5 ghz band.  When you mix network speeds, the network will autosense the slowest link and dumb down the speeds to the entire network to accomodate that device...  I believe that is what Master is talking about in this thread....

But, being that 2 of the 3 systems are getting good speeds, I think we need to target that one system.  But we need to know where to start.  I would still like to know if you experience the same issue when hard wired to the router...  :)

FYI - that's an 802.11b card.  "Enhanced" refers to D-Link's proprietary speed doubling technology.  If you were using a compatible D-Link router, you could get up to 22Mb/s rather than 11.  Lots of companies do that.  It's not relevant here, but maybe clear up your confusion about what type of card it is.  I fully agree that you should wire this one up and eliminate wireless as the cause.  If it were somehting with your wireless card though, you should have nearly the same result on any site and not picking and choosing.  When you are talking about adjusting your packet size, are you referring to your network MTU?  If not, you may need to experiment with that.  The only logical pattern I can see here is, assuming you're in Australia, that the geographically local sites are loading and international / nonlocal are not.  This would indicate a data loss / timeout problem.  A lower MTU will usually help with that, and greater timeout settings if that is configurable on your particular computer.  As to why it's going so slow in the first place, again the MTU could be the cause.  If it's attempting to transfer very large units, individual transmissions are probably timing out before all the data is reached, while others get through, hence you get half the page, it takes forever, and it eventually gives up.  ALso, as far as setting MTU's or packet size based on ping results, that's a good start, but it's really not accurate, because pings are ICMP packets over UDP, and when you're on the internet, you're dealing with transmission controlled data packets, which have a higher overhead.  In plain English, a large transmission unit size just small enough to ping well, may still be too large for accurate TCP data, because TCP has MUCH higher overhead.  A normal MTU size on broadband would be 1200-1500.  Start with something like 500, and go up in increments of about 150.  reboot each time after changing it, run some speed tests, try yahoo etc.  it should get faster each time, and at some point start getting slower again.  I'm guessing somewhere around 900-1000 would be optimal based on the symptoms you're describing.  There are instructions here

LeonthewolfAuthor Commented:
I have been rather slow in responding to this, like my wireless connection.  

I tried Fatal Exception's idea of direct linking.  There was no particular reason why I had that computer wireless connected 2 metres from the wireless router.  I guess I did not think the computer would end up in that situation.

Well, using the direct connection was interesting and finally very valuable.  Look, I have to tell you I am not very intuitive in relation to these matters; it is largely a matter of trial and error.  Call me an idiot if you like.  

I first of all installed an ethernet port in the computer (I had previously taken it out; hell knows why).  With the wireless card still installed I connected the computer also by cable to the wireless router.  There was no change.  The ABC site opened rapidly.  Google never fully opened; no change.

I then uninstalled the wireless card software and also physically removed the card.  Now the computer was just connected via the cable to the wirless router.  There was no change.  

I then had the idea that, with the new situation, which I am more familiar with being a newcomer to wireless technology, I could adjust the packet size.  I adjusted it to 1412, allowed for a header of 28 so put the number 1440 in the tweaker.  I saved the information in the tweaker software, exited it, and reopened Mozilla.  There was no change.

Finally I thought maybe I should restart the computer.  I did that.  When I opened Mozilla again IT WORKED!!!!!!  Every site could now be loaded.  So I thank Fatal Exception very much.  It appears the answer lies in both his idea of direct connection and in the ability to tweak the ethernet port.

The other suggestions were very good.  I am not completely sure of the rules here but I should probably close this question, award marks, and ask a new question.

Leon the Wolf
Very good.  And yes, rebooting is ALWAYS the way to go.  

If you really want to take a load off a system, instead of pulling hardware out, just go to the Device Manager and disable it.  You never know when you may need that hardware again.

Glad you got it, and thank you...

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now