Solved

JBuilder Tomcat port configuration

Posted on 2004-10-07
5
783 Views
Last Modified: 2008-01-09
Hi Expert,

I am using JBuilder Enterpirse Studio 7. I configured Tomcat 4.0 to run my web applicaiton. But getting the following exception. I looked at all the configurations to see if I can change the port number, but couldn't find any. When I go to http://localhost:8080 - nothing is configured but http://localhost:8081 something is already occupied that port. I just want to use a new port.

Help is greatly appreciated


tandardWrapper[/webapp:invoker]: Loading container servlet invoker

HttpConnector[8080] Starting background thread

StandardServer.await: create[8081]: java.net.BindException: Address already in use: JVM_Bind

java.net.BindException: Address already in use: JVM_Bind

      at java.net.PlainSocketImpl.socketBind(Native Method)

      at java.net.PlainSocketImpl.bind(PlainSocketImpl.java:331)

      at java.net.ServerSocket.bind(ServerSocket.java:318)

      at java.net.ServerSocket.<init>(ServerSocket.java:185)

      at org.apache.catalina.core.StandardServer.await(StandardServer.java:276)

      at org.apache.catalina.startup.Catalina.start(Catalina.java:794)

      at org.apache.catalina.startup.Catalina.execute(Catalina.java:681)

      at org.apache.catalina.startup.Catalina.process(Catalina.java:179)

      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

      at java.lang.reflect.Method.invoke(Method.java:324)

      at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:243)



Thanks
Dasari
0
Comment
Question by:DASARI_R
  • 2
  • 2
5 Comments
 

Author Comment

by:DASARI_R
ID: 12247469
Hi Again,

Just to give some more info:

I tried this option also but it throwed FileNotFoundException saying that it could find server8080.xml file
//--------------------
Change tomcat port in server.xml and it should be like this :
<Connector className="org.apache.catalina.connector.http.HttpConnector"
port="8080" minProcessors="5" maxProcessors="75"
enableLookups="true" redirectPort="8443"
acceptCount="10" debug="0" connectionTimeout="60000"/>
Change the port 8080 to someother port.
//-----------------
0
 
LVL 3

Accepted Solution

by:
applekanna earned 500 total points
ID: 12250027
Hi DASARI_R,
I have had this problem before,even when the app is closed the server keep running for some unknow reason.
I usually shut down my machine and the restart windows as well as JBUilder and it works fine then.

try this as well
go to Project-> Project Properties -> Run -> clik on the project u r workingin -> Edit -> clijk  on the JSP/Servelt on th eleft pane. You will be able to change the Server port this way.

Cheers!
0
 
LVL 11

Expert Comment

by:sompol_kiatkamolchai
ID: 12255735
for server.xml, JBuilder will look for server????.xml which ???? is port number that you config in Project Properties like apple said.
0
 

Author Comment

by:DASARI_R
ID: 12258883
Thanks !! changing the port worked !
0
 
LVL 3

Expert Comment

by:applekanna
ID: 12258922
DASARI_R,
Glad it worked....
Thx for the points :)
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
spring dependency injection using java config 2 89
nested if has else if 13 96
maven set up 2 175
withoutString  challenge 40 208
When it comes to protecting Oracle Database servers and systems, there are a ton of myths out there. Here are the most common.
Read about why it is more lucrative for an IT company to participate in government projects.
Nobody understands Phishing better than an anti-spam company. That’s why we are providing Phishing Awareness Training to our customers. According to a report by Verizon, only 3% of targeted users report malicious emails to management. With compan…

820 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question