Solved

Routing Netware protocols thru PIX site to site VPNs?

Posted on 2004-10-07
4
500 Views
Last Modified: 2010-05-18
Hi Hope someone out there can throw me a pointer here. I have setup a PIX site to site VPN to replace frame relay. It passes IP traffic fine and UNIX/Windows comm is operational.
Are there any other protocols/services I need to include so 2 Netware 5.1 networks can communicate?
TIA
0
Comment
Question by:mothman999
  • 2
  • 2
4 Comments
 

Author Comment

by:mothman999
ID: 12248436
Doh, my acl/encaps are;

access-list acl_out permit gre any any
access-list no_nat permit ip 10.0.6.0 255.255.255.0 10.6.1.0 255.255.255.0
access-list no_nat permit ip 10.0.6.0 255.255.255.0 10.0.1.0 255.255.255.0
access-list outside_cryptomap_20 permit ip 10.0.6.0 255.255.255.0 Winnipeg 255.255.255.0
access-list vpn permit ip 10.0.6.0 255.255.255.0 10.0.1.0 255.255.255.0

TIA
0
 

Author Comment

by:mothman999
ID: 12248909
The whole thing (I am using IPsec)

PIX Version 6.3(3)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password vjjjjjlfBcC encrypted
passwd LPPzNgXFvyD8jjjjjjcH encrypted
hostname gone
domain-name blah.com
clock timezone cst -6
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
fixup protocol pptp 1723
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name 10.0.6.0  remote
access-list acl_out permit gre any any
access-list acl_out permit tcp any any eq www
access-list acl_out permit tcp any any eq domain
access-list acl_out permit udp any any eq domain
access-list no_nat permit ip 10.0.1.0 255.255.255.0 10.1.1.0 255.255.255.0
access-list no_nat permit ip interface inside remote 255.255.255.0
access-list outside_cryptomap_20 permit ip interface inside remote 255.255.255.0
pager lines 24
logging on
logging timestamp
logging trap errors
mtu outside 1500
mtu inside 1500
ip address outside 222.333.555.666 255.255.255.252
ip address inside 10.0.1.2 255.255.255.0
ip verify reverse-path interface outside
ip audit info action alarm
ip audit attack action alarm
ip local pool pptp-pool 10.1.1.200-10.1.1.250
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list no_nat
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
access-group acl_out in interface outside
route outside 0.0.0.0 0.0.0.0 222.333.555.254 1
route inside 10.0.4.0 255.255.255.0 10.0.1.1 1
route inside 10.0.5.0 255.255.255.0 10.0.1.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
sysopt connection permit-pptp
sysopt noproxyarp inside
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto map outside_map 20 ipsec-isakmp
crypto map outside_map 20 match address outside_cryptomap_20
crypto map outside_map 20 set peer 142.179.219.243
crypto map outside_map 20 set transform-set ESP-3DES-MD5
crypto map outside_map interface outside
isakmp enable outside
isakmp key xxxxxxxxxx address 111.222.333.444 netmask 255.255.255.255 no-xauth no-config-mode
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
telnet 10.0.1.0 255.255.255.0 inside
telnet timeout 10
ssh 111.111.111.111 255.255.255.255 outside
ssh 0.0.0.0 0.0.0.0 inside
ssh timeout 10
console timeout 0
vpdn group 1 accept dialin pptp
vpdn group 1 ppp authentication pap
vpdn group 1 ppp authentication chap
vpdn group 1 ppp authentication mschap
vpdn group 1 ppp encryption mppe auto
vpdn group 1 client configuration address local pptp-pool
vpdn group 1 client configuration dns 10.0.1.46
vpdn group 1 client configuration wins 10.0.1.46
vpdn group 1 pptp echo 60
vpdn group 1 client authentication local
vpdn username blab password blah
vpdn enable outside
terminal width 80
Cryptochecksum:f9720d7e3b8aefce0b4fdfcda0cd7665
: end
0
 
LVL 79

Accepted Solution

by:
lrmoore earned 250 total points
ID: 12258483
Netware 5.1 servers don't use native IP?
You cannot bridge IPX accross an IPSEC tunnel
You cannot establish GRE tunnels with the PIX
Your option would be to setup a router on the inside of each end point and create a GRE tunnel "through" the PIX..

http://www.cisco.com/en/US/tech/tk827/tk369/technologies_configuration_example09186a0080093f70.shtml

Same concept as multicast through the pix
http://www.cisco.com/en/US/products/hw/vpndevc/ps2030/products_configuration_example09186a00800943fe.shtml
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 12258510
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

Suggested Solutions

Preface Having the need * to contact many different companies with different infrastructures * do remote maintenance in their network required us to implement a more flexible routing solution. As RAS, PPTP, L2TP and VPN Client connections are no…
For a while, I have wanted to connect my HTC Incredible to my corporate network to take advantage of the phone's powerful capabilities. I searched online and came up with varied answers from "it won't work" to super complicated statements that I did…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now