Crystal WEB Report User Login

I have a set of RPT's which I have made available for my Crystal WEB report server. When I select the report, the WEB/ASP Crystal report is not prompting for the user ID and password and does not display data. I can run the RPT's from my workstation and the user/password prompt appears then returns data. Why isn't the WEB side doing the same?
PdiminicoAsked:
Who is Participating?
 
frodomanCommented:
Login to the Crystal Management Console (CMC) and navigate to the report in question.  On the "Database" tab at the very bottom (you'll probably have to scroll down) there's a checkbox for "Prompt the User for Database Login when Viewing".  Check this box and they'll be prompted.

frodoman
0
 
mlmccCommented:
Are you running the same way from your workstation as others are?

Are the required Crystal dlls installed and available for download on the web server?

mlmcc
0
 
ebolekCommented:
Agreed
0
Cloud Class® Course: SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

 
PdiminicoAuthor Commented:
When Crystal Enterprise is installed wouldn't all the DLL's be installed and available?
0
 
frodomanCommented:
If you're working through CE you should have set the database id and password in e-portfolio when you published the report and the user should *not* be asked for this information.  Are you saying that you want the user to have to provide db authentication?
0
 
PdiminicoAuthor Commented:
Yes
0
 
PdiminicoAuthor Commented:
I have navigated to the Crystal Management Console,  opened objects, clicked on the selected box, and clicked on objectvsettings. I cannot find anywhere a database tab to make the change.
0
 
frodomanCommented:
In management console, it's simplest to check the 'folders' option and navigate to the report but you can get there by using objects as well.  What tabs *do* you see?  Is it possible you don't have admin rights to set the db?

frodoman
0
 
PdiminicoAuthor Commented:
Found it, thank you.
0
 
frodomanCommented:
Glad to help - frodoman
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.