Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1238
  • Last Modified:

Crystal 9 Problems and Errors

Hello Everyone!  We just switched from Crystal 8.5 to Crystal 9.  Ever since the upgrade, we have experienced several problems.

1.  We receive the errors "Query Engine Error: 'ORA-01001: Invalid Cursor" and "Not Supported. Details: Fail to fetch data.  OCI Call: OCIStmtFetch."  When opeing an existing file and changing a value, we receive these errors.  They come about 3 or 4 times daily.  

2.  A majority of our reports from 8.5 contain subreports.  When we open these reports in 9.0, the refresh button is grayed out.  In order to run the data, you have to open each subreport separately and do it that way.  Does 9.0 not support subreports?  I tried to re-import the subreport and go the error "Query Engine Error: 'ORA-03120: two-task converstion routine: interger overflow."  

Can anyone help me out here.  Is there something I need to know about Crystal 9.0 or something I need to do?
Thanks!
Ryan Black
0
w003rpb
Asked:
w003rpb
  • 2
  • 2
1 Solution
 
ebolekCommented:
>>>We receive the errors "Query Engine Error: 'ORA-01001: Invalid Cursor" and "Not Supported. Details: Fail to fetch data.  OCI Call: OCIStmtFetch."  When opeing an existing file and changing a value, we receive these errors.  They come about 3 or 4 times daily

This article explains the case:
support.businessobjects.com/library/kbase/articles/c2013847.asp

>>>A majority of our reports from 8.5 contain subreports.  When we open these reports in 9.0, the refresh button is grayed out.  In order to run the data, you have to open each subreport separately and do it that way.  Does 9.0 not support subreports?  I tried to re-import the subreport and go the error "Query Engine Error: 'ORA-03120: two-task converstion routine: interger overflow."  

this article shows how to do the subreport for 9 with samples.
support.businessobjects.com/communityCS/FilesAndUpdates/cr9_subreport_samples.zip.asp
0
 
w003rpbAuthor Commented:
I tried to re-import them as well and got the same error.  Has anyone else had this problem?  Is there a way to get around it?  What about the errors listed in #1 above?
Thanks for the help!
Ryan
0
 
w003rpbAuthor Commented:
Sorry, I didn't see the 1st article.  I am looking it over right now.  Has anyone else experienced these problems?
Thanks!
Ryan
0
 
ebolekCommented:
Comment from ebolek
Date: 10/07/2004 10:16AM PDT
 Your Comment  

gives detaile explanation to the problem and suggestion. Suggest accept to ebolek

Regards
Emre
0

Featured Post

Ask an Anonymous Question!

Don't feel intimidated by what you don't know. Ask your question anonymously. It's easy! Learn more and upgrade.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now