Solved

Crystal 9 Problems and Errors

Posted on 2004-10-07
7
1,169 Views
Last Modified: 2008-01-09
Hello Everyone!  We just switched from Crystal 8.5 to Crystal 9.  Ever since the upgrade, we have experienced several problems.

1.  We receive the errors "Query Engine Error: 'ORA-01001: Invalid Cursor" and "Not Supported. Details: Fail to fetch data.  OCI Call: OCIStmtFetch."  When opeing an existing file and changing a value, we receive these errors.  They come about 3 or 4 times daily.  

2.  A majority of our reports from 8.5 contain subreports.  When we open these reports in 9.0, the refresh button is grayed out.  In order to run the data, you have to open each subreport separately and do it that way.  Does 9.0 not support subreports?  I tried to re-import the subreport and go the error "Query Engine Error: 'ORA-03120: two-task converstion routine: interger overflow."  

Can anyone help me out here.  Is there something I need to know about Crystal 9.0 or something I need to do?
Thanks!
Ryan Black
0
Comment
Question by:w003rpb
  • 2
  • 2
7 Comments
 
LVL 10

Accepted Solution

by:
ebolek earned 250 total points
ID: 12251142
>>>We receive the errors "Query Engine Error: 'ORA-01001: Invalid Cursor" and "Not Supported. Details: Fail to fetch data.  OCI Call: OCIStmtFetch."  When opeing an existing file and changing a value, we receive these errors.  They come about 3 or 4 times daily

This article explains the case:
support.businessobjects.com/library/kbase/articles/c2013847.asp

>>>A majority of our reports from 8.5 contain subreports.  When we open these reports in 9.0, the refresh button is grayed out.  In order to run the data, you have to open each subreport separately and do it that way.  Does 9.0 not support subreports?  I tried to re-import the subreport and go the error "Query Engine Error: 'ORA-03120: two-task converstion routine: interger overflow."  

this article shows how to do the subreport for 9 with samples.
support.businessobjects.com/communityCS/FilesAndUpdates/cr9_subreport_samples.zip.asp
0
 

Author Comment

by:w003rpb
ID: 12251291
I tried to re-import them as well and got the same error.  Has anyone else had this problem?  Is there a way to get around it?  What about the errors listed in #1 above?
Thanks for the help!
Ryan
0
 

Author Comment

by:w003rpb
ID: 12251315
Sorry, I didn't see the 1st article.  I am looking it over right now.  Has anyone else experienced these problems?
Thanks!
Ryan
0
 
LVL 10

Expert Comment

by:ebolek
ID: 12463003
Comment from ebolek
Date: 10/07/2004 10:16AM PDT
 Your Comment  

gives detaile explanation to the problem and suggestion. Suggest accept to ebolek

Regards
Emre
0

Featured Post

Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

Hot fix for .Net Crystal Reports 10.2.3600.0 to fix problems with sub reports running on 64 bit operating systems ISSUE: Reports which contain subreports fail with error "Missing Parameter Value" DEPLOYMENT SERVER OS: Windows 2008 with 64 bi…
Hello everyone, Hope you find this as helpful as we did. We have on the company I work for an application built in Delphi V with Crystal Reports 8. We all know that Crystal & Delphi can be temperamental sometimes and the worst thing is, nearly…
This video discusses moving either the default database or any database to a new volume.
This tutorial demonstrates a quick way of adding group price to multiple Magento products.

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now