Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

configure: error: no acceptable C compiler found in $PATH ?????

Posted on 2004-10-07
4
Medium Priority
?
653 Views
Last Modified: 2013-11-17
Hello,

I get this error when I try to install Unix apps from my Mac OSX command line.  I only have shell access to the machine that I am trying to install on so Im forced to do it without downloading mac's "developer tools" which supposedly includes a C compiler.

When I tried to install GCC's host of compliers (including the C-complier) I get a similar error (apparently you need a C compiler to install the GCC C-complier!).  I realized that its because I need to do a "native install".. using "make bootstrap" command.  The problem is that I also dont have the "make" command.  I downloaded it from GNU and it wont let me install it because "configure: error: no acceptable C compiler found in $PATH".

So I need "make" to install the complier, but I need a complier to install "make"!  And all this is so I could install some other app (ImageMagick6.1.0), that I need for some other app (Ablum)!!!;).
Which comes first?  The chicken or the egg?

You'd think that Apple would include all this stuff in their version of BSD..

What do I do?!?!?
0
Comment
Question by:meuedyn
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
4 Comments
 
LVL 23

Expert Comment

by:brettmjohnson
ID: 12253665
> You'd think that Apple would include all this stuff in their version of BSD..

They do - either on a separate cd, as an installable package on the system disk,
or downloadable from the Apple Developer website.  The developer tools are not
installed by default on Apple's consumer-oriented machines.

Look for the file "/Applications/Installers/Xcode Tools/Developer.mpkg"
or download it from http://developer.apple.com/tools/download/

You can install the developer tools package from the command line.
However it does require administrative access to the machine.
Here is an excerpt of a How-To I wrote on command line installs:


This describes some of the steps necessary to perform the
installation of Mac OS X packages via the command line.


1) Download the Package

Download the installation image to a local directory.
I usually download packages to my ~/downloads directory.
Don't try to download it to some target directory like /etc or /usr

I use 'curl' to fetch the package from the net.  I usually Ctrl-click
or right-click the package link in Safari (running locally) and select
'Copy link to Clipboard'.  This copies the URL to the package to the
clipboard.  I then paste the URL into the curl command in a ssh login
window to the server.  Note that curl writes its output to stdout,
so be sure to redirect it to a file.  For example:

% curl http://www2.entropy.ch/download/Entropy-PHP-4.3.6-4.dmg > Entropy-PHP-4.3.6-4.dmg

This DOESN'T work for things on SourceForge, where the links are actually
javascript that goes to a mirror.  In that case, download it locally,
then use sftp (or Fugu) to move it to the server.


2) If it is a compressed archive, decompress it using the appropriate tool.
For instance suppose you have a .tar.gz file:

% ls
xyzzy.pkg.tar.gz

% gunzip xyzzy.pkg.tar.gz
% tar -xvf xyzzy.pkg.tar


3) If it is a disk image file (.dmg) mount it using hdid.  By default,
the disk images are mounted under the /Volumes directory.  I see no
reason to do it otherwise.

% hdid Entropy-PHP-4.3.6-4.dmg
% ls /Volumes
Backup HD               Entropy PHP 4.3.6-4     Server HD
% cd "/Volumes/Entropy PHP 4.3.6-4"
% ls
Documentation.html       php-4.3.6.pkg


4) Run the command line version of the Mac OS X installer.  By default
the installer produces terse output suitable for parsing by scripts
doing installations.  We will make the output verbose [human readable].
The installer takes the package name as well as the target Volume.
The installer is /usr/sbin/installer , which should be on the path.
The installer must be run as root, so be prepared to sudo...

% sudo /usr/sbin/installer -verbose -pkg php-4.3.6.pkg -target /


5) Don't forget to unmount the .dmg disk image if you mounted one.
Here we execute the 'mount' command to determine which virtual
disk device our dmg is mounted as (in this case it is /dev/disk2s2).
Then we use 'hdiutil detach' to unmount it.

% mount
/dev/disk0s3 on / (local, journaled)
/dev/disk1s3 on /Volumes/Backup HD (local)
automount -nsl [336] on /Network (automounted)
/dev/disk2s2 on /Volumes/Entropy PHP 4.3.6-4 (local, nodev, nosuid, read-only, mounted by admin)

% hdiutil detach /dev/disk2s2 -force
"disk2" unmounted.
"disk2" ejected.

0
 

Author Comment

by:meuedyn
ID: 12301372
ok,

I tried this and got stopped at the point where I entered:

% sudo /usr/sbin/installer -verbose -pkg php-4.3.6.pkg -target /.. here is what my mounted image directory looks like:

[pmac:/Volumes/December 2002 Dev Tools] dz% ls -l
total 20904
-rw-r--r--   1 dz  unknown     52179  4 Dec  2002 About AppleScript Studio.pdf
-rw-r--r--   1 dz  unknown     84816  4 Dec  2002 About Developer Tools.pdf
-rw-r--r--   1 dz  unknown  10433333 18 Nov  2002 CHUD_2.5.1.dmg
-rw-r--r--   1 dz  unknown      2048  8 Dec  2002 Desktop DB
-rw-r--r--   1 dz  unknown       978  8 Dec  2002 Desktop DF
drwxr-xr-x   3 dz  unknown       102 18 Nov  2002 Developer.mpkg
drwxr-xr-x   9 dz  unknown       306  8 Dec  2002 Packages
drwxr-xr-x  10 dz  unknown       340 10 Dec  2002 Pre-release Software
-rw-r--r--   1 dz  unknown    116826  4 Dec  2002 What's New.pdf

There is no main pkg that I can install in the image that the developer tools come in on.  Maybe I got the syntax wrong?  What would the line ( % sudo /usr/sbin/installer -verbose -pkg Developer,mpkg -target / ) look like?  Should install something else thats in the Developer.mpkg folder?

Regardless,  there should be some way to just install GCC and set up a c complier without the developer tools.  The system is FreeBSD and there should be some way to install a complier (CC) from the command line.  Can you point me to instructions on how to install the "make" command instead?  Once I have that, Ill just "make bootstrap"
0
 
LVL 23

Accepted Solution

by:
brettmjohnson earned 2000 total points
ID: 12304123
The documentation I provided used installing PHP as an example.  
Obviously, you want to install the developer tools rather than PHP.
An .mpkg is a package that contains other packages.  In this case
Developer.mpkg contains individual packages for the developer tools,
documentation, and examples.  I've never used the command-line
installer to install mpkgs, but I'm assuming it works.  The command
you posted (with the exception of the small typo - .mpkg  not ,mpkg)
would be correct.  The developer tools must be installed at the root
of the boot device (-target /).

sudo /usr/sbin/installer -verbose -pkg Developer.mpkg -target /

0
 

Author Comment

by:meuedyn
ID: 12309491
Thanks brett,

I think I just got the command syntax wrong.. I used your line and it installed the mpkg file just right..

-meue
0

Featured Post

Optimum High-Definition Video Viewing and Control

The ATEN VM0404HA 4x4 4K HDMI Matrix Switch supports 4K resolutions of UHD (3840 x 2160) and DCI (4096 x 2160) with refresh rates of 30 Hz (4:4:4) and 60 Hz (4:2:0). It is ideal for applications where the routing of 4K digital signals is required.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

What's a UDID? If you're involved in developing, testing, or even reviewing an iOS application that's in beta, then at some point you may need to know the UDID for any iOS devices that you'll be testing on. What's the UDID? It stands for Unique Dev…
In this article we have discussed about the OS X EI Capitan and how to fix Wi-Fi issue in OS X El Capitan. We have explained how to delete system level preferences and create a new Wi-Fi location to resolve Wi-Fi issue.
Add bar graphs to Access queries using Unicode block characters. Graphs appear on every record in the color you want. Give life to numbers. Hopes this gives you ideas on visualizing your data in new ways ~ Create a calculated field in a query: …
This tutorial will teach you the special effect of super speed similar to the fictional character Wally West aka "The Flash" After Shake : http://www.videocopilot.net/presets/after_shake/ All lightning effects with instructions : http://www.mediaf…

688 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question