• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1069
  • Last Modified:

Group Policy Restrict Run Problem - Viewing .jpg from Outlook gives access denied.

The system is running Windows XP and due to this user's desire to download and run everything he gets his fingers on I am setting up this new policy.  Everything seems to be ok so far except one problem.  When I double click on an image from Oulook (XP) I seem to get an access denied error message.

When I save the .JPG to disk and double click it from there, the Windows Picture and Fax viewer displays it fine.  When I disable the policy I notice that rundll32.exe is called from outlook and the picture displays fine, but even after adding rundll32.exe and explorer.exe to the allowed list of apps it still doesn't work.  Any thoughts?

One more thing - the default picture viewer is a DLL not an EXE so I imagine outlook is trying to use "something" to spawn this DLL, but I don't know what it is.
0
swabeui
Asked:
swabeui
  • 3
  • 2
1 Solution
 
Debsyl99Commented:
Hi

What policy settings are you using to start with? Check your event logs for any further info, and does it have to open with picture viewer? Have you tried changing the files association so that jpg/jpeg etc files open with Paint, or internet explorer as a workaround?
This also may be worth a look at if you haven't already in case there's some interaction going on with this aspect,
Modify Outlook 2002 and XP Attachment Restrictions
http://www.winguides.com/registry/display.php/929/

Deb :))
0
 
Debsyl99Commented:
Ah read everything except the title properly! Doh, ok understand the policy settings fine.
0
 
swabeuiAuthor Commented:
Internet Explorer is worth a try.  I will give it a shot on Tuesday when I get back into the office.  Paint or any other image modification app is out of the question as that is one of the things I am trying to restrict them from.  They spend all day trying to make photoshop mods of people and emailing them around.
0
 
swabeuiAuthor Commented:
IE worked for both JPG and GIF files which is all I really needed.  Should have thought of that, but oh well, I got the solution anyway.
0
 
Debsyl99Commented:
Hi

Glad it worked!

Deb :))
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now