All Windows 98 client cannot access to a server?

Dear all,

I have problems on all Windows 98 computer that they cannot access to the resouces on a file server.  When they click on the server name on My Network Places, it keeps on searching until it prompts "...XXX server is inaccessible."  For your information, the file server is running Windows 2003.

However, those with Windows XP computers are allowed and able to access.

So, may i know what is the problem actually?
Is it the license connection to the server is full?

Please advise.

Thank you.

altricAsked:
Who is Participating?
 
stardust126Connect With a Mentor Commented:
Do you have WINS installed on the server? Microsoft has confirmed that you must use wins even in a pure windows server 2003/XP environment (for example Exchange wont function properly without WINS installed).
Are the clients configured to use WINS?
Do you have any firewall installed on the network?
0
 
mmbuttCommented:
I faced the same type of problem.
client "windows 98"
server "windows 2000 Server"

I created one userid on windows 2000 gave permission on the share.
use the same user on windows 98 to logon.
<< i know in win98 user name & password are optional you can just press escape and it logs you in, however I used userid & password and it solved my problem>>

0
 
PrashsarCommented:
try to run install wins server on your windows 2003 server.
After this run the following command on your win203 server netdiag/fix
may be after doing this the problem may solve
0
Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

 
dttriCommented:
 Hello,
  You should chech the following:
  1. Install Client for Microsoft Network
  2. Install other protocols
  All of this are accessible in network incon in Control Panel.

  Hope this help,
  Tri
0
 
stardust126Commented:
Did you install the "file and printer sharing" component on your windows 98 clients? otherwise, you wont be able to access network resources.
0
 
altricAuthor Commented:
All users' computer have been installed with file and printer sharing component.

For your information, the Win98 clients are able to access to server by IP address only.
Win98 clients are logon as domain user to the domain server.

Any ideas?

thank you everyone's reply.
0
 
DoTheDEW335Commented:
If your server is a domain server you should make sure your Primary DNS settings on the client machines point to the Windows 2003 Server IP.
0
 
DoTheDEW335Commented:
This will fix that problem ;)
0
 
DoTheDEW335Commented:
If the DNS setting doesn't help (it really shoud be the fix) Try installing IPX/SPX on the clients and server if you don't already have it.
0
 
Mr_C_ObviousCommented:
another guy had a similiar problem and got an answer in networking

http://www.experts-exchange.com/Networking/Q_21152836.html
0
 
onesquinCommented:
What level is your domain?? native, 2003??
0
 
guniteCommented:
If you can resolve the IP address then you obviously have connectivility. Don't install IPX/SPX as it will cause horrible network traffic on your LAN. Also if you do have WAN connections it is likely that IPX is not routed.

Make sure DNS is configured right on the server. If it is, make sure the client is pointing to the DNS. If this still doesn't work enter the IP address and Host name of the server into the HOSTS file to test DNS resolution. By putting the address in there it will eliminate DNS as a possible culprit.
0
 
DoTheDEW335Commented:
gunite, I already stated to set the dns, and your comment about IPX is a little misleading. I have a few networks I monitor and 2 of them use IPS/SPX without and network problems at all. It depends on the network and who set it up. As far as connectivity obviously he has it because they log onto his domain as he posted in the comment above. If he listens to me and sets the 98 machines TCP/IP DNS setting to the Domain Server's IP address it will correct his issue. Also he should make sure in the DNS settings on the server, the forward lookup zone should not have a "." zone (w/o the quotes of course)
0
 
onesquinCommented:
I asked what mode you domain is in because if it is 2003 you will have to perform a policy setting on the DC's to let non-nt os's authenticate on your domain.
0
 
studlyedCommented:
i was helping another guy with a similar issue turned out to be in the group policy of the server. it was so locked down that it didnt allow anything other than secure connections. 98 doesnt support secure connections.
look in the group policy editor under Computer Config->Windows Settings->Security Settings->Local Policy->Security Options and make sure that these are all set right. dont always encrypt the data because you have 98 boxes, that wont work, be sure to allow anonymous SID stuff. check the minimum session security make sure it is no-minium. and make sure FIPS is disabled. if it still doesnt work check basic network connectivity to the server from the 98 boxes using ping and such.
0
 
altricAuthor Commented:
Finally, I found that on my WINS server the IP address of my File Server is another IP address.
(I went to the WINS tool and then select "Find by name".  I typed in my File Server name.  From there I realized that the IP of File Server is wrong.)

It is not the actual IP address of my File Server.

So may I know how to correct it?

Thank you...everyone...
0
 
stardust126Commented:
Either delete the record and boot the file server and it will re-add itself or just edit it yourself.
If you delete the record yourself, make sure you delete all records (Messenger, domain, and so on, just sort by ip and delete everything containing the server's ip) and make sure you replicate the changes to all other wins servers on your domain.
0
 
altricAuthor Commented:
I try to edit it by right click on the computer name but it seems there is no option for me to edit.

Is there anyway to change it?

thank you.
0
 
stardust126Commented:
then try deleting it.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.