Can send packets but can't receive packets

I have a system that was working fine but now it can't get online.  The network is fine. The settings are correct.  Tried a new cable, a different port, a different switch, even a different network card.  Same thing.  Received packets stays at 0.  Didn't run Adaware or anything but did the Winsock fix anyway.  Didn't work.  Reinstalled TCP/IP.  Nothing.  This is a server which hosts an important program so I am in trouble if I need to format.  Any ideas out there?
Who is Participating?
Pentrix2Connect With a Mentor Commented:
Don't use a new hard drive, thats' not going to fix anything.  First, is this computer using which operating system?  If it's using Windows XP, then I would do a SYSTEM RESTORE, which gives you the ability to restore it to a date that you knew it was working fine.  If it's Windows 2000 Professional, use the OS cd to restore all your system files.  I would use this as a adware removal tool:

You can't be going around replacing every hard drive just because it can't get online.  This indicates it's a operating system/software issue.  The only time you need to replace a hard drive is when:   1) you got tons of bad sectors on it.  2) it keeps on doing memory dumps on  you even after you loaded a new os multiple times.  3)  it's so old with less space, like 1gig for example.  4)  You hear a click sound on it, which means it stopped spinning  5)  or any other hardware damage on the hard drive itself.

Next thing I would do is, see if the network cable connected to the network has a light on it.  If it doesn't, bad cable or the port isn't connected.  If it does, I would unjoin and rejoin the domain.

Another thing to try is this.  Drop to a command prompt, do ipconfig /all.   See if you are getting the loopback address or a valid ip from your dhcp server.  See how many network adapters are listed as well.

Another thing to try is this.  Go to your properties on your NIC card in My Network Places, see if there's other adapters or protocols install that shouldn't be there.  
hmz... use a new HDD to install OS and see if it is working or not. I suspect it should be some software / Virus cause the problem. It is worth to try Adware and virus scanning before reinstall the OS.
hindsightAuthor Commented:
It's 2000 server.  I am going to pull the drive and put it in another system to scan for viruses and spyware. We have already tested cables, ports and NICs.  It is something with the OS.  We tried a fast repair off the cd but it didn't work.  I'll see what happens.  My company took over this network a month ago and it is a mess.  I'm actually hoping it's just a virus.
Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

hindsightAuthor Commented:
No viruses and minimal spyware.  Oh well.  It's going to be a long day...
Run ipconfig /all on the machine and verify the tcp/ip parametters. Can you ping the machine from another one? Can you ping another machine? Maybe the tcp/ip parametters (address) is changed and the other computers cannot find that server now.
I wouldn't recommend pulling drives until we have exhausted all possabilities but I know you are in a hurry and at a loss.

what about the IPCONFIG /ALL that pentrix2 suggested?  can you ping
Yes, at least ping the local loopback address to see if the nic is responding.
On a small scale, when I see this problem.... it resides in my router.  At home, I have my cable modem going into a D-Link Router which sends a CAT-5 to my NIC.  There are times where I get 0 packets as well, and even IPCONFIG wont fix it for me... I turn off the workstation, reset the Modem and then reset the Router... bingo.  (Only have to do this after I've messed around with the cabling, its not a daily occurance)

Usually this is due to a bad gateway address/router problem.

Can you ping the LAN address of your router?
Can you ping the Internet address (if you know what it is) of your router?
Can you ping something like

Try doing a Trace Route to see if it shows anything -
tracert (IP address or web site address)

Is DNS working; i.e. you can ping but not

Have you tried connecting another computer in place of this one to see if it works?
Tim HolmanCommented:
If you don't want to rip the drive out, install W2K to another directory - eg WINNT2.  You should be able to dual boot into both and at least verify whether or not a new W2K install would actually fix the problem..
Tim HolmanCommented:
What was the problem ?

The replace HDD suggestion is use to test if it is software problem or hardware problem. I didn't say it will fix the problem. System restore is not stable and sometime it may cause unexpected result. If it is really software error, just try your best to fix it using different software.... AntiVirus, AdWare.....
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.