Bios not detecting scondary drives yet windows XP does

I have a dell Dimension 4600, there is a 40gb secondary drive and my DVD-RW, the DVD is found ok, but not the secondary 40GB drive (partitioned into 4) .. bios says it cannot find the drives, set to auto detect, no go but upon continuing with the boot and starting windows XP (home) .. XP finds the 40GB and the partitions just fine .. just upgraded the bios as well to see if it would fix it, it didn't

Any ideas?
Who is Participating?
SnodlanderConnect With a Mentor Commented:
Try changing your jumper settings to <Master><Slave> instead of what I think you have, <Cable Select>
Cyber-DudeConnect With a Mentor Commented:
Could you add more details such as when the problem started to appear or are you experienceing any POST delays and forth?

Did you try connect all drives seperately and verify their propper working?
Did you verify the <Master> and <Slave> as Snodlander suggests?

Is there an option in the BIOS detect IDE drives? If yes, use it. Also try setup defaults or bios default, or bios optimum settings.
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

go into bios
light up number lock, caps lock and scroll lock
Press alt+E (wait for a beep)
press alt+F (wait for a beep)
exit saving changes
this should force a redetection of the IDE devices
The author tried what you suggested:
>bios says it cannot find the drives, set to auto detect, no go...

We dont want any 'repeatative' solutions, arnt we?...


set to auto detect is in the primary screen, i'm talking about another setting.
You're right we don't want repetitis, but blind readis isn't good either...
Joking !
I strongly agree to tfjeff.

By following the procedure the system redetects all the Devices connected to it and 99% of the time your problem could be resolved by clearing the Bios N-RAM ( ALT E ) and Loading the Bios Defaults ( ALT F ) .

Note : After the IDE Auto Configuration the System would pick up All the IDE devices connected to it and also make sure that you have all of them connected in the Cable Select Mode.

This will works

mwnnjConnect With a Mentor Commented:
Hi all folks,what is hier forum or a pub ;-))
ROAMERNZ,please let us know how many and what kind of partitions you have on both(am i right) of your harddrives.If i am rifht you must have a primery hdd of 160GB....Let us know:How many storage medias are connected to your ide controller onboard:hdd1,hdd2,dvd-wrirer and if something else :positions of jumpers on every drive and hierarchy of drives master/slave ide channel 1 ,master/slave ide channel 2.Types of the drives ,i mean modells :For and instance :Seagate Modell munber :ST3160023AS.So:
hdd1-modell number,position,jumpersettings,partitions on it(all info),
hdd2-modell number,position,jumpersettings,partitions on it(all info),
dvd-writer-modell number,position,jumpersettings,
other storage media-modell number,position,jumpersettings,
If you have pci- storage adapters too,please let us know..
I am not trying to annoy you,but i'm not sure:
i think there is somekind of mess with hierarchy of storage drives on your ide channels,and a mess between the partitions of the two hdds; what have you done with the secondary hdd,have tryied installing parallel system to could be your master boot record of the secondary drive have something about a bootable system or something else,could be virus too,cuz it was:"...bios says it cannot find the drives, set to auto detect, no go..." ican understand it ,your BIOS knew that you had already something bootable on the secondary drive and at this moment it can't find it no more so it boots by default.If Windows detects the partitions and the harddrive ,than you drive is accessable and fully functional,problem is BIOS is more stupide than windows on it's own.
Please,post the info hier :FULL INFO!
Thanks,till later!
huntersvcsConnect With a Mentor Commented:
I think nobus is probably right.  I have worked with DELL computers a lot, and they can sometimes have a confusing BIOS setup that is quite different from what you usually see.  To repeat the suggestion from nobus:  Switch from AUTO to HDD.  This may or may not help, but is worth a try.

If this solves the problem, the points belong to nobus!

If not, remember:  The OS gets it's primary hardware information from the BIOS during the boot process (HAL-process).  If the OS is finding the HDD, but the BIOS is not showing it properly on the screen, the problem probably is somewhere else.  If I remember correctly, the DELL BIOS does not have and AUTO-DETECT function the way other BIOS versions.  Switching simply to HDD is your only other alternative.

If you've flashed the BIOS like you mentioned, then the default settings have already been set back so you don't necessarily have to do that again(?).  If you switch from AUTO to HDD and the system doesn't boot further (freezes during the boot sequence), switch back to AUTO.
I have a PC at present that will bluescreen at boot if I connect my Hard drives and Optical drives in a particular combination.
The solution for this was to try a different combination of drives on IDE cables.

I suggest you do the same. Try setting just one HDD on the primary IDE - nothing else - and set it to master
Then connect the other HDD to the secondary IDE and set it to master. See if your system detects the disks in their new configuration and post your results here.
Points please Roamernz...

Did any of the suggestions actually help?  If yes, give the points to the ones who helped.  If not, either let us know where you are now or request that the question be closed.
The user probably had a combination of cable select and secondary, then attached them in the wrong order.  I've seen this many times.  Since we have had no feedback, recommend giving the points to Snodlander for his comments at the very beginning regarding jumpers.
I agree with huntersvcs!

as we do not have feedback, we don't know the solution; and  It is not up to us to decide who gets points. Let the mods do their job! (they do it well !)
LucFEMEA Server EngineerCommented:
Just my thought on it.
The disk isn't recognized by the BIOS, but it is by windows, so it's recognized by another bios :o)
The most obvious reason is that ROAMERNZ might be using a PCI-IDE controller to which this disk is attached.

Without feedback we can't be sure, hence my recommendation "Delete - no points refunded"

EE Cleanup Volunteer
LucF, do you think that a dell Dimension 4600 ships with PCI IDE cards or that Roamernz has gone and installed one?

I think this is a far from obvious reason and more of a wild stab in the dark, especially since Roamernz only indicates that he has (a maximum of) 3 devices installed - DVD-RW, Secondary drive, and XP (Home)

Besides which, my solution ==>Try setting just one HDD on the primary IDE - nothing else - and set it to master. Then connect the other HDD to the secondary IDE and set it to master. See if your system detects the disks in their new configuration.

Will undoubtedly be recocnised by the BIOS unless there is an issue with hardware. After which he can install the DVD-RW as a slave on the secondary IDE and check again. If problems persist he can place it on the primary IDE and test.

I believe the chances of Roamernz having a PCI IDE card are about as remote as Microsoft considering Windows XP to be nothing but a Basic Input Output System.

In summary I agree 100% with both huntersvcs and mwnnj.

Share the love LucF
You're right LucF.  I've seen the PCI controller from PROMISE uses a separate BIOS for recognizing the hardware.  If Dell had one, this might not show up during the boot sequence because they have modified the BIOS to show only "their logo".  A normal BIOS would show the secondary BIOS recognition sequence.  I guess I just took it for granted that if someone had to go to the trouble to install a separate PCI controller that they would have mentioned it.  But you are probably right!  Sometimes we just don't get sufficient information describing the situation.
ROAMERNZAuthor Commented:
Oh guys, sorry about being absent, have just shifted house and everything is in a mess at the moment.

I tried tjeff's solution and thought for a second it worked, i.e. it rebooted and started just fine, however, then XP didn't find anything, so rebooted and then I was back to the same again, I have not had time to try anything else, yet, actually PC is still packed away, (using a laptop at the moment).

How do you give the points anyways?
next to each post is an accept button, if you want ONE answer; or you can select SPLIT below the posts, and assign points to the selected answers for a total of your points
ROAMERNZ, do you have a PCI IDE card installed in one of your PCI slots?

Or are you just using the IDE connections on the motherboard?
try the hdd on an another machine ,see if it will be not  recognized or if it will work...
try to ad it as slave and as master to check both of the settings.
Good Luck!
I'd suggest a split: mwnnju-snodlander-cyberdude-huntersvcs.  Roamernz has enough ammunition - just needs to unpack his PC!
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.