[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 189
  • Last Modified:

how to change .com to .local

I'm having a problem with a split dns horizon. After migrating to AD from Novell my company decided to have a 3rd party build/host a web site for us. Since my local domain is .com I'm having trouble resolving the web site internally. I came across this expert advice and think it fits what I need. Can someone tell me how to go about changing my internal domain name from .com to .local?

>>DO NOT name the AD domain as the same as your DNS domain.

>>If you domain is QUANGO.COM then best practice is QUANGO.LOCAL
>>You then set the exchange server to route email for QUANGO.COM and as long as the MX records are in place for >>QUANGO.COM then everything will work fine.

>>The reason for this is to avoid SPLIT HORIZON DNS where you have to resolve machines on the same domain that are >>not on your local subnets. This is not insumountable, but is a pain in the ass that you don't have if the internal and >>external domain is different.

>>Cheers

>>JamesDS
0
hullc65203
Asked:
hullc65203
  • 2
  • 2
  • 2
1 Solution
 
robrandonCommented:
You don't need to change your internal domain name for this.  Create an A record on your DNS server with say 'www' pointing to the public IP address of the web server.

0
 
mikeleebrlaCommented:
FYI,, your current setup is called split DNS, not split horizon DNS.  Split horizon is a mechanism to avoid routing loops and has nothing to do with DNS at all.  

Also,  there is absolutely nothing wrong with having your registered domain name as domain.com and your internal AD domain DNS name as domain.com also.  All you have to do is set up your DNS correctly and it will work smoothly and transparently to your users (as it should).

robrandon is right,, all you have to do is have the www.domain.com on your local DNS server actually pointing to the correct IP address of your www server.  In this case it sounds as though your www site is not on your lan,, so you will have to let your local dns server know about this by adding the DNS record for it.
0
 
hullc65203Author Commented:
I've found that setting the client's dns to my ISP will resolve the www address. Howevery, if I enter the public IP in the http:// field, I get "access denied".

I tried adding an entry for www in my dns, but it didn't work.
0
Prep for the ITIL® Foundation Certification Exam

December’s Course of the Month is now available! Enroll to learn ITIL® Foundation best practices for delivering IT services effectively and efficiently.

 
robrandonCommented:
Adding the entry didn't work, or getting to the web site internally didn't work.  

If you can't get to the server by using http://IPADDRESS then it sounds like there is a routing issue or perhaps a firewall issue.
0
 
mikeleebrlaCommented:
that is true that chaing the dns to an external "real" dns server will resolve this one problem, but it will create 1000s more if you run active directory (im not sure if you do or not).  The access denied message comes from the www server, which means that you are actually hitting the server, but just as the message says you dont have access to the page.  this is something that you need to get with whoever hosts the page.  More than likely they dont have anonymous access set in IIS or the page doesn't have read rights for the IUSR (anonymous www user)account
0
 
hullc65203Author Commented:
Turns out I had originally transposed a couple of numbers in the dns entry. I created a correct entry, ran ipconfig /flushdns and it's working fine now.

Thanks!
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 2
  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now