Solved

BTTV Sound Won't Shut Off

Posted on 2004-10-08
11
150 Views
Last Modified: 2013-12-06
Hello-

I am running Fedora Core 2 and was wondering if there is a better method right now for shutting off the sound when using the bttv?  Right now I have to issue /sbin/modprobe -r bttv to stop the sound.

Thank you!
0
Comment
Question by:aaeandcee
  • 6
  • 5
11 Comments
 
LVL 44

Expert Comment

by:Karl Heinz Kremer
ID: 12265714
Does your TV card provide it's own sound support, or did you have to connect the TV card with a cable to your sound card?
0
 

Author Comment

by:aaeandcee
ID: 12265752
I had to connect a cable to my sound card.  
0
 
LVL 44

Expert Comment

by:Karl Heinz Kremer
ID: 12265759
Which application are you using to watch TV? In general, you have to tell your application which audio input your TV card is using to that the application can mute or control the audio card.
0
 

Author Comment

by:aaeandcee
ID: 12265899
I'm using TVTime.  If there is a better application for this, please let me know.
0
 
LVL 44

Expert Comment

by:Karl Heinz Kremer
ID: 12265993
Look into the directory /etc/tvtime or /usr/local/etc/tvtime and edit the file tvtime.xml. In this file look for a line like this:

  <option name="MixerDevice" value="/dev/mixer:line"/>

Change the configuration so that it matches the input of your sound card that you are using.
0
VMware Disaster Recovery and Data Protection

In this expert guide, you’ll learn about the components of a Modern Data Center. You will use cases for the value-added capabilities of Veeam®, including combining backup and replication for VMware disaster recovery and using replication for data center migration.

 

Author Comment

by:aaeandcee
ID: 12266102
I am somewhat of a Newbie, how do I determine what to put on this line?  The device uses my audio in port on the sound card.  My sound card is listed as a 82801DB (ICH4) Audio Controller.  It is using the snd-intel8x0 device driver.  
0
 
LVL 44

Expert Comment

by:Karl Heinz Kremer
ID: 12266308
OK, let's take a step back: Can you control the volume with the cursor keys (left and right should decrease/increase the volume)?

Please type this command in a terminal window and cut&paste the output into your comment:

amixer scontrols
0
 

Author Comment

by:aaeandcee
ID: 12266435
Yes, I can control the sound using the right and left arrow keys.

amixer scontrols
Simple mixer control 'Master',0
Simple mixer control 'Master Mono',0
Simple mixer control 'Master Surround',0
Simple mixer control 'PCM',0
Simple mixer control 'Surround',0
Simple mixer control 'Surround Jack as Input',0
Simple mixer control 'Center',0
Simple mixer control 'Center/LFE Jack as Input',0
Simple mixer control 'LFE',0
Simple mixer control 'Line',0
Simple mixer control 'CD',0
Simple mixer control 'Mic',0
Simple mixer control 'Mic Boost (+20dB)',0
Simple mixer control 'Mic Select',0
Simple mixer control 'Video',0
Simple mixer control 'Phone',0
Simple mixer control 'IEC958',0
Simple mixer control 'IEC958 Playback AC97-SPSA',0
Simple mixer control 'IEC958 Playback Source',0
Simple mixer control 'Aux',0
Simple mixer control 'Capture',0
Simple mixer control 'Mix',0
Simple mixer control 'Mix Mono',0
Simple mixer control 'Downmix',0
Simple mixer control 'Exchange Front/Surround',0
Simple mixer control 'External Amplifier',0
Simple mixer control 'Spread Front to Surround and Center/LFE',0
Simple mixer control 'Stereo Mic',0
0
 
LVL 44

Accepted Solution

by:
Karl Heinz Kremer earned 50 total points
ID: 12266638
The muting is actually done on the TV card, and not the sound card. This means that it's likely that your TV card is not correctly configured.

Which card are you using? This page http://tvtime.sourceforge.net/problems.html (item 4) talks about a muting problem with some cards.
0
 

Author Comment

by:aaeandcee
ID: 12266889
I use the ATI TV Wonder-LE card with the BT878 chip.  
0
 

Author Comment

by:aaeandcee
ID: 12266917
I believe I solved the problem.  On the link you gave me I noticed another issue I was suffering from, the channel being off by one.  I modified the /etc/modprobe.conf file to include the options bttv tuner=2 setting and now the sound shuts off when I exit out of TVTime.  Weird.  Thank you for your help, and the link!
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
parse convert xml feed to text (python) 2 71
AWS CLI - Issue with name display 2 51
Installing VirtualBox in Fedora 25 Linux 2 130
Coding C# in Linux 8 34
If you use Debian 6 Squeeze and you are tired of looking at the childish graphical GDM login screen that is used by default, here's an easy way to change it. If you've already tried to change it you've probably discovered that none of the old met…
Join Greg Farro and Ethan Banks from Packet Pushers (http://packetpushers.net/podcast/podcasts/pq-show-93-smart-network-monitoring-paessler-sponsored/) and Greg Ross from Paessler (https://www.paessler.com/prtg) for a discussion about smart network …
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

867 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

17 Experts available now in Live!

Get 1:1 Help Now