D-link DI-604 ftp slow response

hi experts,
I have a problem about my D-link DI-604 router. I use DI-604 connect to my cable modem and my windows XP. When I browse internet, download stuff, it works perfect, the transfer rate can be up to 300k/s. But when I received files from my ftp server, it is very slow, only 6-8k/s. I redirect the ftp from my router (192.168.0.1) to my computer (192.168.0.100). I don't know why the responds is very slow. I have tried to connect my computer directly to the cable modem, then the ftp speed can go up to 200k/s. When connect back to the router, it goes down again. I have to use the router to connect 4 computers in my house, so don't tell me to remove the router. Any help is very appreciated. Thank you in advance.
shy513Asked:
Who is Participating?
 
DarthModConnect With a Mentor Commented:
PAQed with points (200) refunded

DarthMod
Community Support Moderator
0
 
shy513Author Commented:
more information: the ftp port is using 21
0
 
netspec01Commented:
> I redirect the ftp from my router (192.168.0.1) to my computer (192.168.0.100).

So you have an FTP server that you expose to the Internet through port re-direction?  Or are you using a "DMZ host feature"?

The throughput tests you cite are from an FTP client on the public network connecting to your FTP server?
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

 
shy513Author Commented:
yes, I have a ftp server through port re-direction. I ask my friend to send stuff to my ftp for testing, and the speed is 6-8k/s only.
btw, can you tell me what is DMZ, cuz my router has this feature, but I don't quite understand what it is. Thank netspec01
0
 
shy513Author Commented:
I know wut is DMZ now. I think I would still prefer using virtual server rather than DMZ.
0
 
netspec01Commented:
DMZ opens up all ports to a specified inside host.  Use ONLY if you have a really locked down machine or you could try this for testing.

ALso, why don't you go to dslreports.com and do their speed test if you haven't done so already.  http://www.dslreports.com/stest
0
 
shy513Author Commented:
thanks for your reply, netspec01. I have try the dslreports.com, and my test is normal («1668 down, «225 up) I know it is ok, bcuz as I mention, I can browse at normal speed, but when the transfer is throught my ftp, it will become so slow. I have test that without a router, the speed can be up to 200k/s (ftp) but with the router port forwarding the speed is down to 6-8k/s...please help
0
 
netspec01Commented:
I'd like you to check out your firmware and make sure you are up-to-date.    

1. Use your Dlink web interface and find out what verion of firmware you are using
2. Go to http://www.dlink.com/products/support.asp?pid=62#firmware to identify which model you have.
3. click on the image of the model you have
4. The current firmware for model DI-604 Revision E is 2.07.  The current firmware for DI-604 rev a,b or c is 2.20.  If your version is older, download the firmware and upgrade according to the instructions.


Then run your speed test again with FTP making sure that you have cleared you cache between each test.
0
 
shy513Author Commented:
yea, before I ask this question, I have already updated my firmware to the most updated version, but same result. But I haven't tried to clear my cache. Can you tell me how and where to clear my cache? I suppose it's not clear the cache in IE or reboot my computer or restart my ftp server. Thanks for answering. Thanks
0
 
netspec01Commented:
If you are using IE for doing FTP it will be the IE cache under tools\Internet Options.  If you are using command line i am not sure where it is cached - probably a temp folder.  Just be aware that caching can drastically affect your test results.

Also, make sure that the testing is done from the outside and not from the inside connecting to the outside interface.

AHve your tried resetting the router to factory specs and re-configuring?

Another test I'd like to see done is to do the tesing without the Internet.  Try this using the DMZ feature also.

pc1---router----pc2

If this test yields horrible results, you need to call D-Link Support.
0
 
shy513Author Commented:
oh I like the idea of pc1---router---pc2
I will try what you suggest after work (yea, I cant try it now bcuz I am working) as soon as I try, I will tell you what I got. thanks
0
 
lmpsteelwireIT / Business AnalystCommented:
webpages like yahoo and EE are using high speed connections that are geared towards bandwidth. if you are ftping, you can only download at the absolute maximum of your friends UPLOAD speed. have you tried connecting to a professional ftp and downloading from there? by professional, i mean like a majors software companies ftp? there are a lot of anonymous ftps out there, give'em a try. or get a rich friend to buy faster internet :)
0
 
lmpsteelwireIT / Business AnalystCommented:
btw, most broadband upload speeds are significantly slower then their upload speed. so 6-8k/sec sounds about right if your downloading from your friends cable modem.  
0
 
lmpsteelwireIT / Business AnalystCommented:
btw, most broadband upload speeds are significantly slower then their DOWNLOAD speed. so 6-8k/sec sounds about right if your downloading from your friends cable modem.  
0
 
netspec01Commented:
If you test your router "in the lab" you'll take the Internet out of the equation.
0
 
shy513Author Commented:
sorry for late reply.
To lmpsteelwire:
The problem is for sure not my friend's upload speed limit, bcuz when I connect my cable modem directly to my computer, the upload goes up to 100-200 k/s. It goes down to 6-8k/s when I connect to the router.

To netspec01:
sorry, bcuz I am kinda busy, so I just tried to reset my router to the factory default, but it seems same as before. I haven't tried pc1---router---pc2, will try it today and tell you wut's the result.
Thanks
0
 
lmpsteelwireIT / Business AnalystCommented:
Well, i guess the act of forwarding packets to an internal ip isnt workin so great for you. your last choice is to set your computer to DMZ i guess?
0
 
shy513Author Commented:
To netspec01:
I just tried pc1---router---pc2, and the upload can go up to 2000k/s, so it's not the router problem, I think. So now, it seems not the router's problem nor the cable modem(isp)'s...
any more help is appreciated.
0
 
shy513Author Commented:
To lmpsteelwire:
DMZ...I really dont want to do that, I dont want all my ports open to the public, it's kinda danger
(p.s. I don't know if my understanding of DMZ is right or wrong, correct me if I am wrong,thx)
0
 
netspec01Commented:
> I just tried pc1---router---pc2, and the upload can go up to 2000k/s, so it's not the router problem, I think. So now, it seems >not the router's problem nor the cable modem(isp)'s...

SInce you have great throughput in the lab (assuming exactly the same setup except different WAN-side address), this eliminates the router and your ftp server PC setup.  The only conclusion left (however unlikely as Sherlock Holmes would say) is that it is your ISP or the Internet connection between the ftp client and the ftp server is limiting your bandwidth.

As a last try, maybe take your router to  friend's house that has a different ISP and try the throuput test there.
0
 
shy513Author Commented:
Thanks netspec01, I will try it later. But one thing I still don't understand is if it is ISP side's problem then how come without using the router the speed can be up to 200k/s...
0
 
lmpsteelwireIT / Business AnalystCommented:
using the dmz feature is the same as putting a computer directly on the internet, which millions of people do.  As long as you have all your windows updates, you'll probably be fine...if you download a firewall for that computer, you'll definitely be fine. dmz is nothing to fear
0
 
shy513Author Commented:
To lmpsteelwire:
I have tried DMZ, but no help to solve my problem (it makes sense, bcuz all I need is port 23 for ftp, isn't it?)
again, any suggestion that may help to my problem is appreciated. Thanks
0
 
netspec01Commented:
Were you able to FTP with it set up as a DMZ host?  What were the throughput test results?
0
 
shy513Author Commented:
I haven't tried it, I will test it later.
My problem seems hard to solve?
0
 
netspec01Commented:
FTP is TCP port 21
0
 
shy513Author Commented:
oh ftp is 21, telnet is 23, typing mistake...
0
 
Don JohnstonInstructorCommented:
No comment has been added to this question in more than 21 days, so it is now classified as abandoned. I will leave the following recommendation for this question in the Cleanup topic area:

PAQ - Refund points

Any objections should be posted here in the next 4 days. After that time, the question will be closed.

donjohnston
EE Cleanup Volunteer
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.