telnet to router, says "name"

When I telnet to a router, it gives me a prompt "name"

When I dial into the console  port, it works fine with the regular password prompt.  Why does it say name when I telnet to it?  the router is a 2610.
LVL 9
Pentrix2Asked:
Who is Participating?
 
lrmooreConnect With a Mentor Commented:
On the router that you are trying to telnet into...

This is an example config:
!
aaa new-model
aaa authentication login default group radius none
                                   ^^^
As long as this is "default", then you will be promted at a telnet
If it is not "default", then this authentication method can be applied to telnet, but not necessarily to console access

0
 
Dr-IPCommented:
Probably because you have a line in your config with "aaa new-model”. You could remove it if you don't need AAA accounting, or add the following line “aaa authentication login default line” if you don’t want to use user names.
0
 
lrmooreCommented:
AAA is enabled, but not applied to the console port.
0
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
Pentrix2Author Commented:
how do i check and how to turn it off?  Is it recommend to keep it or turn it off?
0
 
lrmooreCommented:
If it's part of your overall security strategy to use AAA, then leave it on.
It is highly recommended that you do use it.
To turn it off, simply use?
  no aaa new-model

0
 
Pentrix2Author Commented:
on the host router or the client router?  I don't see it in either places though.
0
 
Pentrix2Author Commented:
I do realize that part, but there's nothing in the running-config (the client side) with "aaa"
when I do telnet to it, it says:


name:
0
 
JFrederick29Commented:
Do you have "login local" configured on the VTY lines?  If so, use "no login local" and just type login.
0
 
Pentrix2Author Commented:
for vty 0 4
password xxxxxx
login
0
 
lrmooreCommented:
take out the "login"
  vty 0 4
    no login
 
Else, have you tried using "enable" as the user and the enable password?
0
 
Pentrix2Author Commented:
if i take out the vty 0 4, then i wouldn't be able to login through telnet?  because doesn't telnet use the vty 0 4?
0
 
lrmooreCommented:
You're not taking out the vty, just the "login" keyword under it...

0
 
Pentrix2Author Commented:
tried that already, and still says:


name:
0
 
Dr-IPCommented:
Add this line to the config and it should go away.

aaa authentication login default line

Example of commands needed below

config t
aaa authentication login default line
exit
wr
0
 
Pentrix2Author Commented:
I"m pretty sure I'm not using the security IOS, just the regular ip ios.  so the aaa authentication won't be valid.
0
 
Dr-IPCommented:
Why don’t you do a show run, and post the output with the passwords and IP address XXX out? Also post a copy of the show version too. With that we should be able to see what is going on.
0
 
illogikCommented:
Might seem stupid but are you sure you're telnetting to the right IP address?  I work with Netopia routers here and there and I know the initial prompt is simply "name".
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.