• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 12138
  • Last Modified:

I got this error when I install the Microsoft SQL Server Desktop Engine (MSDE)

Hi,
I have downloaded MSDE from microsoft
http://www.microsoft.com/downloads/details.aspx?FamilyID=a0dac778-60a6-4b11-8aa8-bf12261a303a&DisplayLang=en

I need to install the MSDE ( \sql2ksp3\MSDE) in my desktop (Win XP) I got this error and still can't solve

" A strong SA Password required for security reasons. Please use SAPWD switch to supply the same........."

This is frist time I install the MSDE in my Win XP, I tried the get a solution form Internet, but I still can't understand and can't solve it. Please help.

Can I just install the MSDE with SP3 in my desktop? I never install the previous version MSDE.


Cathy
0
kaifong78
Asked:
kaifong78
  • 3
  • 2
  • 2
  • +2
2 Solutions
 
jdlambert1Commented:
Execute from the command line:

Setup.exe sapwd="apa$$wordnOonewi!!everGUESS"
0
 
Brendt HessSenior DBACommented:
Try this:

When you go to execute the setup program, use Start/Run instead of clicking on the executable.  In the Open box, you can either browse to the executable, or drag the executable's icon to the box.  Either way, you will end up with something like:

C:\Downloads\SQL\sql2kdesksp3.exe

in the box.  Now, add on to the end of this:

SAPWD=<your_password_here>

Your password should have numbers and letters, and be something that you can remember.  For this example, I will use your EE username.  You would end up with:

C:\Downloads\SQL\sql2kdesksp3.exe SAPWD=kaifong78

Now, click OK, and the install should commence

0
 
kaifong78Author Commented:
Hi,

I still having a problem, I have done the above step

C:\Downloads\SQL\sql2kdesksp3.exe SAPWD=kaifong78  ---> my password is p@ssw0rd

after that in MSDE folder (D:\sql2ksp3\MSDE) I double cleck the Setup.exe  same error message for me ....
" A strong SA Password required for security reasons. Please use SAPWD switch to supply the same........."
 
What do you think? This time I have enter the password, stil unable to run it...

Please help!
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
kaifong78Author Commented:
when done this step C:\Downloads\SQL\sql2kdesksp3.exe SAPWD=kaifong78

I still need to run the setup.exe(double click) in the MSDE folder?
0
 
kaifong78Author Commented:
Hi,

I did try one more time, I have used this password 12qwaszx (number + letter) still have error...same error..

0
 
jdlambert1Commented:
What is your exact command, and how did you issue it?
0
 
stigmata53Commented:
Try putting entry in your D:\sql2ksp3\MSDE\setup.ini
 
should look like this:

[Options]
SAPWD=p@ssw0rd

0
 
coolerboyCommented:
0
 
Brendt HessSenior DBACommented:
Recommendation:
    Answer: stigmata53 (85)
    Assist: jdlambert1 (40)
0
 
stigmata53Commented:
I concur, it's abandoned & needs to be closed.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 3
  • 2
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now