Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

Mount SMB share on startup

Posted on 2004-10-09
7
1,513 Views
Last Modified: 2008-02-07
Hey folks,

      I'm fairly new to linux and I have a problem.  I'm running FC2 an two PCs, XP pro on 1, and 2000 on another.  I set up an SMB share on Linux1 and I can access it with XP1 and 20001.

      On linux2, if I use smb client I have read/write access but if I mount the smb share, I only have read/execute.  What's going on?

I would like to mount the smb share on start up with 777 permissions.

Thanks for your help,
TNC
0
Comment
Question by:tncbbthositg
7 Comments
 
LVL 8

Author Comment

by:tncbbthositg
ID: 12268346
Nevermind

I had to add dmask and fmask and it's working fine now (except that I cannot delete)

Please PAQ and refund

Thanks,
TNC
0
 
LVL 3

Expert Comment

by:TRobertson
ID: 12273328
//server/share    /mnt/dir   smbfs   auto,rw,username=user,password=xxx  0 0
0
 

Expert Comment

by:avtarsingh
ID: 12325969
Open your smb.conf file

under the share folder put this line

force directory mode = 777

Thanks,

Avtar
0
 
LVL 2

Expert Comment

by:garak1357
ID: 12374807
Don't forget to set the username/group and permissions on the directory to which you are mounting the share(s). Setting permissions in the smb.conf file is only half the story.
0
 

Accepted Solution

by:
CetusMOD earned 0 total points
ID: 16287471
PAQed with points refunded (125)

CetusMOD
Community Support Moderator
0

Featured Post

Portable, direct connect server access

The ATEN CV211 connects a laptop directly to any server allowing you instant access to perform data maintenance and local operations, for quick troubleshooting, updating, service and repair.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
I've attached the XLSM Excel spreadsheet I used in the video and also text files containing the macros used below. https://filedb.experts-exchange.com/incoming/2017/03_w12/1151775/Permutations.txt https://filedb.experts-exchange.com/incoming/201…

856 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question