Solved

Maxtor DiamondMAX 9 HD sector 0 broken or?

Posted on 2004-10-10
3
353 Views
Last Modified: 2008-02-01
I have an VERY suspicious "Partition Table" error(or something else)!

It all began when I tried to create an partition in Linux.
I have (had) an Windows NTFS formatted partition starting from sector 2.

This is the history:

When I installed Windows I wanted to create an "Primary" partition from sector 1 and 22Gb in size.

I thought that everything went correctly but afterwards in Win enviroment when I where about to delete another Win parition I saw that the "Primary" one (22Gb) wasn't an Primary it was an Extended with an Logical in it.
It caused some problem, I couldn't remove the other Win partition on (6Gb) because it was the active one.

The GUI forbidded me to remove it so I used the console instead, I marked the (22Gb) partition active instead and after that I could remove the (6Gb).
But now when I where about to close the Disk mangement tool it said something "Can't save .......".... I ignored it!

I rebooted the computer with my "Gentoo LiveCD" in the drivebay.

It booted successfully.

In Gentoo install enviroment I started the fdisk tool to create necessary partitions.
I typed something like this:

fdisk /dev/hda
>n
>p (for primary)
>1 (for the number)
> RETURN (default start sector)
And it didn't prompt for how big the partition should be, it should really do that but fdisk didn't!

After some identical tries to create the same partition I saw the problem.....

Because Win had crated an partition at sector 2 and forward Linux automaticly created the new Linux partition at sector 1 or 0 to 2!
And because it is only "1" sector between them then it wasn't necessary to ask for ending sector.

But okey... After an "slurk" coffe I understanded that it was meaningless to try to smass in an partition in the start of the drive.
So I created an new Linux primary partition and entered the start sector manually so it where placed one sector after the first partition.

Something like:

fdisk /dev/hda
>n  (New partition)
>p  (Primary)
>2259 (Start sector)
>+20000M (Ending sector)

And it went smoothly so I :

> w (Save table to disk "I think")

It wrote the partition table without errors,
when I wrote the table to disk I "hadn't" any filesystem mounted from that drive so I shouldn't need to restart the computer to get the new table to work. But when I tried the format the drive to ext3 then some errors about
"******.. :  {SeekRead ....}" I don't remember what it said clearly but something about Seek and read error..!

I rebooted the computer and now the kernel couldn't even get the partition table!
I tried to enter fdisk again (fdisk /dev/hda) but it complained about "Drive not ready..." "{Seek..}" etc.....

And with that long story you now know what the problem is, the disk seems to be dead but it isn't!

I have tried EVERYTHING!

I took the HD to an friend to test it in his computer but it was the same...

I have tested tools like "Maxtor low level formating (PowerMax)" and about 5 other disk mangemant tools.
One tool (R-Studio) was able to read the disk and recover some important files, but all other (even R-studio) complains about "Sector 0" is unreadable.

Please help me!
Iam out of ideas.......

I don't care about the data on the drive, the warranty isn't active longer.... the disk could be broken.. but I don't think so and I don't want to buy an new one as long this one could be working....


0
Comment
Question by:Nosferat0
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
3 Comments
 
LVL 31

Expert Comment

by:rid
ID: 12274471
The only thing I can think of in that situation is to run a "low-level format" or zero-fill several times, using a different character to "fill" with every time. If you're lucky, the problam may go away as the magnetic domains get som exercise... Otherwise the drive is useless.
/RID
0
 

Author Comment

by:Nosferat0
ID: 12274613
Hmm.. ok!

I forgot some revelant info!
When I used the "PowerMAX" utility I got an error code:  de95da6d  .
The application said that I should go to www.maxtor.com and do an RMA with the error code with it.
Because the warranty where out I couldn't do an RMA and there is no place on the net with this error code listed( I have searched tru google in hours.....)!

Someone who know what the code stands for?
0
 
LVL 13

Accepted Solution

by:
Dr-IP earned 125 total points
ID: 12288056
You might be able to find some trick tool that will make it work again, but it will probably only be a temporary solution. My experience with hard drives has taught me to get rid of them quick with they start having problems other than an occasional bad sector.

I suspect your hard drive had a head crash that has damaged the section of the disk where sector 0 is, and the damage was so bad the factory diagnostic software was unable to relocate it to an acceptable spare track. If I am right you now have microscopic trash all over the disk, which will continue to further damage the drive, eventually leaving it totally unusable.

Also contemplate this, if the software that Maxtor uses to determine what drives should be returned under warranty says the drives bad, it’s bad. Because Maxtor, or any other hard drive company doesn’t want to take back any more drives than they have to under warranty. So I think you can take it to the bank, it’s broken.      
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
PC will not stay shut down 56 155
How to complete an 'Apply Security' to a drive 25 121
Problem with Lenovo M73 Tiny with Dual Display 10 51
How to add a web site image to my desktop 15 45
Many people don't really know what the difference is between memory and storage. And most regular users don't understand the relationship between any of those fancy words printed on the front of their new computer. Of course, it's perfectly fine -- …
Windows 7 does not have the best desktop search built in. This is something Windows 7 users have struggled with. You type something in, and your search results don’t always match what you are looking for, or it doesn’t actually work at all. There ar…
Finds all prime numbers in a range requested and places them in a public primes() array. I've demostrated a template size of 30 (2 * 3 * 5) but larger templates can be built such 210  (2 * 3 * 5 * 7) or 2310  (2 * 3 * 5 * 7 * 11). The larger templa…
Finding and deleting duplicate (picture) files can be a time consuming task. My wife and I, our three kids and their families all share one dilemma: Managing our pictures. Between desktops, laptops, phones, tablets, and cameras; over the last decade…

710 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question