?
Solved

Samba wants guest passord

Posted on 2004-10-11
11
Medium Priority
?
969 Views
Last Modified: 2008-02-01
I have just set up a Samba server on a Fedora 2 box. When I try to access it from Windows XP Pro, it wants to attach to the Samba server by asking for a guest password.

I do not want it to use any passwords. This is just a "box in the corner" that must provide Windows like file access.

my sama config file looks like this after setting it up with the Samba GUI tools.
[global]
workgroup = office
server string = samba server
security = share
dns proxy = no
====share definitions
idmap uid = 16777216-33554431
idmap gid = 16777216-33554431
template shell = /bin/false
password server = none
guest ok = yes
winbind use default domain = no
[homes]
comment = home directories
browseable = no
writeable = yes
[accounts]
comment = Accpac Plus
path = /home/accounts
writeable = yes
public = yes
guest ok = yes

The main folder I want to share is one called accounts. Ther are some print parameters as well but I have left them out of this to make it brief.

Please assist.
0
Comment
Question by:Alex Angus
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 5
11 Comments
 
LVL 6

Accepted Solution

by:
blkline earned 2000 total points
ID: 12276086
To the global section add:

guest account = ftp
map to guest = Bad User

Replace "ftp" with whatever account you want as your guest account.
0
 

Author Comment

by:Alex Angus
ID: 12277882
tried this but still the same.
also changed to folder permission to the group but no change.
just rebooting and need to go out for 1hr or so.

thanks for help so far, any further suggestions?
0
 

Author Comment

by:Alex Angus
ID: 12279799
Have changed values of Forceguest and Limitblankpassword in registry and still no change. Still insists on guest (greyed out) login and password, which is unknown.

0
DFW AZURE MEETUP TONIGHT FRI 6PM

We will be discussing what Azure Stack is, how does it fit into the suit of offerings that Azure has currently, and where can it fit into your organizations technology stack. We will also be discussing limitations of the platform while covering various applicable scenarios.

 

Author Comment

by:Alex Angus
ID: 12280245
Tried it with user level login and it works.
Just added the user alex to the accounts group and added to the samba users. Then changed folder properties access from "allow access to everyone" to user alex.
Left the smb config file as it was.
So this must eliminate some questions.
Now, how to change it to allow anybody access?
If this does not work I will create users for everyone, but would like to avoid this.
0
 
LVL 6

Expert Comment

by:blkline
ID: 12280576
Unfortunately, that's not really what you want to do.   I'm not sure why this isn't working for you.  I already have one machine that functions exactly as you wish:

[global]
        workgroup = TEST
        netbios name = LAPTOP2
        server string = Samba Server
        security = SHARE
        update encrypted = Yes
        log file = /tmp/log.%m
        max log size = 50
        socket options = TCP_NODELAY
        dns proxy = No
        guest account = admn
        map to guest = bad user
        wins server = 192.168.1.243
                                                                                                                   
[gui]
        comment = GUI programs
        path = /win/gui
        read only = Yes
        guest ok = Yes

All you've done is make the client authenticate to the server, which is fine, but as you have already figured out it will require you to add every user.  Is this machine authenticating to an NT or Win2K server or is this a strictly peer network?

0
 

Author Comment

by:Alex Angus
ID: 12280838
Hi,
This is the one and only server.
From my original question you can see my smb config. I think it is basically same as yours except for the WINS, DNS and NETBIOS stuff.
Yea, there is no security risk here, so want a completely open system. I have a RH 7.3 from 2 years ago that works like that and it basically has the same setup.

Have been through the Samba tutorial on the Samba site as well. That indicates basically what you and I have.

Seems like with Samba no two systems would have the same config file. Maybe some day someone will build a diagnostic and config toolkit to take the guesswork out of it. One hour to load FD2 and 3 days to get Samba half working does not seem like a viable solution. Already costing more than a Windows server solution. If I throw away my time and get a Linux expert in it also costs more than the Windows solution. So I think by tomorrow I will suggest that to the client. I surpose another solution is to find RH 7.3, but that may not work on this box. I have the patience but at this point I am starting to pay the client to take this box.

Sorry, thinking aloud here about the business decisions.
0
 
LVL 6

Expert Comment

by:blkline
ID: 12280927
What's the client OS?
0
 
LVL 6

Expert Comment

by:blkline
ID: 12281043
I've looked over your config again, try this:

in the global section, ensure that you have:

security = user
encrypt passwords = yes

To your share add:

force user = root
force group = root

What we want to do is have a valid smb user that Samba can move its user to.  

If these changes doesn't work then let's try with a fresh SMB.conf file, removing the excess cruft from your file and specifying  exactly what you want.  Start with the config that I gave you (substituting the guest account name) and, if necessary, add the things I just mentioned.  Should it fail, change "security = SHARE" to "security = user" and restart samba.
0
 
LVL 6

Expert Comment

by:blkline
ID: 12281277
I just set up a new Samba server to test this out.  My final smb.conf is:

[global]
        workgroup = TEST
        netbios name = SNAPSHOT
        server string = Samba Server
        security = user
        update encrypted = Yes
        log file = /var/log/samba/log.%m
        max log size = 50
        socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
        guest account = baduser
        map to guest = bad user
 
[tmp]
        comment = temporary space
        path = /tmp/tmp
        guest ok = yes
        force user = root
        force group = root
        read only = no

I created "baduser" as:

     useradd -d /dev/null -s /sbin/nologin baduser

That was it!  
0
 

Author Comment

by:Alex Angus
ID: 12283999
Hi blkline,

Thanks for your help so far.

I have decided this: I will install the server today (it is 7am Tuesday here) on a user level security. I need to get the client up and running because their previous "server" (Windows 98 PC - hehe, can't believe what people have) has finally called it a day. This is a new client for me, so I also need to give them good support.

Then I am going to some clients 500km away for the rest of the week. When I get back I will set up another PC and load FD2 again and spend some quality time learning more about the system. Linux and Samba that is. There is also that Samba tutorial that I will go through again in more detail. After my exams (Delphi) on 28th I will be able to spend more time on this as well. I cannot accept that this can get me down when there is such excellent support and many patient people to help on the web. So I must get on top of this by month end. Then I will go and change this at the client.

In the meantime, they will be up and running and will be happy.

So many thanks for your help and patience and I hope we can be in contact later on again.
0
 

Author Comment

by:Alex Angus
ID: 12379700
Managed to get 1 user logged on to Samba. Copied some folders over and that went ok but when I look at them there are no sub folders.
So added
create mode = 0777
directory mode = 0777

When I connect the second user, the first one cannot access again and the second user has no write rights.

Tested a spare system with RH7.3 and that seems to work fine. So why does FD2 not work?
0

Featured Post

On Demand Webinar: Networking for the Cloud Era

Did you know SD-WANs can improve network connectivity? Check out this webinar to learn how an SD-WAN simplified, one-click tool can help you migrate and manage data in the cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Using 'screen' for session sharing, The Simple Edition Step 1: user starts session with command: screen Step 2: other user (logged in with same user account) connects with command: screen -x Done. Both users are connected to the same CLI sessio…
Join Greg Farro and Ethan Banks from Packet Pushers (http://packetpushers.net/podcast/podcasts/pq-show-93-smart-network-monitoring-paessler-sponsored/) and Greg Ross from Paessler (https://www.paessler.com/prtg) for a discussion about smart network …
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial
Suggested Courses
Course of the Month13 days, 1 hour left to enroll

777 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question