Solved

Help I have a slow server with the STORE.exe running at 99%

Posted on 2004-10-11
7
350 Views
Last Modified: 2008-02-01
I upgraded the exchange server to SP3 (SBS 2000) yesterday, was working well last night.  It had been dismounting the store frequently before this.

This morning every thing was slow to access eventually managed to get a terminal session and saw that the process STORE.EXE is running at 99%

Tried to restart the exchangh services but now the information store is stuck at stopping and the store have been dismounted.

Not in a good position to reboot at the moment

What can I do!!!
0
Comment
Question by:jimcrint
  • 4
  • 2
7 Comments
 
LVL 57

Accepted Solution

by:
Pete Long earned 500 total points
ID: 12280666
Hi jimcrint,
Why is Exchange Store.exe so RAM hungry?
http://blogs.msdn.com/exchange/archive/2004/08/02/206012.aspx

XADM: Store.exe Uses a Higher Percentage of Your CPU Resources Than You Expect
http://support.microsoft.com/default.aspx?scid=kb;en-us;821411

XADM: A Memory Leak in Store.exe Degrades Performance
http://support.microsoft.com/default.aspx?scid=kb;en-us;q322125

Cheers!
0
 
LVL 1

Author Comment

by:jimcrint
ID: 12280806
There is a Post sp3 rollup that includes the fix for this as per your second link.  I am currently downloading it and will post back with the result
0
 
LVL 1

Author Comment

by:jimcrint
ID: 12282453
Installed the SP3 rollupa nd have now just restarted the computer and the STORE.EXE is still running at over 90%
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 
LVL 104

Expert Comment

by:Sembee
ID: 12282743
How large is your database?
Anything of interest in the queues?

Simon.
0
 
LVL 1

Author Comment

by:jimcrint
ID: 12283098
It has just gone from bad to worse.

Uninstalled the rollup patch in safe mode then rebooted and reinstalled the SP3 but this failed something about Base DAV.  On restart I have multiple DCOM errors and no services like iis or exchange are starting
0
 
LVL 1

Author Comment

by:jimcrint
ID: 12284902
Thanks for the help.  Lost the sys vol, had to restore system backup.

recreated the exchange stores and problem went away, restore from back up and there is a new problem
0
 
LVL 57

Expert Comment

by:Pete Long
ID: 12288576
ThanQ
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This process describes the steps required to Import and Export data from and to .pst files using Exchange 2010. We can use these steps to export data from a user to a .pst file, import data back to the same or a different user, or even import data t…
This article aims to explain the working of CircularLogArchiver. This tool was designed to solve the buildup of log file in cases where systems do not support circular logging or where circular logging is not enabled
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…
This video shows how to quickly and easily add an email signature for all users on Exchange 2016. The resulting signature is applied on a server level by Exchange Online. The email signature template has been downloaded from: www.mail-signatures…

830 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question