Dll Register Server in xxxx.dll failed. Unable to register Dlls

I am trying to install Intervideo DVDCreator and at the end of installation, I receive an error message :"Self Registration Error.  One or more files did not self-register"  It then lists the files and "Class not registered". I have also tried installation in safe mode with no change.

So I thought I could manually register them.  So I copied the dll files to the c:\windows\system32 directory and then ran from the command line in the system32 directory:  regsvr32.exe filename.dll.

Each time, the error: "DLL Register Server in filename.dll failed.  Return code was 0x80040154.

The same return code is given with each different file that I attemp to register.

Can anyone suggest what I can do?  The software vendor cannot help me.

I am running XP Pro.
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Any further info in the event log?

sgarson1Author Commented:
These Event Viewer entries ocurred around the time.

The COM+ Event System detected a bad return code during its internal processing.  HRESULT was 8007043C from line 44 of d:\nt_qxp\com\com1x\src\events\tier1\eventsystemobj.cpp.  Please contact Microsoft Product Support Services to report this error.

Volume Shadow Copy Service error: Unexpected error calling routine CoCreateInstance.  hr = 0x80040206.

Windows cannot unload your classes registry file - it is still in use by other applications or services. The file will be unloaded when it is no longer in use.  

Steve..... try creating a new user account with Administrative rights, and login with it, now try to install ur product there to check for the problem ??
Protecting & Securing Your Critical Data

Considering 93 percent of companies file for bankruptcy within 12 months of a disaster that blocked access to their data for 10 days or more, planning for the worst is just smart business. Learn how Acronis Backup integrates security at every stage

sgarson1Author Commented:
Tried to reinstall under a new admin rights account.  No difference.  

I think the event viewer messages are not relevant to my problem.

Anyone else with ideas?

sgarson1Author Commented:
Just reviewed the Event Viewer log after cleaing it and then attempting the reinstall.  There are no events to indicate anything, even though the error message :"Self Registration Error.  One or more files did not self-register"  Appears.   It then lists the files and "Class not registered".
only this particular product has problems.... or others also suffer from the same error ??
sgarson1Author Commented:
Only this product.  Everything else works perfectly
which version of DirectX are u using.... and having a Nvidia video card ??
and do u have XP SP1 with all the windows updates ??
sgarson1Author Commented:
Direct x 9.0, SP1 with all updates,
I have read on Intervideo DVD Creator website, that they require DirectX Runtime Libraries..... not sure if its related to ur problem or not.... but here u can download and install them >> http://www.microsoft.com/downloads/details.aspx?FamilyID=1d97f320-9dfd-4e7a-b947-3a037ccf84af&displaylang=en

Btw have u tried to install DVD Creator on another system with this CD to make sure that its in a good state :)
sgarson1Author Commented:
I did as you suggested to no avail.  Last night I installed the software on another computer and it went fine.  But that this my business machine and the computer with the installation headaches is what I expected to be the video computer - faster, more ram, faster disk, etc.
hmmmmm i was researching on this Class Not Registered errors..... and some cases were strange ones !!
70% of people facing this problem were suffering from an invalid codec entry or registry entry.... so before i start digging into this issue...... can u tell me if u have installed any other DVD player on the mahcine and ur DVDs are working fine ??

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
This is a major RESET of the dshow database and you may want to consider it if
all else fails.  (if you do it, set a manual restore point first)

After that, reinstall your version of WMP.
windows media player 9

Or if you have wmp 10

In general, reinstalling WMP over itself is like a repair, and will recreate all the relevant
registry entries.  You'll have to uninstall/reinstall all your codec-related software,
such as divx, dvd players, mpg encoders, etc,etc.
sgarson1Author Commented:
I've decided to give up and install this software on another machine.  It works fine and I just can't spend the time any more.

Thanks to everyone for your input on this problem.

It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows XP

From novice to tech pro — start learning today.