Solved

Zone Alarm Pro and Remote Desktop

Posted on 2004-10-11
15
3,559 Views
Last Modified: 2010-05-18
Hello,

I recently installed Zone Alarm Pro and now I cannot get Windows XP Remote Desktop to work. When I try to connect to my laptop with remote desktop, Zone Alarm doesn't  even detect the incoming connection, it just ignores it.

I tried opening up the port 3389 in Zone Alarm, but that hasn't worked.

Does anyone have any suggestions as to how to fix my problem?

Thanks,
Bill
0
Comment
Question by:Cornellian
  • 5
  • 4
  • 4
  • +1
15 Comments
 
LVL 49

Expert Comment

by:sunray_2003
ID: 12283047
Bill,

Turning off Zonealarm , can you get remote desktop working ?

Make sure the inbuilt firewall in windows xp is NOT turned ON aswell ..

Is your computer directly connected through cable modem or through a router ?

Also check if this would help
http://members.cox.net/ajarvi/RemoteDesktop/Multiple_PC_RD.html

Do this aswell

How to change the listening port for Remote Desktop
http://support.microsoft.com/default.aspx?scid=kb;EN-US;q306759

SR
0
 
LVL 6

Expert Comment

by:parkerig
ID: 12283093
Terminal Services ( Remote Desktop ) is a service.

I am assuming that Zone Alarm is on the machine that you are trying to connect to ( you mentioned it didn't see incoming calls )

Goto Control Panel Services
With Zone Alarm  running find the Terminal Services ( remote desktop service ) and restart.
Zone Alarm should detect it and prompt you.

I always restart all of may services at least once like this after I install or update Zone Alarm.

Cheers
Ian
0
 

Author Comment

by:Cornellian
ID: 12283288
I cannot restart terminal services. It is started, but it doesn't allow me to start, stop, or restart it.

And to answer above, Remote Desktop worked perfectly before, it works when I shutdown Zone Alarm, no the Windows firewall is not running, and yes I am behind a router that forwards port 3389 to my static IP.

Thanks,
Bill
0
Comprehensive Backup Solutions for Microsoft

Acronis protects the complete Microsoft technology stack: Windows Server, Windows PC, laptop and Surface data; Microsoft business applications; Microsoft Hyper-V; Azure VMs; Microsoft Windows Server 2016; Microsoft Exchange 2016 and SQL Server 2016.

 
LVL 49

Expert Comment

by:sunray_2003
ID: 12283318
Is opening port 3389 in Zonealarm , the only thing you have done in it for remote desktop to work ?

When you try to connect from a different machine , have you given like this

<ipaddress>:3389

SR
0
 
LVL 6

Expert Comment

by:parkerig
ID: 12283353
If you can not restart then chances are you are not a local administrator.
Log on as a local Administrator and so as above.

Cheers
Ian
0
 

Author Comment

by:Cornellian
ID: 12283366
I am not on the Administrator account, but the account I am using is part of the administrator accounts
0
 

Author Comment

by:Cornellian
ID: 12283372
No I haven't tried ipaddress:3389, but I am 100% sure the default port is 3389, my router is only forwarding that port and the MS support site says the default port is 3389.

Yes, the only thing I have tried is opening port 3389 is zonealarm.

Thanks,
Bill
0
 
LVL 49

Expert Comment

by:sunray_2003
ID: 12283391
Try that ipadress:3389 to connect to the machine and see if that would wokr.
You are right about port 3389.. I was just suggesting you to try that ipaddress:3389

SR
0
 
LVL 49

Expert Comment

by:sunray_2003
ID: 12283413
Bill,

Also in your zonelarm , see if you have done this
open Zonealarm
In the left, you would see "program control". Click on it
Now you would see list of programs displayed . In that check if you see Remote desktop connection. If you see then, on the right of it , if you see ?, just click on it and press the green tick mark. Do for all the ?s there. See if that would help

SR
0
 
LVL 6

Expert Comment

by:parkerig
ID: 12283468
Bill,

I have just tried the below to confirm it works. One or other should work.

Go start run C:\Windows\System32\svchost -k DComLaunch     ( Terminal Services executeable path as per services entry ) As terminal services already running may not work but Zone Alarm should still pop up ( my equivalent did )

or if this doesn't work then

Start services.msc
Go to terminal services service ( note if manual or automatic )
Disable it
Reboot
Change back to auto / manual
Press play to start

Cheers
Ian
0
 

Author Comment

by:Cornellian
ID: 12283825
The service is allowed access to the internet in zonealarm.

I checked the log, and here is the line that shows the blocking of the remote desktop

FWIN,2004/10/12,00:13:20 -4:00 GMT,67.20.246.57:1796,192.168.1.100:3389,TCP (flags:S)

Ian, I tried your steps, but it didn't work. The service, svchost.exe, is already in zonealarm, and nothing popped up.

Thanks,
Bill
0
 
LVL 6

Expert Comment

by:parkerig
ID: 12284514
Bill,
I am on my home machine now trying to replicate.
Firstly can you run remote desktop from the local machine ( ie the one with Zone Alarm on)

If you can then chances are Zone Alarm Network is blocking the application not Zone Alarm Programmes. The fact that C:\WINDOWS\System32\svchost.exe is already enabled also points to this.

Check the Zone Alarm network settings and see if you are trusting the local subnet.

Also what version of XP ( ie sp1 or SP2 ) if running SP2 then it could be ICF that is stopping the connection not Zone Alarm.

Check control panel networking to see if enabled / disabled.

Let us know how you go

Cheers
Ian
0
 
LVL 8

Accepted Solution

by:
amirinamdar earned 500 total points
ID: 12290902
Hi Bill,
I had the same problem connecting to my work pc from my laptop. Both my laptop and my work PC have Zone Alarm Pro installed. I realized, while I was having this problem, that I was also unable to ping the work PC. Then, one fine day, I did this:
1] On my work PC, to which I wanted to connect using Remote Desktop on my laptop, I added my laptop name to the trusted
zone.
2] Importantly, I changed the firewall setting in both my trusted and and internet zone to the 'med' level.
3] I also made the necessary changes for remote desktop in my ZA program list, on both the computers.
I was able to ping my work pc then and was also able to connect to it using the remote desktop on my laptop. incidentally, i realised that ZA mentions that in the 'med' zone, other computers can see my computer but cannot share it's resources. so that means that though i am able to access my work pc with remote desktop, nobody else is able to sneak into my computer, which is why ZA is for. In the 'stealth' level settings, my work pc was hidden from all computers on the network and so i was neither able to ping it nor able to connect to it with remote desktop.

I guess, this same procedure should work for you.
Good luck!
Cheers!
Amir
0
 

Author Comment

by:Cornellian
ID: 12294454
Amir,

Thank you very much for your help.

I did was change both settings (trusted and internet zone) to the med level. This has fixed the problem.

Thanks,
Bill
0
 
LVL 8

Expert Comment

by:amirinamdar
ID: 12295225
Hi Cornellian,
Glad to be or help, and, thanks for the grade.
:-)
Amir
0

Featured Post

Active Directory Webinar

We all know we need to protect and secure our privileges, but where to start? Join Experts Exchange and ManageEngine on Tuesday, April 11, 2017 10:00 AM PDT to learn how to track and secure privileged users in Active Directory.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Burning ISO Win/Mac 21 60
Software for IT quotations, invoices, delivery orders 2 56
Transferring files to iPhone 3 72
internet fax? 7 18
I previously wrote an article addressing the use of UBCD4WIN and SARDU. All are great, but I have always been an advocate of SARDU. Recently it was suggested that I go back and take a look at Easy2Boot in comparison.
This article describes how to use the timestamp of existing data in a database to allow Tableau to calculate the prior work day instead of relying on case statements or if statements to calculate the days of the week.
This video demonstrates how to use each tool, their shortcuts, where and when to use them, and how to use the keyboard to improve workflow.
An overview on how to enroll an hourly employee into the employee database and how to give them access into the clock in terminal.

827 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question