Solved

Mouse pointer disappears in Windows games

Posted on 2004-10-12
10
1,064 Views
Last Modified: 2013-12-29
This problem has some most of the fun of gaming on my PC.
After the game has started the mouse pointer disappears. When the mouse is moved it is visible (although stightly flikkering) to disappear again when the mouse stops. Moreover, when the image (e.g. map, instructions, whatever) on the screen is scrolled parts of the screen are incorrectly drawn. It's almost as if a block, a rectangle slightly larger than the mouse cursor, is pasted at the wrong spot of the screen.

I have no mouse problems in "normal" widows. Do you have some suggestions?

Mouse: Logitech M-C48 (that's a wheelmouse with wire)
Mouse connected to PS/2 port
Windows 98 SE
DirectX version 9.0
P4 1.7 GHz
40 Gb HD
512 Mb RAM
0
Comment
Question by:asciiman
10 Comments
 
LVL 8

Expert Comment

by:qfren
ID: 12284917
hi:

try to reinstall the VGA driver witht he latest one.
or maybe the game require u to make some config ?


mc
0
 
LVL 38

Expert Comment

by:BillDL
ID: 12285092
Do you by any chance have Tweak UI installed?  If so, check your settings for the mouse in there.  It is possible that animations applied to your mouse from the Control Panel's "Mouse" applet might be causing this behaviour, ei. leaving a trail behind it that cannot be interpreted by the game screen, but is OK in Windows.

Could also be related to the screen refresh rate if the above is true and the refresh rate is changed to allow games to play.

Turn off Pointer Trails under the "Motion" tab, and optionally try creating a new "scheme" for your pointers using different cursor pointers.

Perhaps the cursor isn't disappearing, maybe it's just blending into the background.

Does the game itself have any user options that allow you to tailor the mouse actions to suit?

You've got the same spec pc as the one I'm sitting at, except that I have stuck to DirectX 8.1 because of stability problems.  I am not a gaming person, otherwise I could have tested out a few settings to see what results.
0
 
LVL 8

Expert Comment

by:ddrdan
ID: 12285308
Can you give us the name of the game?
0
 

Author Comment

by:asciiman
ID: 12285584
gfren: VGA drivers, do you mean the display drivers? No, I don't think it's a setting in the games itself, since it happens in nearly every game.

BillDL: No I haven't got it installed. Erm. Well, in windows the refresh rate is optimal and accelleration is set to full. Hope that helps.
Pointer Trails are off, I never had them on since they are utterly annoying. I already thried a lot of other mouse cursor schemes, no change.
Blending in the background? I doubt it; even on an opaque, coloured background the cursor isn't visible.
Most games don't have any options regarding the mouse. Simcity has a choice between transparent and opaque cursors, but either setting has that problem.

ddrdan: Simcity 4, F1 Challenge '99-'02, Collin Mcrae 04, SkyCaptain (www.skycaptain.com), Fifa 2004, etc. etc. etc.

One stupefying detail: Command & Conquer: the tiberian sun, does NOT have the problem.

In advance, I thanks for your help
0
 

Author Comment

by:asciiman
ID: 12285612
Oh, nearly forgot to mention, I've got a LG Studioworks 570 LS monitor (LCD) connected to an ASUS AGP-V7700 Pro Deluxe SDRAM v12.90
0
Integrate social media with email signatures

Is your company active on social media? Do you also use email signatures? Including social media icons in your email signature is a great way to get fans for free. Let all your email users know you’re on social media quickly and easily, in a single click.

 
LVL 38

Assisted Solution

by:BillDL
BillDL earned 50 total points
ID: 12285981
I'm afraid that I am stumped by this one then, asciiman, but by the look of it you and I aren't the only ones:

http://forums.thatcomputerguy.us/index.php?showtopic=6661

Now, although this answer to a similar question seems a bit strange at first glance, the questioner found it to be the resolution to the problem:

http://www.cybertechhelp.com/forums/showthread.php?p=271178&mode=threaded

"You need to go into your desktop properties then settings I think you will find you have 2 monitors enabled so your pointer will go off screen to the right because it thinks there is another monitor there".

Although the following advice relates to games in DOS, it still hints at the "Single Screen" setting notion, and might be more related to similar problems in 32-bit mode than first appears.

http://www.ati.com/support/infobase/372.html
0
 
LVL 3

Accepted Solution

by:
Squew01 earned 250 total points
ID: 12291527
It's a common problem with Hardware-accelered mouse cursors. To resolve it, disable Hardware Cursors in the settings of your games.
I think it's resolved with newer version of directx, but I'am not sure and it's maybe because of Windows98...

/squew/
0
 

Author Comment

by:asciiman
ID: 12297662
Squew: There is no "Hardware cursors" setting in any of my games (And I doubt if it ever did). To my knowledge, I'm running the latest version if directX (9.0c).

You were right about the hardware acceleration, though. If I set the performance setting (Control Panel->Display->Settings->Advanced...->Performance) from 'Full' (setting 4) all the way back to 'Basic' (setting 2) the problem is gone. Setting it to 'Most' (setting 3) is not sufficent; even though the explantion text sepcifically states that the 'Most' setting is to resolve mouse problems (GRUMBL!!!).

Only drawback is that Simcity is complaining that it cannot initiate DirectDraw. Besides that it works fine though.
0
 

Author Comment

by:asciiman
ID: 12297692
Ok. Points time... the 250 points go to Squew. I've awarded BillDL with another 50 points for a great effort. :)
0
 
LVL 38

Expert Comment

by:BillDL
ID: 12300699
Thank you, asciiman:

DirectDraw and Direct3D Settings.  These DirectX registry settings allow you to change some of the DirectDraw and Direct3D video acceleration parameters.  Maybe by systematically changing the settings from enable to disable for each in turn, you might find a setting that allows full control while resolving the cursor issue.

SOME of these settings MAY be available from your graphics card's extended advanced options, but I am NOT sure about this.  If you are like me you begin to forget which permutations you have tried in your graphics cards advanced options by the time you get to the 3rd change, and this might make it easier to track the changes you made :-)

PERSONALLY?  I WOULDN'T RISK MESSING ABOUT WITH DIRECT DRAW SETTINGS LIKE THIS BECAUSE MY COMPUTER RUNS FINE FOR WHAT I NEED IT TO DO.

THE RISK IS UP TO YOU IF YOU WISH TO TRY THIS.

Firstly I suggest that you make a backup of the registry key that this will change settings in.

Create a new folder C:\DDBACK

Start menu > RUN > and type REGEDIT > click "OK".

Plough down through the + signs in the LEFT pane to find the key:
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DirectDraw]

Click on the "DirectDraw" key and then use the menu options as follows:

Registry > Export Registry File > Browse to the C:\DDBACK folder.

Type in a short filename name like DDBAK and ensure that the "Save As Type" field shows *.REG.

Ensure that the "Range" is set to export "Selected Branch Only".

Click "Save" and this will create a file C:\DDBACK\DDBAK.REG.  This is your backup from which you would be able to reinstate the settings currently set in your registry.

Now make a copy of that file, and rename it something like "DDNEW.REG".  This is the one that you will change the settings in using NotePad.

RIGHT-Click the "DDNEW.REG" file, and select "Edit".  It should open in NotePad. and look something like the following extract:

REGEDIT4

[HKEY_LOCAL_MACHINE\Software\Microsoft\DirectDraw]

[HKEY_LOCAL_MACHINE\Software\Microsoft\DirectDraw\Compatibility]

[HKEY_LOCAL_MACHINE\Software\Microsoft\DirectDraw\Compatibility\ScorchedPlanet]
"Name"="SPLANETW.EXE"
"ID"=hex:69,04,4c,32
"Flags"=hex:02,00,00,00

[HKEY_LOCAL_MACHINE\Software\Microsoft\DirectDraw\Compatibility\NHLPowerPlay]
"Name"="PP96.EXE"
"ID"=hex:ff,3f,bf,31
"Flags"=hex:01,00,00,00

There MAY be some individual entries under the top key
[HKEY_LOCAL_MACHINE\..\..\DirectDraw]

If so, retain these, but delete everything below it that falls under sub-keys of DirectDraw, eg. [..\..\..\Compatibility].

Now save the file.

What you are now going to do is modify any existing values IF they are already in your "DDNEW.REG" file, or create new ones and set the values.  The value names that will be modified or created are shown below, with a description of what the setting does shown after each:

DisableAGPSupport - Disable AGP support
DisableMMX - Disable MMX processor extensions
DisableWiderSurfaces - Disable Wider Surfaces support
DisableInactivate - Disable dual-head video card debugging
EnablePrintScreen - Enable Print Screen capture
ModeXOnly - Use Mode-X for older video cards
ShowFrameRate - Display the frame rate (if supported)
DisableNoSysLock - Disable long-duration locks on video memory
ForceNoSysLock - Force use of long-duration locks on video memory
EmulationOnly - Enable software emulation for older cards (** SEE NOTE)

** NOTE **
If you enable the "EmulationOnly" setting, then the value of the named setting "DisableDP2" in the registry key
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Direct3D]
would have to be changed to "1" to disable Direct3D, or "0" to enable it.

ALSO

The value of the named setting "SoftwareOnly" in the key
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Direct3D\Drivers]
would have to be changed to "1" to use software emulation or "0" to disable it.

So, here's what you should type into NotePad, and how it should look after you are finished.  Note, this is your blank canvas with nothing yet disabled:

REGEDIT4

[HKEY_LOCAL_MACHINE\Software\Microsoft\DirectDraw]
"DisableAGPSupport"=dword:00000000
"DisableMMX"=dword:00000000
"DisableWiderSurfaces"=dword:00000000
"DisableInactivate"=dword:00000000
"EnablePrintScreen"=dword:00000001
"ModeXOnly"=dword:00000000
"ShowFrameRate"=dword:00000001
"DisableNoSysLock"=dword:00000000
"ForceNoSysLock"=dword:00000001
"EmulationOnly"=dword:00000000  

[HKEY_LOCAL_MACHINE\Software\Microsoft\Direct3D]
"DisableDP2"=dword:00000000

[HKEY_LOCAL_MACHINE\Software\Microsoft\Direct3D\Drivers]
"SoftwareOnly"=dword:00000000

Now, by modifying each of the dword:00000000 to dword:00000001 or vice-versa, you can enable or disable that particular feature.  Remember the related settings in the last 2 keys for the "EmulationOnly" item.

To MERGE the data from this new .reg file after saving it in NotePad, just double-click on it OR RIGHT-Click > "Merge".

The bind here is that you usually have to reboot to have the changed settings take effect.

IF, by some horrible event, one of the changed settings prevented your system from booting into Windows, you could always reinstate the settings by pressing F8 repeatedly as the system starts to boot, selecting the boot option "Command Prompt" or "Safe Mode" from the boot menu, and then running REGEDIT to restore the original settings.

IF NONE of those "dword" settings existed in your originally exported "DDBAK.REG" file under the key
[HKEY_LOCAL_MACHINE\Software\Microsoft\DirectDraw]
then the following .REG file would delete them all.

Note that "merging" data into the registry does NOT delete entries already in the registry (unless the following method is used), but it WILL create entries not already there, and modify the values set against existing items.

REGEDIT4

[HKEY_LOCAL_MACHINE\Software\Microsoft\DirectDraw]
"DisableAGPSupport"=-
"DisableMMX"=-
"DisableWiderSurfaces"=-
"DisableInactivate"=-
"EnablePrintScreen"=-
"ModeXOnly"=-
"ShowFrameRate"=-
"DisableNoSysLock"=-
"ForceNoSysLock"=-
"EmulationOnly"=-

To merge data from a .REG file from DOS, first change to your C:\Windows directory, and then run the following command which assumes that you saved the above as "C:\DDBACK\RESETDD.REG"

regedit  /s  c:\ddback\resetdd.reg

So, there you have it.  As I said, it MIGHT be risky, but with backups and prior knowledge of recovery methods, maybe you might like to try this.

Bill
0

Featured Post

Integrate social media with email signatures

Is your company active on social media? Do you also use email signatures? Including social media icons in your email signature is a great way to get fans for free. Let all your email users know you’re on social media quickly and easily, in a single click.

Join & Write a Comment

NTFS file system has been developed by Microsoft that is widely used by Windows NT operating system and its advanced versions. It is the mostly used over FAT file system as it provides superior features like reliability, security, storage, efficienc…
If you get continual lockouts after changing your Active Directory password, there are several possible reasons.  Two of the most common are using other devices to access your email and stored passwords in the credential manager of windows.
Windows 8 comes with a dramatically different user interface known as Metro. Notably missing from the new interface is a Start button and Start Menu. Many users do not like it, much preferring the interface of earlier versions — Windows 7, Windows X…
The viewer will learn how to successfully create a multiboot device using the SARDU utility on Windows 7. Start the SARDU utility: Change the image directory to wherever you store your ISOs, this will prevent you from having 2 copies of an ISO wit…

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

22 Experts available now in Live!

Get 1:1 Help Now