Solved

sending mails thorough CDONTS / ASP

Posted on 2004-10-12
28
779 Views
Last Modified: 2011-09-20
hi experts,

I have two pages namely support.html and eemailprocess.asp . Below is the code of these two files


------------------------------------------------support.html-----------------------------------------------
<html>
<body>
<form method="POST" action="eemailprocess.asp">
<p>
 <input type="hidden" name="rcpt" size="20" value="support@mydomain"></p>
  <p>E-mail address:<input type="text" name="mailfrom" size="20"></p>
<p>Subject:<input type="text" name="subject" size="20"></p>
  <p>Message:</p><textarea rows="5" name="data" cols="33"></textarea></p>
  <p><input type="submit" value="Submit" name="B1"><input type="reset" value="Reset" name="B2"></p>
</form>
</body>
</html>
-----------------------------------------end of support.html-----------------------------------------------------



------------------------------------------------eemailprocess.asp-----------------------------------------------
<%
Dim objCDO
Set objCDO = Server.CreateObject("CDONTS.NewMail")
objCDO.To = request.form("rcpt")
objCDO.bcc = request.form("rcpt")
objCDO.From = request.form("mailfrom")
objCDO.Subject = request.form("subject")
objCDO.Body = request.form("data")
objCDO.MailFormat = 0
objCDO.BodyFormat =0
objCDO.Send
      response.write "email sent" & "<br>"
%>
----------------------------------------------End of eemailprocess.asp-----------------------------------------------
when a user submits the form it's not processed hence it returns

+++++++++++++++error code+++++++++++++++++
HTTP 500.100 - Internal Server Error - ASP error
Internet Information Services

--------------------------------------------------------------------------------

Technical Information (for support personnel)

Error Type:
Server object, ASP 0177 (0x800401F3)
Invalid ProgID. For additional information specific to this message please visit the Microsoft Online Support site located at: http://www.microsoft.com/contentredirect.asp.
/em/eemailprocess.asp, line 3


Browser Type:
Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Page:
POST 115 bytes to /em/eemailprocess.asp

POST Data:
rcpt=support@najam-njm.com&mailfrom=testing@testing.com&subject=testing+a+feedback+form&data=test+message&B1=Submit

----end of error-------



I am using a cable internet(have a local IP address I.E 10.10.x.x) running windows 2000 with IIS 5.0 (mspclnt installed)
internet is shared by the server 10.10.1.1 thorough MS ISA configured in proxy and firewall mode.
can somebody help me how to solve this problem?
btw, I would be running it on my local pc so my local area users could be able to surf it within a network and send mails regarding their comments and suggestions.

Thanks in advance
0
Comment
Question by:imnajam
  • 15
  • 6
  • 5
  • +1
28 Comments
 
LVL 11

Accepted Solution

by:
mouatts earned 300 total points
ID: 12285113
It looks to me as though either CDONTS isn't installed or possibilt that you don't have the SMTP server installed. The Invalid prog id error means that it cannot locate the CDONTS dll.

Try searching your registry for CDONTS if you don't find it then it isn't installed.

HTH
Steve
0
 
LVL 9

Author Comment

by:imnajam
ID: 12288655
Hello mouatts

you were right to say that SMPT was not installed I just installed it and now it say "mail sent" but the mail is not received
why:s

thanks in advance
0
 
LVL 11

Expert Comment

by:mouatts
ID: 12288798
You will need to allow SMTP traffic out of your machine (assuming that you have a firewall blocking things) and you may need to alter the configuration of the server it's self. I have to say I thought from memory that it worked 'out of the box'.

You can also check the log file to see what is going wrong (system32/logfiles/SMTPSVC1).

If you are only using this for test purposes it is actually easier if the smtp is stopped then you can examine the emails 'sent' by checking the drop folder (inetpub/mailroot/drop).


Steve
0
 
LVL 2

Expert Comment

by:Aggieangler
ID: 12289870
Is your server actually going to be sending the mail, or do you need to relay through an exchange/domino etc server your ISP provides? You may need to set up the SMTP relay fields in SMTP Service under the IIS console. Most of the time, people overlook this step. It may not apply to you though.
0
 
LVL 2

Expert Comment

by:eWizard
ID: 12359882
Also its worth checking to see if you have valid DNS servers setup in your network connections. If you are connecting via an ISP then the DNS servers are probably dynamically assigned but its worth a check. Without valid DNS servers your emails won't be going anywhere!

Regards
0
 
LVL 9

Author Comment

by:imnajam
ID: 12442189
I am using a shared interenet connection don't have any public IP for dns like 203.x.x.x or something can I send  mail from localhost without having any public IP or DNS
0
 
LVL 11

Expert Comment

by:mouatts
ID: 12442428
So long as the SMTP server can get to DNS (and if you can surf from that machine then SMTP can get to DNS) then that should be enough.
So far as the server settings are concerned use the following

General Tab
--------------
Enable logging

Access Tab - Authentication
--------------------------------
Turn anonymous,basic and Windows Security package on

Access Tab - Connection
----------------------------
Add the IP address of your machine and select Only Those Listed below

Access Tab - Relay Relay
------------------------------
Add your IP address again

When entering you IP address it is the local IP address that your Web Server is running at so if you are using LocalHost only then use 127.0.0.1.

Restart the SMTP server and try sending a message.
If it doesn't work check the log file (normally created in WINNT/System32/Logfiles/Smtpsvc1) and post back the log file entries (but try to restrict it to just a single message).

HTH
Steve




0
 
LVL 9

Author Comment

by:imnajam
ID: 12450568
hello mouatts,

I configured my SMTP as per your instruction but I see that the log file is not generating when I am using my pages to email. than I tried to telnet localhost 25 and run (hello,mail from,rcpt to, data,.) commands and it says message queued for delivery(not delivered) the log file is as follows:-

#Software: Microsoft Internet Information Services 5.0
#Version: 1.0
#Date: 2001-10-31 20:10:50
#Fields: time c-ip cs-method cs-uri-stem sc-status
20:10:50 127.0.0.1 HELO - 250
20:10:54 127.0.0.1 MAIL - 250
20:11:00 127.0.0.1 RCPT - 250
20:11:17 127.0.0.1 DATA - 250
20:11:35 127.0.0.1 QUIT - 240

what to do next?
0
 
LVL 9

Author Comment

by:imnajam
ID: 12450584
in my "C:\Inetpub\mailroot\Badmail" folder I see 6 files (2 .bdr , 2.bdp and 2.bad) these are generated when I tries to send 2 mails.

here are the names of files with respective data
\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\
002364421203110200100000037.BAD
\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\
From: postmaster@homepc142.home.local
To: emailnajam@yahoo.com
Date: Thu, 1 Nov 2001 01:21:42 +0500
MIME-Version: 1.0
Content-Type: multipart/report; report-type=delivery-status;
      boundary="9B095B5ADSN=_01C1624865F6D2500000006Dhomepc142.fari"
Message-ID: <SA1XvpFVj00000037@homepc142.home.local>
Subject: Delivery Status Notification (Failure)

This is a MIME-formatted message.  
Portions of this message may be unreadable without a MIME-capable mail program.

--9B095B5ADSN=_01C1624865F6D2500000006Dhomepc142.fari
Content-Type: text/plain; charset=unicode-1-1-utf-7

This is an automatically generated Delivery Status Notification.

Delivery to the following recipients failed.

       emailnajam@gmail.com




--9B095B5ADSN=_01C1624865F6D2500000006Dhomepc142.fari
Content-Type: message/delivery-status

Reporting-MTA: dns;homepc142.home.local
Received-From-MTA: dns;homepc142.home.local
Arrival-Date: Thu, 1 Nov 2001 01:21:39 +0500

Final-Recipient: rfc822;emailnajam@gmail.com
Action: failed
Status: 5.0.0

--9B095B5ADSN=_01C1624865F6D2500000006Dhomepc142.fari
Content-Type: message/rfc822

Received: from mail pickup service by homepc142.home.local with Microsoft SMTPSVC;
       Thu, 1 Nov 2001 01:21:39 +0500
From: "NJM" <emailnajam@yahoo.com>
To: <emailnajam@gmail.com>
Subject: testing a feedback form
Date: Thu, 1 Nov 2001 01:21:39 +0500
MIME-Version: 1.0
Content-Type: multipart/alternative;
      boundary="----=_NextPart_000_0074_01C16273.8E89A130"
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1106
Message-ID: <homePC142X3cf3edn0000001e@homepc142.home.local>
X-OriginalArrivalTime: 31 Oct 2001 20:21:39.0754 (UTC) FILETIME=[A5D6D8A0:01C16249]

This is a multi-part message in MIME format.

------=_NextPart_000_0074_01C16273.8E89A130
Content-Type: text/plain;
      charset="iso-8859-1"
Content-Transfer-Encoding: 7bit

testing if it sent or not

------=_NextPart_000_0074_01C16273.8E89A130
Content-Type: text/html;
      charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

testing if it sent or not
------=_NextPart_000_0074_01C16273.8E89A130--


--9B095B5ADSN=_01C1624865F6D2500000006Dhomepc142.fari--

\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\



\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\
002364421203110200100000037.BDP
\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\
vCMM   `   vGPT°              ÿÿÿÿvLPTl  d      \      P  vMPTÿÿÿÿè              €  :~›`ÉѪ^ ÀO£[‚c:\inetpub\mailroot\Queue\NTFS_a757f88001c1624900000056.EML ÿÿ8]vPFSÿÿÿÿ`   N   P    0  ¸        (  Ð          '  Ü        0  à          ä        #  ü  $   $   "     -   0      ð  '   (   !                      $          ,          4          <          D          ´          X          \          `          h          p          x          €          ˆ                                                                                          :~›`ÉѪ^ ÀO£[‚c:\inetpub\mailrVersion: 5.0.2195.6713 0homePC142    <>  emailnajam@yahoo.com hoopostmaster@homepc142.home.local <SA1XvpFVj00000037@homepc142.home.local> aho   Ÿ          å  
   þÿÿÿvPFSÿÿÿÿ    Ð  ÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿ                                            vRPTÿÿÿÿˆ             ÿÿÿÿemailnajam@yahoo.com yahoo.com .Delivery Status Notification (Failure)  r  p¢U§IbÁp‚Š<®bÁp")üÛcÁp‚Š<®bÁp")üÛcÁ   ÿÿÿÿè              €  45184f5cda9aeaa4088c5714bc6dd57200.00000019.eml vPFSÿÿÿÿ`   0   0     ˜  N   P    0  è        2  ì                   "  $        +  @        #  X        !  p  N   P   1  À       
  Ü  
               è  
       &  ô          '           (             8        )  <  7   8      t  =   @   /  ´          X          \          `          h          p          x          €          ˆ                                                                                          :~›`ÉѪ^ ÀO£[‚c:\inetpub\mailroot\Queue\NTFS_ddbd32b001c162480000003c.EML ÿÿ      emailnajam@yahoo.com    "NJM" <emailnajam@yahoo.com>    smtp:emailnajam@yahoo.com   <emailnajam@gmail.com>  testing a feedback form multipart/alternative;
      boundary="----=_NextPart_000_0060_01C16272.C66CFDF0"   homepc142.home.local    127.0.0.1   127.0.0.1   homePC142
\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\


\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\
002364421203110200100000037.BDR
\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\
Unable to deliver this message because the follow error was encountered: "This message is a delivery status notification that cannot be delivered.".

The specific error code was 0xC00402C7.


The message sender was <>.


The message was intended for the following recipients.
      emailnajam@yahoo.com
\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\
0
 
LVL 9

Author Comment

by:imnajam
ID: 12450588
I am increasing the points to 400
0
 
LVL 11

Expert Comment

by:mouatts
ID: 12450901
Ok well the good news is that the 5 messages that you got in the log file is what you would expect when an email has been sent.

Just to make double sure that they are ok can you go back into the SMTP Server settings and click the properties button for logging and turned on all the extended logging parameters and repeat your test and post back the log file entries generated.

Also try turning off the SMTP server and repeating you test again. This will create a file in the queue directory. Open this and check that it does have the correct to address in it.

One of the possibilities is that your ISP is blocking the message but the log file entires should give us a clue if this is the case.

Also if you are running a firewall make sure that port 110 is open for outbound traffic.

Steve
0
 
LVL 2

Expert Comment

by:eWizard
ID: 12451322
Make sure that the objCDO.From is a valid email address. I have had an issue where the mail does not get sent if the FROM address is not valid.

Give it a go

Ian.C
0
 
LVL 9

Author Comment

by:imnajam
ID: 12451425
objCDO.from is a valid address
mouatts,can you tell me how can I check if port 110 is open for outbound traffic ? actually I told you that I am using a shared internet access and yes I am behind the ISA server/firewall just tell me how to check if pot 110 is open for outbound traffic or not I will do the test will inform you about this.

okay now come to the other thing i.e logging it was w3c extended logging or something {I have a question at this point, why I can't see SMTP service in the internet information service :-s where it was before I configured it from there but now I don't have it I didn't have it previously either but at that time I just removed smtp and reinstalled and it appears there} but what do I do..
0
Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

 
LVL 9

Author Comment

by:imnajam
ID: 12455862
I wonder sending mail from my page several time (I have checked all the extended properties in logging) but whenever I try to email thorough my page using CDONT it doesn't create any log file in "smtpsvc1" folder! only creates .bad .bdr and .bdp files.
active loggin is checked and in active log format "W3C Extended Log File Format" is selected
0
 
LVL 11

Expert Comment

by:mouatts
ID: 12456205
So far as checking if port 110 is open it may be possible from the log file (that you haven't got) otherwise you need to contact your ISP as ask them.

The log files is cached to some extent, it the output doesn't appear immediately. Try restarting the server to see what if that flushes it.
0
 
LVL 9

Author Comment

by:imnajam
ID: 12456558
I have tried not only restarting the service also restarting computer aswell as changed the new log time period to "When log file reaches 10 MB" and again restarting service aswell as computer but to no avail.........
I noticed that whenever I connect thorough telnet localhost 25 it creates or appends the log file but when I use my asp to send mail it doesn't log anything.!!!
0
 
LVL 2

Assisted Solution

by:eWizard
eWizard earned 100 total points
ID: 12456694
Here's the ASP I use in our website.

Private Sub SendEmail(SendTo, BCC, ReplyTo, Subject, Body, Page)

'      on error resume next
      
      Dim myMail, oConf, Flds
      Set myMail = Server.CreateObject("CDO.Message")
      
      'Use CDO Config so it can use merak Mail server
      Set oConf = Server.CreateObject("CDO.Configuration")
      Set Flds = oConf.Fields
      With Flds
            .Item(cdoSendUsingMethod) = cdoSendUsingPort
            .Item(cdoSMTPServer) = "127.0.0.1" '***** CHANGE SMTP SERVER HERE
            .Item(cdoSMTPServerPort) = 25
            .Item(cdoSMTPconnectiontimeout) = 10
      .Update
      End With

      Set myMail.Configuration = oConf
            myMail.From = ReplyTo
            myMail.To = SendTo
            myMail.Bcc = BCC
            myMail.Subject = Subject
            myMail.ReplyTo = ReplyTo
            myMail.HTMLBody = Body
            myMail.Send
      Set myMail = Nothing
End Sub

Give it a go. I don't use the CDONTS.
0
 
LVL 9

Author Comment

by:imnajam
ID: 12456744
I changed the above code to the one listed below but its not working even giving me an error

Error Type:
ADODB.Fields (0x800A0CC1)
Item cannot be found in the collection corresponding to the requested name or ordinal.
/em/ee.asp, line 13


<%
'Private Sub SendEmail(SendTo, BCC, ReplyTo, Subject, Body, Page)

'     on error resume next
     
     Dim myMail, oConf, Flds
     Set myMail = Server.CreateObject("CDO.Message")
     
     'Use CDO Config so it can use merak Mail server
     Set oConf = Server.CreateObject("CDO.Configuration")
     Set Flds = oConf.Fields
     With Flds
          .Item(cdoSendUsingMethod) = cdoSendUsingPort
          .Item(cdoSMTPServer) = "127.0.0.1"
        .Item(cdoSMTPServerPort) = 25
          .Item(cdoSMTPconnectiontimeout) = 1
     .Update
     End With

     Set myMail.Configuration = oConf
          myMail.From = request.form("mailfrom")
          myMail.To = request.form("rcpt")
          myMail.Subject = request.form("subject")
          myMail.HTMLBody = request.form("data")
          myMail.Send
      response.write "mail sent"
     Set myMail = Nothing
'End Sub
%>

I didn't changed the 127.0.0.1 as I want to email from my localhost
0
 
LVL 9

Author Comment

by:imnajam
ID: 12456763

HTTP 500.100 - Internal Server Error - ASP error
Internet Information Services

error
0
 
LVL 2

Expert Comment

by:eWizard
ID: 12456800
Put the following code at the top of the page:

<!--METADATA TYPE="typelib" UUID="CD000000-8B95-11D1-82DB-00C04FB1625D" NAME="CDO for Windows Library" -->

Regards

Ian C
0
 
LVL 9

Author Comment

by:imnajam
ID: 12456855
I did as you suggest and now it says mail sent but it's not received in my yahoo account...!!!

also I notice that the the log file is generated and appended when I posts!!

belows is the log file
_---------------------


#Software: Microsoft Internet Information Services 5.0
#Version: 1.0
#Date: 2004-10-31 02:25:14
#Fields: date time c-ip cs-username s-sitename s-computername s-ip s-port cs-method cs-uri-stem cs-uri-query sc-status sc-win32-status sc-bytes cs-bytes time-taken cs-version cs-host cs(User-Agent) cs(Cookie) cs(Referer)
2004-10-31 02:25:14 127.0.0.1 homepc142 SMTPSVC1 homePC142 127.0.0.1 0 HELO - +homepc142 250 0 48 16 20 SMTP - - - -
2004-10-31 02:25:14 127.0.0.1 homepc142 SMTPSVC1 homePC142 127.0.0.1 0 MAIL - +FROM:+<emailnajam@yahoo.com> 250 0 45 33 170 SMTP - - - -
2004-10-31 02:25:14 127.0.0.1 homepc142 SMTPSVC1 homePC142 127.0.0.1 0 RCPT - +TO:+<achadoost@hotmail.com> 250 0 34 32 10 SMTP - - - -
2004-10-31 02:25:14 127.0.0.1 homepc142 SMTPSVC1 homePC142 127.0.0.1 0 DATA - +<000001c4bef0$db18a370$29130a0a@home.local> 250 0 129 871 171 SMTP - - - -
2004-10-31 02:25:14 127.0.0.1 homepc142 SMTPSVC1 homePC142 127.0.0.1 0 QUIT - homepc142 240 401 73 4 0 SMTP - - - -

does it help?
0
 
LVL 9

Author Comment

by:imnajam
ID: 12456886
another thing I noticed is that no more .bad .bdp or .bdr files are created
0
 
LVL 2

Expert Comment

by:eWizard
ID: 12457410
Stop the SMTP service, run your ASP code and see if a file is created in your pickup directory. If it is, start your SMTP service again and see if the file disappears.

Regards

Ian C
0
 
LVL 9

Author Comment

by:imnajam
ID: 12460735
when I stop and run that asp code, it gives me the following error and nothing in pickup folder I just start the service and refresh the page and it says mail sent..!!



\\\\\\\\\\\\\\\\\
The page cannot be displayed
There is a problem with the page you are trying to reach and it cannot be displayed.

--------------------------------------------------------------------------------

Please try the following:

Click the Refresh button, or try again later.

Open the localhost home page, and then look for links to the information you want.
HTTP 500.100 - Internal Server Error - ASP error
Internet Information Services

--------------------------------------------------------------------------------

Technical Information (for support personnel)

Error Type:
CDO.Message.1 (0x80040213)
The transport failed to connect to the server.
/em/ee.asp, line 26


Browser Type:
Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Page:
POST 100 bytes to /em/ee.asp

POST Data:
noofem=10&rcpt=emailnajam@yahoo.com&mailfrom=testing@testing.com&subject=testing&data=test&B1=Submit

Time:
Thursday, November 01, 2001, 12:16:23 AM


More information:
Microsoft Support
 
\\\\\\\\\\\\\\\\\\\
0
 
LVL 11

Expert Comment

by:mouatts
ID: 12471594
Firstly I suggest that you revert back to your original code. Using CDO needs, I beleive and exchange server in place to send messages, but either way you where closer to getting it to work before.

Looking at the log file that you posted it is not getting out of you system but is trying to connect to you again, ie the client and server ip addresses are the same (127.0.0.1), which they shouldn't be. The Client IP (c-ip) should be that of the destination server (ie hotmail).

Now the settings that I gave you are taken from one of my SMTP servers that does work. The big difference is that I am not using local host (also know as the loop back address which might be the clue to what is going on). I might be an idea if you could set the server (SMTP and HTTP) up to use an address other than this. If you don't have a network card on the machine try using the IP address that you ISP has assigned you (even if it is dynamic) just to see if this will resolve the problem.

HTH
Steve
0
 
LVL 9

Author Comment

by:imnajam
ID: 12612322
mouatts I reverted back to original code but I am still unable to email from my pc let me explain you my network a bit

server-this is the main computer connected to internet having two ips one public 203.x.x.x another local 10.x.x.x and running windows 2000 server sharing internet thorough ISA server
client-this is my computer connected to the server by using proxy and firewall client having one NIC and the address of 10.x.x.x
I thought that I should be using a smarthost for the purpose but I read the article and configured accordingly but to no avail the mails are in queue folders but not sent.
I am really tired and thinking if it is possible or not :-s

0
 
LVL 9

Author Comment

by:imnajam
ID: 12744054
Thank you all for your interest in helping me and giving your comments.
Grade 'C' is because the problem is not solved!
0

Featured Post

What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

I would like to start this tip/trick by saying Thank You, to all who said that this could not be done, as it forced me to make sure that it could be accomplished. :) To start, I want to make sure everyone understands the importance of utilizing p…
Have you ever needed to get an ASP script to wait for a while? I have, just to let something else happen. Or in my case, to allow other stuff to happen while I was murdering my MySQL database with an update. The Original Issue This was written…
Excel styles will make formatting consistent and let you apply and change formatting faster. In this tutorial, you'll learn how to use Excel's built-in styles, how to modify styles, and how to create your own. You'll also learn how to use your custo…
When you create an app prototype with Adobe XD, you can insert system screens -- sharing or Control Center, for example -- with just a few clicks. This video shows you how. You can take the full course on Experts Exchange at http://bit.ly/XDcourse.

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

23 Experts available now in Live!

Get 1:1 Help Now