vb 6 '' could not be loaded

Posted on 2004-10-12
Last Modified: 2007-12-19
I have a vb6 active x control that I created months ago.  I use it in a program.  It compiles fine, and up until a couple of days ago it worked fine.  Now when I try to open my project it says '' could not be loaded.  When I look in the error log for the form the component is used for, it says: Line 15: Class ScaleControl.ctlScale of control ctlScale1 was not a loaded control class.  Even if I open a new project and try to add it as a component it says that same message, '' could not be loaded.  Has anyone else seen this?
Question by:Fraser_Admin
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
  • 2
LVL 19

Accepted Solution

RanjeetRain earned 500 total points
ID: 12286862
Look into the registry and try to locate its location from the ProgID. Check if your control OCX is still there. THere is a chance it got deleted.

Author Comment

ID: 12287411
I tried to unregister and re-register.  Does not work.  I can bring it in as a component on another machine fine.  So it is something to do with my machine, and I'm as well guessing the registry.

I have very minimal experience with the registry.  Can you explain how I go about this?  What is the ProgID and how do I locate it?

Author Comment

ID: 12288220
Finally got it to work.  I searched for the name of my control and deleted the entry for it.
Optimize your web performance

What's in the eBook?
- Full list of reasons for poor performance
- Ultimate measures to speed things up
- Primary web monitoring types
- KPIs you should be monitoring in order to increase your ROI

LVL 19

Expert Comment

ID: 12288371
Glad zou got it to work.

Expert Comment

ID: 25221322
In addition, if you created the control, you could open up the controls vbp file on it's own and recompile the project (it must be on it's own and without being part of a vbg project group else it might not work). Close down the vbp file and open the group; you should have some more success without having to go into the registry which is not for everyone.

If the control is not your own then you have no choice but to use the registry method.

Expert Comment

ID: 25221324
There is also a Microsoft help file on the subject...

Featured Post

On Demand Webinar - Networking for the Cloud Era

This webinar discusses:
-Common barriers companies experience when moving to the cloud
-How SD-WAN changes the way we look at networks
-Best practices customers should employ moving forward with cloud migration
-What happens behind the scenes of SteelConnect’s one-click button

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Whether you've completed a degree in computer sciences or you're a self-taught programmer, writing your first lines of code in the real world is always a challenge. Here are some of the most common pitfalls for new programmers.
In this post we will learn how to connect and configure Android Device (Smartphone etc.) with Android Studio. After that we will run a simple Hello World Program.
An introduction to basic programming syntax in Java by creating a simple program. Viewers can follow the tutorial as they create their first class in Java. Definitions and explanations about each element are given to help prepare viewers for future …
Viewers will learn how to properly install Eclipse with the necessary JDK, and will take a look at an introductory Java program. Download Eclipse installation zip file: Extract files from zip file: Download and install JDK 8: Open Eclipse and …

623 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question