Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Choice of C/C++ API toolkit

Posted on 2004-10-12
8
Medium Priority
?
381 Views
Last Modified: 2013-12-18
i am developing a Add-in for lotus notes.Please suggest me which C and C++ API toolkit is compatible for Lotus Notes version 5.0.11 and later ( all version of Lotus notes 6 )
0
Comment
Question by:Mayuresh_04
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
8 Comments
 
LVL 31

Expert Comment

by:qwaletee
ID: 12290589
The 5.0.7 C toolkit was the last released for R5.  Anything compiled with it will work in R5.0.11 or later and R6 or later.  Not sure about C++.
0
 

Author Comment

by:Mayuresh_04
ID: 12294951
If i use 6.0.2 C API then will it work on R5 ?
0
 
LVL 19

Expert Comment

by:RanjeetRain
ID: 12298932
Why not? It will of course.
0
 
LVL 19

Expert Comment

by:RanjeetRain
ID: 12299041
See this:

A C API program running under Notes Release 5 or later can access databases on a server running Lotus Domino 6.0.2. The databases on the Lotus Domino 6.0.2 server can have either the Domino Release 5 or the Domino 6 format.

A C API program running under Domino or Notes 6.0.2 can access databases on a server running Lotus Domino Release 5 or later.

NOTE: When you use Notes Release 5 or later to access a Lotus Domino 6 database, you must perform that access through a Lotus Domino 6 release or later 6.x release. Do not copy a Lotus Domino 6 database directly to a machine running Lotus Domino or Notes Release 5. The Lotus Domino Release 5 software will not be able to read this database.


http://www-12.lotus.com/ldd/doc/tools/c/6.0.2/api60ug.nsf/85255d56004d2bfd85255b1800631684/001b00f900a500e885255e2d0079221e?OpenDocument

0
 
LVL 31

Accepted Solution

by:
qwaletee earned 500 total points
ID: 12709964
Just a note... Ranjeet's comemnts are misleading for your purpose.  I think what you are really asking is will an executable compiled woth the R6 API, be able to run on a box that has R5 installed.

I would not count on it.  It might, it might not.  Depends on what compile options you used, and what parts of teh API you accessed.
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

  In today’s Arena we can’t imagine our lives without Internet as we are highly used to of it. If we consider our life style just for only 2 min we found that face to face communication is swapped by e-communication.  Every Where from Works place to…
Article by: Rob
Notes 8.5 Archiving Steps and Tips This article covers setting up a Notes archive, and helps understand some of the menu choices making setting up and maintaining a Notes archive file easier.
In this brief tutorial Pawel from AdRem Software explains how you can quickly find out which services are running on your network, or what are the IP addresses of servers responsible for each service. Software used is freeware NetCrunch Tools (https…
In this video you will find out how to export Office 365 mailboxes using the built in eDiscovery tool. Bear in mind that although this method might be useful in some cases, using PST files as Office 365 backup is troublesome in a long run (more on t…
Suggested Courses

715 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question