Solved

Cisco 1721 with 2 T1 wics bounces second serial connection

Posted on 2004-10-12
14
606 Views
Last Modified: 2010-08-05
With 2 1721 routers in remote locations connected via point to point dedicated T1's.  Using one T1 as a backup if needed but both are always (should be) connected.
According to ATT the lines are good, according to Cisco TAC the configurations should work, however, when I connect the second T1 to the second wic the line is up and the protocol is up for about 15 seconds.  Then the line stays up but the protocol goes to down and stays down.  

Any suggestions I have all the config info just let me know what you would like to look at.  

These lines have been out of service for apx 4 weeks or longer, having just started at this firm I would like to repair this quickly.
0
Comment
Question by:riciit
  • 5
  • 4
  • 3
  • +2
14 Comments
 
LVL 43

Expert Comment

by:JFrederick29
ID: 12291014
Both interfaces are not shutdown right?  Encapsulation matches on both ends?  IP addresses are in same subnet?

It would help immensely if you could post both routers configurations, edit out passwords.
0
 
LVL 13

Expert Comment

by:Dr-IP
ID: 12291048
First thing I’d do is put a hard loop up locally towards that interface on the routers, set the protocol to HDLC if it isn’t set to that, and see if it stays up, or not. Also you could try switching the T1’s on both routers and see if the issue moves with the T1, or stays with the interface, but depending on your situation this may be too disruptive.
0
 
LVL 13

Expert Comment

by:Dr-IP
ID: 12291185
By the way, I get told all the time by telephone companies that their lines are good, and end up proving them wrong. The only problem is, you have to go through the steps to make sure your equipment isn’t at fault, before giving the riot act.  
0
 
LVL 11

Expert Comment

by:PennGwyn
ID: 12292007
This sounds like an encapsulation or clocking issue.  Let's see the configs....
0
 
LVL 1

Author Comment

by:riciit
ID: 12292585
Here are the two router config files output is from 'sh tech' command and should give all the needed information.

sh tech

------------------ show version ------------------

Cisco Internetwork Operating System Software
IOS (tm) C1700 Software (C1700-IPBASE-M), Version 12.3(6b), RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2004 by cisco Systems, Inc.
Compiled Thu 20-May-04 00:20 by dchih
Image text-base: 0x80008120, data-base: 0x80C73B38

ROM: System Bootstrap, Version 12.2(7r)XM2, RELEASE SOFTWARE (fc1)

uptime is 4 days, 15 hours, 3 minutes
System returned to ROM by power-on
System restarted at 09:28:03 UTC Thu Oct 7 2004
System image file is "flash:c1700-ipbase-mz.123-6b.bin"

cisco 1721 (MPC860P) processor (revision 0x400) with 55597K/9939K bytes of memory.
Processor board ID FOC08201NT6 (1558521062), with hardware revision 0000
MPC860P processor: part number 5, mask 2
Bridging software.
X.25 software, Version 3.0.0.
1 FastEthernet/IEEE 802.3 interface(s)
2 Serial network interface(s)
WIC T1-DSU
32K bytes of non-volatile configuration memory.
32768K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102


------------------ show running-config ------------------


Building configuration...

Current configuration : 1247 bytes
!
! Last configuration change at 10:17:03 UTC Thu Oct 7 2004
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ***###**
boot-start-marker
boot-end-marker
!
enable secret 5 <removed>
enable password <removed>
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
no aaa new-model
ip subnet-zero
no ip cef
!
!
!
no ftp-server write-enable
!
!
!
!
interface FastEthernet0

 ip address 10.10.10.10  255.255.0.0
 speed auto
 full-duplex
!
interface Serial0
 description Point to point dedicated line
 ip unnumbered FastEthernet0
 fair-queue
!
interface Serial1
 description Point to point dedicated line
 ip unnumbered FastEthernet0
 encapsulation ppp
!
router eigrp 1
 network 10.0.0.0
 auto-summary
 no eigrp log-neighbor-changes
!
no ip classless
ip route 0.0.0.0 0.0.0.0 10.10.15.250
ip route 0.0.0.0 0.0.0.0 10.10.0.0
ip route 0.0.0.0 0.0.0.0 10.10.15.252
no ip http server
!
snmp-server community <removed> RO
snmp-server community <removed> RO
snmp-server enable traps snmp authentication
snmp-server enable traps tty
!
line con 0
line aux 0
line vty 0 4
 password <removed>
 login
!
!
end


------------------ show stacks ------------------


Minimum process stacks:
 Free/Size   Name
 5420/6000   CEF process
 5576/6000   CPE MMI SNMP
11208/12000  Router Init
 9232/12000  Init
 5728/6000   CEF Scanner
 5456/6000   RADIUS INITCONFIG
 9352/12000  Exec
10460/12000  Virtual Exec

Interrupt level stacks:
Level    Called Unused/Size  Name
  3           0   9000/9000  PA Management Int Handler
  4    23199540   8356/9000  Network interfaces
  5           0   9000/9000  Timebase Reference Interrupt
  6       12472   8880/9000  16552 Con/Aux Interrupt
  7    99951429   8920/9000  MPC860P TIMER INTERRUPT

------------------ show interfaces ------------------


FastEthernet0 is up, line protocol is up
  Hardware is PQUICC_FEC, address is 0011.20c2.1830 (bia 0011.20c2.1830)
  Description:
  Internet address is 10.10.10.10/16
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, 100BaseTX/FX
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 1/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 66000 bits/sec, 64 packets/sec
  5 minute output rate 265000 bits/sec, 97 packets/sec
     4792382 packets input, 801545114 bytes
     Received 142083 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog
     0 input packets with dribble condition detected
     6590418 packets output, 2816554818 bytes, 0 underruns
     0 output errors, 0 collisions, 3 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
Serial0 is up, line protocol is up
  Hardware is PQUICC with Fractional T1 CSU/DSU
  Description: Point to point dedicated line
  Interface is unnumbered. Using address of FastEthernet0 (10.10.10.10)
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
     reliability 255/255, txload 9/255, rxload 42/255
  Encapsulation HDLC, loopback not set
  Keepalive set (10 sec)
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/22/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 1158 kilobits/sec
  5 minute input rate 259000 bits/sec, 97 packets/sec
  5 minute output rate 59000 bits/sec, 63 packets/sec
     6562459 packets input, 2747805057 bytes, 0 no buffer
     Received 42319 broadcasts, 0 runts, 0 giants, 0 throttles
     198 input errors, 144 CRC, 54 frame, 0 overrun, 0 ignored, 0 abort
     4766833 packets output, 747114535 bytes, 0 underruns
     0 output errors, 0 collisions, 1228 interface resets
     0 output buffer failures, 0 output buffers swapped out
     3 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

Serial1 is up, line protocol is down
  Hardware is PQUICC with Fractional T1 CSU/DSU
  Description: Point to point dedicated line
  Interface is unnumbered. Using address of FastEthernet0 (10.10.10.10)
  MTU 1500 bytes, BW 1536 Kbit, DLY 20000 usec,
     reliability 252/255, txload 1/255, rxload 1/255
  Encapsulation PPP, LCP REQsent, loopback not set
  Last input 00:00:01, output 00:00:01, output hang never
  Last clearing of "show interface" counters 4d14h
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/1/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 1152 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     83812 packets input, 6756200 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     13641 input errors, 216 CRC, 13051 frame, 0 overrun, 0 ignored, 374 abort
     71767 packets output, 1004738 bytes, 0 underruns
     0 output errors, 0 collisions, 20405 interface resets
     0 output buffer failures, 0 output buffers swapped out
     3 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up


-----------------------------------------------------------------------
****************************************************************************
here is the other
*************************************************************************
----------------------------------------------------------------------
sh tech

------------------ show version ------------------

Cisco Internetwork Operating System Software
IOS (tm) C1700 Software (C1700-Y-M), Version 12.2(4)YA2, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)
Synched to technology version 12.2(5.4)T
TAC Support: http://www.cisco.com/tac
Copyright (c) 1986-2002 by cisco Systems, Inc.
Compiled Thu 11-Apr-02 21:54 by ealyon
Image text-base: 0x80008124, data-base: 0x807976DC

ROM: System Bootstrap, Version 12.2(7r)XM1, RELEASE SOFTWARE (fc1)
ROM: C1700 Software (C1700-Y-M), Version 12.2(4)YA2, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)

McM-Remote3 uptime is 3 days, 6 hours, 21 minutes
System returned to ROM by power-on
System image file is "flash:c1700-y-mz.122-4.YA2.bin"

cisco 1721 (MPC860P) processor (revision 0x100) with 29492K/3276K bytes of memory.
Processor board ID FOC072120JE (3049692628), with hardware revision 0000
MPC860P processor: part number 5, mask 2
Bridging software.
X.25 software, Version 3.0.0.
1 FastEthernet/IEEE 802.3 interface(s)
2 Serial network interface(s)
WIC T1-DSU
32K bytes of non-volatile configuration memory.
16384K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102


------------------ show running-config ------------------


Building configuration...

Current configuration : 1135 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Remote3
!
enable secret 5 <removed>
enable password 7 <removed>
!
ip subnet-zero
!
!
!
!
interface FastEthernet0
 ip address 10.10.10.10 255.255.0.0
 ip helper-address 10.10.5.254
 no keepalive
 speed auto
 full-duplex
!
interface Serial0
 ip unnumbered FastEthernet0
 no ip route-cache
 no fair-queue
!
interface Serial1
 ip unnumbered FastEthernet0
 no ip route-cache
!
router eigrp 1
 network 10.0.0.0
 auto-summary
 no eigrp log-neighbor-changes
!
no ip classless
no ip forward-protocol udp bootpc
no ip forward-protocol udp tftp
no ip forward-protocol udp time
no ip forward-protocol udp netbios-ns
no ip forward-protocol udp netbios-dgm
no ip forward-protocol udp tacacs
ip route 0.0.0.0 0.0.0.0 64.160.86.1
ip route 0.0.0.0 0.0.0.0 10.10.0.1
no ip http server
!
!
snmp-server community <removed> RO
snmp-server community <removed> RO
snmp-server community <removed> RO
!
line con 0
line aux 0
line vty 0 4
 password 7 <removed>
 login
line vty 5 15
 password 7 <removed>
 login
!
no scheduler allocate
end


------------------ show stacks ------------------


Minimum process stacks:
 Free/Size   Name
11256/12000  Router Init
 8784/12000  Init
 5348/6000   RADIUS INITCONFIG
 9420/12000  Virtual Exec

Interrupt level stacks:
Level    Called Unused/Size  Name
  3           0   9000/9000  PA Management Int Handler
  4   306173596   8560/9000  Network interfaces
  5           0   9000/9000  Timebase Reference Interrupt
  6         140   8916/9000  16552 Con/Aux Interrupt
  7    70519195   8916/9000  MPC860P TIMER INTERRUPT

------------------ show interfaces ------------------


FastEthernet0 is up, line protocol is up
  Hardware is PQUICC_FEC, address is 000c.ce6d.111b (bia 000c.ce6d.111b)
  Internet address is 10.10.10.10/16
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive not set
  Full-duplex, 100Mb/s, 100BaseTX/FX
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Queueing strategy: fifo
  Output queue 0/40, 0 drops; input queue 9/75, 10 drops
  5 minute input rate 203000 bits/sec, 52 packets/sec
  5 minute output rate 45000 bits/sec, 40 packets/sec
     3672409 packets input, 1300541611 bytes
     Received 1165807 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog
     0 input packets with dribble condition detected
     2388882 packets output, 439034014 bytes, 0 underruns
     0 output errors, 0 collisions, 3 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
Serial0 is down, line protocol is down
  Hardware is PQUICC with Fractional T1 CSU/DSU
  Interface is unnumbered. Using address of FastEthernet0 (10.10.10.10)
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, loopback not set
  Keepalive set (10 sec)
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Queueing strategy: fifo
  Output queue 0/40, 0 drops; input queue 0/75, 0 drops
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions
     DCD=down  DSR=up  DTR=up  RTS=up  CTS=down

Serial1 is up, line protocol is up
  Hardware is PQUICC with Fractional T1 CSU/DSU
  Interface is unnumbered. Using address of FastEthernet0 (10.10.10.10)
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
     reliability 255/255, txload 32/255, rxload 6/255
  Encapsulation HDLC, loopback not set
  Keepalive set (10 sec)
  Last input 00:00:02, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 22
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/22 (size/max total/threshold/drops)
     Conversations  0/18/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 1158 kilobits/sec
  5 minute input rate 41000 bits/sec, 40 packets/sec
  5 minute output rate 195000 bits/sec, 46 packets/sec
     2420914 packets input, 413096682 bytes, 0 no buffer
     Received 32912 broadcasts, 0 runts, 0 giants, 0 throttles
     48 input errors, 4 CRC, 23 frame, 0 overrun, 0 ignored, 21 abort
     2610259 packets output, 1153631786 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 output buffer failures, 0 output buffers swapped out
     1 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up
0
 
LVL 13

Expert Comment

by:Dr-IP
ID: 12292796
Since you are using IP unnumbered on the serial interfaces, swap the T1’s on one of the routers, and see if the down link changes. It should only be down for a few seconds, so no one will probably notice too much.
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 12292959
I would highly suggest putting actual IP addresses on all serial interfaces and changing encap to PPP
Since both ends are private and belong to you, there is no logical reason not to.
Then you can get the benefit of dynamic routing, and I'll bet they will both come up..

>Serial1 is up, line protocol is down
The protocol is down because the L3 is confused with same IP address assigned to three interfaces.
0
Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

 
LVL 1

Author Comment

by:riciit
ID: 12292963
I have done that and the down status follows with it.  As does the up status on the other one.  Keep in mind that one of the T1's has been in place for some time and the other, the one we are having trouble with is new and have never been connected yet.  I believe it is a line issue but I don't want to pitch a b#@@#%$ before I have all my ducks in a row.
0
 
LVL 79

Assisted Solution

by:lrmoore
lrmoore earned 250 total points
ID: 12292981
Can you confirm with the telco that tey are providing clocking for both ends of both t1s? Sometimes on point-to-point they will expect you to provide the clocksource on one end.
0
 
LVL 13

Accepted Solution

by:
Dr-IP earned 250 total points
ID: 12293196
One way to get around the clock issue, that is if it's an issue, is add this line to one of the routers on the serial port with the T1 that won’t come up. My bet at this time by the way is it’s the T1 was not configured properly by the telephone company.

interface Serial <----< that is not comming up
service-module t1 clock source internal
0
 
LVL 1

Author Comment

by:riciit
ID: 12303542
I just found out from the telco that because of the private status the clocking in on me not them so let me adjust that setting and get back with you.  
By the way thank you for all the input so far you have given me several ideas and options I had not thought of.
0
 
LVL 13

Expert Comment

by:Dr-IP
ID: 12304704
It won’t hurt to try originating the clocking on one of the routers, but I have doubts on it being the problem. As when I run into that problem, the circuit usually bounces repeatedly, and you say you only see one bounce, and that’s it.  

0
 
LVL 1

Author Comment

by:riciit
ID: 12310217
The provider ran the test again yesterday and told me that there are 36 hours of alarms showing on the line. Imagine that would you.  All in like 19 or 20 different time periods from 12:00am to 3 - 4:00 am.  I am thinking it is a provider problem and have now focused my attention on them.  
I upped the points to 500 and split the diff between you thanx again for your effort.
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 12310245
Thanks! Keep us updated on your progress...
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Suggested Solutions

In a WLAN, anything you broadcast over the air can be intercepted.  By default a wireless network is wide open to all until security is configured. Even when security is configured information can still be intercepted! It is very important that you …
It happens many times that access list (ACL) have to be applied to outgoing router interface in order to limit some traffic.This article is about how to test ACL from the router which is not very intuitive for everyone. Below scenario shows simple s…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now