Solved

ASP.NET is not Authorized

Posted on 2004-10-12
3
2,019 Views
Last Modified: 2012-05-05
am getting this message when i try to run EditItemTemplate on the server. Acces to MyCalendar.xml" is denied.

ASP.NET is not authorized to access the requested resource. Consider
To grant ASP.NET write access to a file, right-click the file in Explorer, choose "Properties" and select the Security tab. Click "Add" to add the appropriate user or group. Highlight the ASP.NET account, and check the boxes for the desired access

ASP.NET is not authorized to access the requested resource. Consider granting access rights to the resource to the ASP.NET request identity. ASP.NET has a base process identity (typically {MACHINE}\ASPNET on IIS 5 or Network Service on IIS 6) that is used if the application is not impersonating. If the application is impersonating via <identity impersonate="true"/>, the identity will be the anonymous user (typically IUSR_MACHINENAME) or the authenticated request user.

To grant ASP.NET write access to a file, right-click the file in Explorer, choose "Properties" and select the Security tab. Click "Add" to add the appropriate user or group. Highlight the ASP.NET account, and check the boxes for the desired access

My operating system is XP Professional.....and it does not have any security tab when I right click.

Please its very very urgent.
0
Comment
Question by:angireddy
3 Comments
 
LVL 3

Expert Comment

by:yellowjetski
ID: 12291475
If  give ASPNET the right does not solve the problem, what I had to do is to create another account with a little more right then the aspnet

For security reasons, ASPNET "cannot" make changes to the windows system (What I figured)

Go to Control Panel -> IIS -> Right click on the application you want to change -> Properties

Go to Directory Security tab -> Anonymous access and authentication control -> Edit

The click for anonymous access box should be check, and the user name is the account you grant anonymous access.

FOR TESTING PURPOSE, you can use your logon info and see if it solve the problem, if it does. please create an account with the read/write right to the correct directory, and use that account for this folder only.

Hope that helps
0
 
LVL 18

Accepted Solution

by:
tusharashah earned 500 total points
ID: 12292216
To view Security Tab on your Windows XP Pro:

Open Windows Explorer, and choose Folder Options from the Tools menu.  On the View tab, scroll to the bottom of the Advanced Settings and clear (click) the check box next to "Use Simple File Sharing."  Click OK to apply the change, and you should now have a Security tab when viewing the properties of a file on an NTFS volume.

From:
http://windows.about.com/library/tips/bltip542.htm?terms=windows+xp+security

-tushar

0
 
LVL 3

Expert Comment

by:mAjKoL
ID: 12295680
In the sedurity tab add write/modification access to ASPNET. I assume you have no impersonation.
0

Featured Post

3 Use Cases for Connected Systems

Our Dev teams are like yours. They’re continually cranking out code for new features/bugs fixes, testing, deploying, testing some more, responding to production monitoring events and more. It’s complex. So, we thought you’d like to see what’s working for us.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

In my previous two articles we discussed Binary Serialization (http://www.experts-exchange.com/A_4362.html) and XML Serialization (http://www.experts-exchange.com/A_4425.html). In this article we will try to know more about SOAP (Simple Object Acces…
This document covers how to connect to SQL Server and browse its contents.  It is meant for those new to Visual Studio and/or working with Microsoft SQL Server.  It is not a guide to building SQL Server database connections in your code.  This is mo…
Migrating to Microsoft Office 365 is becoming increasingly popular for organizations both large and small. If you have made the leap to Microsoft’s cloud platform, you know that you will need to create a corporate email signature for your Office 365…
Both in life and business – not all partnerships are created equal. As the demand for cloud services increases, so do the number of self-proclaimed cloud partners. Asking the right questions up front in the partnership, will enable both parties …

863 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

27 Experts available now in Live!

Get 1:1 Help Now