• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3209
  • Last Modified:

Bind ProFTPD to only one IP address (to see in sockstat 192.168.0.1:21)

Hello!

FreeBSD machine has 32 IP's.
Want bind ProFTPD to only one IP adress ( Not to use all socket like *:21 - only 192.168.0.1:21)
It's for jails.
Tried all possible variants - zero result.

Here's proftpd config:

ServerName                      "ProFTPD Default Installation"
ServerType                      standalone
DefaultServer                   on

TransferLog                     /var/log/proftpd/proftpd.log
ExtendedLog                     /var/log/proftpd/access.log WRITE,READ
ExtendedLog                     /var/log/proftpd/auth.log AUTH

Port                            21
Umask                           007 007
MaxInstances                    30

User                            root
Group                           wheel

DebugLevel 0

<Directory /*>
GroupOwner      www
</Directory>

DefaultRoot ~
AllowOverwrite          on

Thanks for help!

0
kolyakarpov
Asked:
kolyakarpov
1 Solution
 
van_dyCommented:
Hi karpov,
use the DefaultAddress option and then SocketBindTight, I havent tried this but see if it helps. add the following to your config


DefaultAddress     192.168.0.1
SocketBindTight                 on

Hope this helps.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: CompTIA Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now