• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 279
  • Last Modified:

*fla has mad issues*

Hi all,

If you test my fla.  You should see some strange behaviors when selecting from the combobox component.

1. the menu part of the combobox changes positions while the other part stays in place
2. movieclips that i loaded prior don't disapear

I made the firewall component have two different positions in the xml doc to show that the old movieclips are not disapearing.


Any ideas would be great, Thanks :)


http://www.portopen.com/lcdb.rar
 
0
gmailrules
Asked:
gmailrules
1 Solution
 
ssdesignCommented:
ok,
One of your problem was in this XML line:

<component name="class_checkin" visible="true" xpos="40"

It should read:

<component name="class_checkin" visible="true" xpos="4"

Still working on it further.

0
 
negatyveCommented:
Why do you use gotoAndPlay in a actionscript driven environment to change data and clip assets?
0
 
gmailrulesAuthor Commented:
" Why do you use gotoAndPlay in a actionscript driven environment to change data and clip assets?"

I don't know, I'm just trying to get it to work.  If you know of a better way that works please tell.
0
Get 10% Off Your First Squarespace Website

Ready to showcase your work, publish content or promote your business online? With Squarespace’s award-winning templates and 24/7 customer service, getting started is simple. Head to Squarespace.com and use offer code ‘EXPERTS’ to get 10% off your first purchase.

 
gmailrulesAuthor Commented:
I think your talking about this line: <component name="firewall" visible="true" xpos="40" ypos="304"></component>
I made it 40 and not 4 that way you could clearly tell that the old movieclips were not going away.  It shouldnt be causing any problems.

I think there is something wrong with the combobox component.  did you notice that the menu part of it changes positions?
0
 
gmailrulesAuthor Commented:
ok a friend told me how to fix the combobox component.  all i had to do was give it an instance name.  and he also told me that i could possibly use an array to store all the mc's names so i could manually remove them.  I am going to try that, but if anyone knows a better way or why this problem is happening in the first place.  please let me know.

Thanks :)
0
 
gmailrulesAuthor Commented:
V2 components have tons of bugs!  jeez...  I found out what the strange behavior was caused by:

http://www.macromedia.com/support/flash/ts/documents/remove_mc_depth.htm?pss=rss_flash_19435

now using this code:

_root[name].swapDepths(1048575);
removeMovieClip(_root[name]);  //_root[name].unloadMovie() <- doesnt work
_root.attachMovie(name + "_mc", name, this.getNextHighestDepth(), {_x:comp.xpos, _y:comp.ypos});


Negatyve, if you could explain this to me:  "Why do you use gotoAndPlay in a actionscript driven environment to change data and clip assets?"  I will accept your anwser.  

Thanks!!!
0
 
moduloCommented:
PAQed with points refunded (500)

modulo
Community Support Moderator
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now