vb.net IDE editor problems

Anyone found a way of using the vb.net IDE without going completely mad ?

The things I'd like to fix are:

- Stop it deleting white space that I put in
- Have the cursor fall onto the current indentation without using pretty formatting, as opposed to the start of the line
- Stop it from rogering all your code when you insert an IF inside a select case statement

I've tried various combinations of settings and just cant find something that fits, yet when I use the IDE to edit asp and js pages it seems fine.
LVL 8
plqAsked:
Who is Participating?
 
flavoConnect With a Mentor Commented:
I dont have VS .Net on me, but there is an option to turn that off.  Cant quite remember where it is but try Options and look for something like Auto Indent and un-tick it
0
 
plqAuthor Commented:
Just shutting down old Q's, I couldnt get it working how I need it. v.frustrating
0
 
flavoCommented:
Got VS.Net on me (at home)

Tools - Options and select TextEditor from the list down the left.. play around in there

Dave
0
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

 
plqAuthor Commented:
Nah tried all that already. The only possibility is allowing virtual space but then its just totally crap to use. There seems to be no way of just getting it like VB6/ASP.NET-HTML/MSVC6 kind of editing behaviour. I wondered if there was some combination of options which established vb.net developers had used to achieve this. I've been messing with it for months and not found a suitable set of options

0
 
plqAuthor Commented:
How about this

- Indenting = None, means that all your tabs are removed on every line you change
- Indenting = Block, tabs are kept on lines with code but lost on blank lines when you move off
- Indenting = Smart, same as block

I could live with it removing tabs when I hit save or compile, but not in the middle of an editing session

Insert Spaces vs Keep Tabs has no effect on whether it removes tabs you put in on a blank line

Turn off Automatic insertion of end constructs and the cursor always goes to the start of the next line when you press enter, instead of maintaining the current indent.

Maybe the answer is to rename all my .vb files to .html !!!
0
 
flavoCommented:
I agree.. coming from years of VBA programming to VB .Net, i got very annoyed with the autoformating.. i have got used to it though...

Maybe post a suggestion on msdn... there is a site there for developer input..

Sorry i cant be more help... Im off to bed..

Dave
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.