• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 5913
  • Last Modified:

Stop desktop icons from flickering!

Ever since I've had Win XP home edition & when using explorer, (opening & usually closing My computer, My documents, etc.) all the icons on my desktop flicker & momentarely disappear. Sometimes the icons in explorer windows do the same thing. This is so annoying. I've tried everything from patches to replacing my video card & memory, but still does the same thing! I even turned off everything running by the clock. I notice in task manager that explorer.exe runs extremely high (18,000 kb up to 32,000 kb memory usage), much higher than Win 2000 Pro. If anyone can solve this, please let me know.  Thanks, Bob            
2 Solutions
Explorer is faily bulky on my machine too. I've had similar problems that were down to heat.

Power down your PC and let it cool a bit then power it back up without the sidepanel on the case. See if it still happens.

I suspect its heat. Also check the temp of your CPU. This can also be a common cause. Most Bios give a reading now.

Let me know how the tests come along, and if you are unfamialr with the bios just reboot and keep pressing the "del" key by the num pad and it should pop up, in there you can normally get a reading.
Hello bobdi64 =)

When you boot ur system in safemode and check for the problem there,,,, same problem occur there also ??
if No then in normal mode goto Start>Run>msconfig>Startup and click on Disable All
then in services section, click on Hide Amicrosofot Services, and now untick all those third party services !!
Restart and check for the problem now ??
if it doesn't occur then re-enable each application and service at a time and trace out the culprit one !!
Good Luck :)
try adjsuting teh refresh rate for your monitor,
go to control panel>display properties>settings
click advanced in the lower right corner
go to the monitor tab
most monitors work well at 75Hz
there should be a label on the back of your monitor with acceptable refresh frequncies (45~85 Hz) on most new monitors
a slow refresh rate can make the screen appear to flicker.
Rename the shelliconcache which is located in C:\Documents and Settings\Your User Name\Local Settings\Application Data\Iconcache.db

rename it to iconcache.db.old

Reboot your Pc.

TweakUi has been known to cause these problems.

Cheers and good luck,

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

Tackle projects and never again get stuck behind a technical roadblock.
Join Now