"Computers Near Me" doesn't work...

I have a point-to-point network in windows 2000, and most of the computers work fine.   However, two of the computers have problems with opening "Computers Near Me" but they will open up under Microsoft Windows Network (which sees all the computers on the network).

The error message is the pop-up box "Workgroup is not accessible. The list of servers for this workgroup is not currently available."

All computers are using static IPs, and NetBIOS over TCP/IP is enabled on every computer.   All computers use windows 2000.   Have checked and am fairly sure this is not a master browser issue.   Have uninstalled and reinstalled File and Print Sharing.

Any suggestions would be appriciated.
tenrowsdownAsked:
Who is Participating?
 
moduloConnect With a Mentor Commented:
PAQed with no points refunded (of 250)

modulo
Community Support Moderator
0
 
nihlcatCommented:
Are the affected stations using NetBIOS over TCP/IP?
0
 
corneliupCommented:
Solution Title: Win2K Workgroup not accessible
http://www.experts-exchange.com/Operating_Systems/Win2000/Q_10405458.html
0
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
tenrowsdownAuthor Commented:
nihlcat, as I stated in my question NetBIOS over TCP/IP is enabled on every computer in the network.  
0
 
nihlcatCommented:
Oopsy.
0
 
tenrowsdownAuthor Commented:
corneliup, the maintainserverlist key is set to Auto, and IsDomainMaster is set to False.   I changed these keys to that in the solution you gave, but it did not fix the problem.   Even if it did, there are two main differences in the problem I have to the solution you gave:
1. He could not open his wourgroup under Microsoft Windows Network whereas I can
2. He only had problem with his one Windows 2000 computer, I have a problem with 2 out of 6, and can not make both of the the Domain Master.

Also, I am not using any firewall software.

Thanks.
0
 
nihlcatCommented:
And Computer Browser is on?
0
 
tenrowsdownAuthor Commented:
I assume it is, where would I change it?   I have made all the necessary changes to the registry that I know of...  
0
 
nihlcatCommented:
It's in services.  I would expect that it's on, but you never now.
0
 
tenrowsdownAuthor Commented:
Yeah, I have already checked the services.   The configuration is the exact same on all computers, both working and nonworking.   Thanks for your help thus far...
0
 
nihlcatCommented:
HRmmmm.  Irritating.  Do you perhaps have these registry keys?

User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Network]

System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Network]

Value Name: NoWorkgroupContents
Data Type: REG_DWORD (DWORD Value)
Value Data: (0 = disabled, 1 = enabled)
0
 
tenrowsdownAuthor Commented:
Yeah, you pretty much sume it up with the irritating reference...

On all the computers (working and nonworking), there is no Network in the registry path you gave above, and thus no key named NoWorkgroupContents.
0
 
nihlcatCommented:
Ok, well that's good.  I know that you can probably enable LMhosts and create entries for the other PCs, that should do it.  The file you need to edit is C:\WINNT\SYSTEM32\DRIVERS\ETC\LMHOSTS.SAM.  That's sort of tedious, and doesn't explain how this happened, but it should work.

I'll keep thinking about it.
0
 
tenrowsdownAuthor Commented:
What is really irritating is I can access every computer in my workgroup through the workgroup icon in Microsoft Windows Network, but I can't from clicking "Computers Near Me".   The Computers Near Me should open up the exact same as the Windows Network...
0
 
tenrowsdownAuthor Commented:
Ok, I got the answer myself.   Realizing that the Computers Near Me should show the same as under MWN, I took a look at the properties of "Computers Near Me", and apparently when the problematic computers were added to the Wourgroup, the "Computers Near Me" target didn't change.  

So I just took them off their current workgroup to a different workgroup, restarted, brought them back into the workgroup, restarted, and the "Computers Near Me" target worked.

I guess I was over-complicating the issue.
0
 
nihlcatCommented:
Sweet!!  I typed that up as my latest suggestion, but you beat me to it!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.