?
Solved

phpmyadmin + config.inc.php + http authtype says try again buddy

Posted on 2004-10-13
17
Medium Priority
?
1,712 Views
Last Modified: 2008-10-17
Ok I have just configured WAMP (Windows Apache MySQL and PHP) development
server. I posted in Misc but got no response so I will try my luck here.

MySQL 4.1
php 4.3.9
apache 1.3.31
phpmyadmin 2.6.0 pl2

Configured phpmyadmin to match similar setups i have on other computers.
config and cookie auth types work fine but http is giving me a headache
that i just don't need and it just so happens to be the one i need at the moment. Everytime i enter the http authentication username and password it just keeps asking me for them in a loop until i cancel and get a wrong username/password error access denied.

What am i forgetting?
0
Comment
Question by:ricbax
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 8
  • 7
17 Comments
 
LVL 3

Expert Comment

by:thecode101
ID: 12300299
How do you have your htaccess file set up? Is it pointing to the correct location of the .htpasswd file?
0
 
LVL 3

Author Comment

by:ricbax
ID: 12300642
I know that an .htaccess and .htpasswd files are a possibility however I am trying to get the http authtype within phpmyadmin to work and comunicate with mysql.
0
 
LVL 3

Expert Comment

by:thecode101
ID: 12300698
Is your AllowOverride directive in apache set up correctly?
0
Ransomware: The New Cyber Threat & How to Stop It

This infographic explains ransomware, type of malware that blocks access to your files or your systems and holds them hostage until a ransom is paid. It also examines the different types of ransomware and explains what you can do to thwart this sinister online threat.  

 
LVL 3

Author Comment

by:ricbax
ID: 12300822
What would that be?
0
 
LVL 3

Expert Comment

by:thecode101
ID: 12300841
Where ever your apache is set up there should be a conf folder with a file called httpd.conf. In that file there should be a directive called AllowOverride. AllowOverride controls what directives may be placed in .htaccess files.
0
 
LVL 3

Author Comment

by:ricbax
ID: 12300943
yes I understand that you want me to go with the htaccess/htpasswd directive, however I am 99.9% positive that this is not necessary with phpmyadmin if the authtype is set within the config.php to "http"

I know your solution works but it is not what I am trying to achieve.
0
 
LVL 3

Expert Comment

by:thecode101
ID: 12300982
Ok, I think I understand now. Let me check out my phpmyadmin config and see what I can find.
0
 
LVL 3

Expert Comment

by:thecode101
ID: 12301049
So you set up a MySQL user account and it is not working when you enter that username and password?
0
 
LVL 3

Author Comment

by:ricbax
ID: 12301172
MySQL is setup as root as user and has a password ... MySQL works fine from the cmd prompt with the username and password.

HTTP Authentication will not work when the username and password are entered for phpmyadmin.

0
 
LVL 3

Expert Comment

by:thecode101
ID: 12301228
Just to test, try setting up another user and password and give that a try. We will have to do some troubleshooting to find out exactly where the problem is. You can also try setting the authtype to config and seeing if you are actually able to connect to the databases that way.
0
 
LVL 3

Author Comment

by:ricbax
ID: 12304938
Config works before I add a password for root, after adding the pasword i get the following error

#1045 - Access denied for user 'ODBC'@'localhost' (using password: NO)

http will not accept a username and password.

0
 
LVL 3

Author Comment

by:ricbax
ID: 12305151
Why is ODBC more important than root? and why is it if you delete all users from the mysql database that ODBC@localhost likes to hang around even after you kill the process 1000 times and it renews itself.

Simply frustrating...
0
 
LVL 3

Expert Comment

by:thecode101
ID: 12310057
I had a similar problem when my 'controluser' and 'controlpass' variables where incorrect. Make sure you have these filled in with a valid user account/password.
0
 
LVL 3

Author Comment

by:ricbax
ID: 12319199
Solution:

Installation order of older version of MySQL 4.1.4 (not 4.1.5), Apache 1.3.31 and PHP 4.3.9 seemed to solve my problem and thoroughly reading the phpMyAdmin documentation. Any other order of installation and I would have a problem where I would get ODBC@localhost errors rather than root@localhost (row order in mysql database) and password errors as mentioned above.

I like to thank thecode101 for the effort in providing me with possible solutions. In the end I found my own solution that worked.

ricbax
0
 
LVL 3

Expert Comment

by:thecode101
ID: 12321129
No objections, glad you got it worked out.
0
 

Accepted Solution

by:
RomMod earned 0 total points
ID: 12349223
PAQ'd points refunded.
RomMod
Community Support Moderator
0

Featured Post

The Eight Noble Truths of Backup and Recovery

How can IT departments tackle the challenges of a Big Data world? This white paper provides a roadmap to success and helps companies ensure that all their data is safe and secure, no matter if it resides on-premise with physical or virtual machines or in the cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this blog post, we’ll look at how using thread_statistics can cause high memory usage.
Backups and Disaster RecoveryIn this post, we’ll look at strategies for backups and disaster recovery.
In this video, Percona Solution Engineer Dimitri Vanoverbeke discusses why you want to use at least three nodes in a database cluster. To discuss how Percona Consulting can help with your design and architecture needs for your database and infras…
In this video, Percona Solution Engineer Rick Golba discuss how (and why) you implement high availability in a database environment. To discuss how Percona Consulting can help with your design and architecture needs for your database and infrastr…
Suggested Courses

765 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question