Solved

Cisco PIX 506e + Cisco VPN Client 4.03

Posted on 2004-10-13
15
905 Views
Last Modified: 2013-11-16
Following this:
http://www.cisco.com/en/US/products/hw/vpndevc/ps2030/products_configuration_example09186a0080093f89.shtml

I was able to setup a VPN connection, however I am unable to browse the remote network.

Any ideas / help on how to troubleshoot this?
0
Comment
Question by:just1coder
  • 9
  • 6
15 Comments
 
LVL 79

Expert Comment

by:lrmoore
ID: 12299691
Do you have internal DNS/WINS servers?
Are they properly identified in the vpngroup config?
Did you use a separate IP subnet for your clients than your local LAN?

Can you paste your config?

You can try adding a LMHOSTS file with domain controller identified...

0
 
LVL 2

Author Comment

by:just1coder
ID: 12299703
Sorry, I should have been more specific. I *can* browse to the remote LAN servers via IP address, but not hostname.

Is there a particular part of the config?

LMHOSTS ?
0
 
LVL 2

Author Comment

by:just1coder
ID: 12299722
The remote LAN has internal DNS - no WINS.

There is a seperate submet for the VPN clients.
0
Watch Anatomy of a Wi-Fi Hack On-Demand

In less than a weekend, anyone with Internet access and some free time can become a Wi-Fi MitM to wreak havoc on your network. View our Wi-Fi Expert in an on-demand episode of our Secure Wi-Fi mini-series as he explores the motives, execution, and anatomy of a Wi-Fi hack.

 
LVL 79

Expert Comment

by:lrmoore
ID: 12299876
Try adding a LMHOSTS file on your PC. You only need the two entries for the Domain Controller:

http://support.microsoft.com/kb/180094/EN-US/
0
 
LVL 2

Author Comment

by:just1coder
ID: 12299950
Great - thanks

Is there anything I can do to allow the VPN, as well as the normal traffic simultaneously?

Whenever I open the VPN it drops all of my other connections.
0
 
LVL 79

Accepted Solution

by:
lrmoore earned 70 total points
ID: 12300029
Use the split-tunnel acl and only define traffic from your local lan to the VPN client subnet

Example:

   access-list split_tunnel_acl permit ip <local lan> mask <client subnet> mask
  vpngroup split-tunnel split_tunnel_acl

0
 
LVL 2

Author Comment

by:just1coder
ID: 12300227
OK, looking good! But now when I have my connection established, and another user connects my connection is dropped.
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 12301357
That's not good...
How many IP addresses are there in your VPN address pool?
0
 
LVL 2

Author Comment

by:just1coder
ID: 12301519
Thanks for you help!! If I had more pts I would certianly assign them :)

For the IP pool, I used: 10.99.99.0 - 10.99.99.255

On another note, adding this to the config seems to have aced my existing PIX-to-PIX config :o

nat (inside) 0 access-list no_nat <-- that was changed to: nat (inside) 0 access-list 101
nat (inside) 1 0.0.0.0 0.0.0.0 0 0

coudl I have just added it as:
nat (inside) 2 access-list 101?

Thank goodness for backups.
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 12301567
I'd have to see your complete config, but I'll try to explain
<you can always buy points>

You need multiple entries in your nat 0 acl. Combine both the VPN clients and the remote site LAN-LAN vpn:

   access-list 101 permit ip <local subnet> mask <remote subnet> mask
   access-list 101 permit ip <local subnet> mask 10.99.99.0 255.255.255.0
   nat (inside) 0 access-list 101
                    ^^
                   This MUST be a zero
0
 
LVL 2

Author Comment

by:just1coder
ID: 12301668
I see. Thanks. I will give that a go.
0
 
LVL 2

Author Comment

by:just1coder
ID: 12309761
I went through the examples line for line and was able to get both working successfully, however I still have the problem where I can not have more than 1 user connected to the VPN at the same time.
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 12309825
Do you have nat-traversal enabled?

 isakmp nat-traversal 20  
0
 
LVL 2

Author Comment

by:just1coder
ID: 12309974
No - will try now.
0
 
LVL 2

Author Comment

by:just1coder
ID: 12310036
Excellent, thank you!
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you are like regular user of computer nowadays, a good bet that your home computer is on right now, all exposed to world of Internet to be exploited by somebody you do not know and you never will. Internet security issues has been getting worse d…
Do you have a windows based Checkpoint SmartCenter for centralized Checkpoint management?  Have you ever backed up the firewall policy residing on the SmartCenter?  If you have then you know the hassles of connecting to the server, doing an upgrade_…
Nobody understands Phishing better than an anti-spam company. That’s why we are providing Phishing Awareness Training to our customers. According to a report by Verizon, only 3% of targeted users report malicious emails to management. With compan…
With Secure Portal Encryption, the recipient is sent a link to their email address directing them to the email laundry delivery page. From there, the recipient will be required to enter a user name and password to enter the page. Once the recipient …

713 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question