Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Help with Cisco 1720 DS1 config

Posted on 2004-10-13
6
Medium Priority
?
429 Views
Last Modified: 2013-11-30
Hello,

I'm a Cisco wannabe expert and I just had a DS1 (T1) turned on in my office.  I have a Cisco 1720 Router and although I was hoping that my ISP would have sent me the config in Cisco router language, they sent me what's below.  Can someone help me with providing what my Cisco config should look like when I do a "show config"?

Thank you,

DanV

*Note - I've x'd my ip's to keep them private.

LAN Range Info:

      Useable IP addresses:   xx.xx.xx.xx - xx.xx.xx.xx


      Subnet Mask:            255.255.255.240


      Gateway Address:        xx.xx.xx.xx
For DNS Resolution -

      Primary DNS Server:     xx.xx.xx.xx


      Secondary DNS Server:   xx.xx.xx.xx
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
Below are recommended configuration settings for your equipment should you choose not to take advantage of
Broadwing Communications' turnkey solution.
Please provide these settings to your equipment vendor/configurator to ensure a smooth service installation.

      CPE* LAN address/mask:          xx.xx.xx.xx / 255.255.255.240


      CPE* WAN address/mask:          xx.xx.xx.xx / 255.255.255.252


      Broadwing WAN address/mask:     xx.xx.xx.xx / 255.255.255.252
      A default route should be setup in the router as follows:


            network / mask:     0.0.0.0 / 0.0.0.0


            gateway:            xx.xx.xx.xx

      * CPE refers to the Customer Premise Equipment.


        LAN refers to the port used to connect to the internal network.


        WAN refers to the port used to connect to the dedicated circuit.
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
DS1 default framing and line coding - ESF and B8ZS, respectively
DS3 line coding - C-bit parity
DS3 ATM cell scrambling - enabled
ATM cell mapping into DS3 C-bit frame = PLCP (Physical Layer Convergence Protocol)
Frame Relay encapsulation - RFC 1490/2427
Frame Relay default LMI - Annex D User

0
Comment
Question by:dvelez
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
6 Comments
 
LVL 79

Expert Comment

by:lrmoore
ID: 12304990
We are missing one very vital piece of information.
With DS1, assume default frame/encode - OK
 Is this DS1 frame-relay? If so, you need a DLCI number..
Assuming that it IS frame-relay and they can provide you a DLCI:

Basically, you can cut/paste this config into your router.

!
interface FastEthernet 0
  ip address 12.34.56.7 255.255.255.240   <== LAN address/mask
  no shutdown
!
interface Serial 0
  no shut
  encap frame-relay
  frame-relay lmi-type annex-d  <== check the syntax with "frame-relay lmi-type ?"
!
interface serial 0.1 point-to-point
  ip address 43.56.78.9 255.255.255.252  <== WAN address/mask
  frame-relay interface-dlci  ##  <== this is what you are missing
!
ip route 0.0.0.0 0.0.0.0 x.x.x.x  <== "gateway"
!

NOTE: you don't need to put the dns server information in the router, they are for your clients to use. Set those up in your DHCP scope.

That should at least get you up and running..
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 12307138
In addition to needing the DLCI, you'll need to use IETF encapsulation on your frame-relay interface:

interface Serial 0
  no shut
  encap frame-relay ietf
0
 

Author Comment

by:dvelez
ID: 12309715
Thanks for the input so far.  I just found out that the information that Broadwing sent me was generic information except for my Ip Adresses.  They never gave me what I needed to configure my router.  

I was just told that the DS1 is a Serial HDLC  That's all the information that they've volunteered so far.  I feel as if they are trying to force a tech on site that I'll have to pay big bucks to.

This is what I have in my router so far.  Can anyone figure out what I'm missing?

*Note - As soon as I turn on my Cisco 1720 Router and it goes through the self test, the AL light in the back of the WIC 1DSU T1 light goes on.  Is this normal?

Thank you,

DanV


Router#show config
Using 615 out of 29688 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
logging rate-limit console 10 except errors
!
memory-size iomem 25
ip subnet-zero
no ip finger
!
!
!
!
interface FastEthernet0
 ip address x.x.x.x 255.255.255.240
 speed auto
!
interface Serial0
 description to Boadwing (0000000)
 no ip address
 no fair-queue
!
interface Serial0.1
 ip address x.x.x.x 255.255.255.252
!
ip classless
no ip http server
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
!
no scheduler allocate
end

Router#
0
Looking for a new Web Host?

Lunarpages' assortment of hosting products and solutions ensure a perfect fit for anyone looking to get their vision or products to market. Our award winning customer support and 30-day money back guarantee show the pride we take in being the industry's premier MSP.

 
LVL 79

Accepted Solution

by:
lrmoore earned 2000 total points
ID: 12309803
Some changes required:
>

no interface Serial0.1   <== no sub-interface for HDLC
!
interface Serial0
 description to Boadwing (0000000)
 ip address x.x.x.x 255.255.255.252   <== assign the IP to the major interface
 no fair-queue
  no shutdown  <== very important
!


0
 

Author Comment

by:dvelez
ID: 12322106
Thank you for all your help.  I couldn't have done it without you.
DanV
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 12324258
Glad to help!
0

Featured Post

Moving data to the cloud? Find out if you’re ready

Before moving to the cloud, it is important to carefully define your db needs, plan for the migration & understand prod. environment. This wp explains how to define what you need from a cloud provider, plan for the migration & what putting a cloud solution into practice entails.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When you try to share a printer , you may receive one of the following error messages. Error message when you use the Add Printer Wizard to share a printer: Windows could not share your printer. Operation could not be completed (Error 0x000006…
WARNING:   If you follow the instructions here, you will wipe out your VTP and VLAN configurations.  Make sure you have backed up your switch!!! I recently had some issues with a few low-end Cisco routers (RV325) and I opened a case with Cisco TA…
Internet Business Fax to Email Made Easy - With  eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, f…
Michael from AdRem Software outlines event notifications and Automatic Corrective Actions in network monitoring. Automatic Corrective Actions are scripts, which can automatically run upon discovery of a certain undesirable condition in your network.…

670 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question