?
Solved

Not linking to documents in a view

Posted on 2004-10-13
6
Medium Priority
?
200 Views
Last Modified: 2013-12-18

This might be a bit of a daft question...
Is there anyway I can just display a view on the internet and not have links to the documents.  I'm using R5 and just a standard $$ViewTemplateDefualt form for all my views.  None of the columns have the option "show values in the column as links" checked but at the moment the first column is displaying as a link (which I think is what notes automatically defaults too).

0
Comment
Question by:RichardStarkey
6 Comments
 
LVL 19

Expert Comment

by:madheeswar
ID: 12305366
Create a form:
$$ViewTemplateDefault  ->Check the psell. Your is wrong.

And create a field:

$$ViewBody

open any view on web. And u can see the view using this form.
0
 
LVL 15

Accepted Solution

by:
Bozzie4 earned 200 total points
ID: 12305455
A view will always display at least 1 column as links on the web.  But there is a solution : create an extra column, and give this the property "Show values in the columns as links", and then hide the column.

Another solution is to enable the property "treat as html", but then you'll have to write all the html necessary to build the view yourself (which is a lot more work)

cheers,

Tom
0
 

Expert Comment

by:orion17
ID: 12305467
Use something like "[</a>]" in your first column to stop the href, generated by default.
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
LVL 14

Expert Comment

by:p_partha
ID: 12308086
Or use html views and you have complete control over them.

something like this :
http://codestore.net/store.nsf/unid/EPSD-5VBS6Y?OpenDocument

Partha
0
 

Author Comment

by:RichardStarkey
ID: 12336645

Tom,
Cheers for that.
A quick question - do you know how this affects DBLookups and DbColumns on the view?  I'm pretty sure there should be no problems...
0
 
LVL 15

Expert Comment

by:Bozzie4
ID: 12336798
That does not affect dblookups.  DBlookups are only affected if you hide the view (completely) for the web, or if you put Read rights on the view

cheers,

Tom
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Problem "Can you help me recover my changes?  I double-clicked the attachment, made changes, and then hit Save before closing it.  But when I try to re-open it, my changes are missing!"    Solution This solution opens the Outlook Secure Temp Fold…
Article by: Rob
Notes 8.5 Archiving Steps and Tips This article covers setting up a Notes archive, and helps understand some of the menu choices making setting up and maintaining a Notes archive file easier.
this video summaries big data hadoop online training demo (http://onlineitguru.com/big-data-hadoop-online-training-placement.html) , and covers basics in big data hadoop .
Are you ready to place your question in front of subject-matter experts for more timely responses? With the release of Priority Question, Premium Members, Team Accounts and Qualified Experts can now identify the emergent level of their issue, signal…
Suggested Courses

755 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question