COM + and IIS 6.0

I have site that was hosted on IIS 5.0 and WIndows 2000 that created com+ objects.  We upgraded to Windows 2003 and the asp pages no longer have permission to create the object
I swear i set all the permissions correctly but obviously not.
Can some please help me to get this working.

error i get is: 006~ASP 0177~Server.CreateObject Failed~80110821
Who is Participating?
alimuConnect With a Mentor Commented:
check that the dll's you're using have at least the ntfs permissions read&execute access for the administrators group and system, IUSR, IWAM accounts.

Another thing you can try is setting this up as a COM+ component in Component Services mmc snap-in which will allow you to run it under a specific userid and password.  You create a new package and then add components (your dll's), then edit the package properties to alter the identity this component will run under.

If you're not sure which dll is causing the problem, download & install filemon from and try running the app.  It will show you in realtime any access denied errors, etc, that occur during application access.

Hope this helps,
Hi madface,
Can you please provide some feedback to advise whether this resolved your problem or not?
If this is fixed up could you close off your question please?
If you're not sure how, here's the options:
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.