Solved

PIX Configuration

Posted on 2004-10-13
6
400 Views
Last Modified: 2013-11-16
I want to have the outside interface accept specific port traffic and forward to inside host.  The corrent configuration looks like this.

so what i want to do is have outside (123.33.33.68) map to 10.0.7.2 all traffic ports 25000-25010

 
PIX Version 6.3(3)                  
interface ethernet0 auto                        
interface ethernet1 auto                        
nameif ethernet0 outside security0                                  
nameif ethernet1 inside security100                                
enable password 1OrtXeG/i8Eb0bkp encrypted                                          
passwd 1OrtXeG/i8Eb0bkp encrypted                                
hostname bigbad-wolf                            
fixup protocol dns maximum-length 512                                    
fixup protocol ftp 21                    
fixup protocol h323 h225 1720                            
fixup protocol h323 ras 1718-1719                                
fixup protocol http 80                      
fixup protocol pptp 1723                        
fixup protocol rsh 514                      
fixup protocol rtsp 554                      
fixup protocol sip 5060                      
fixup protocol sip udp 5060                          
fixup protocol skinny 2000                          
no fixup protocol smtp 25                        
fixup protocol sqlnet 1521                          
fixup protocol tftp 69                      
names    
access-list 1 permit icmp any any                                
access-list 1 permit gre any any                                
access-list 1 permit tcp any host 123.33.33.67 eq pop3                                                    
access-list 1 permit tcp any host 123.33.33.67 eq smtp                                                    
access-list 1 permit tcp any host 123.33.33.67 eq imap4                                                      
access-list 1 permit tcp any host 123.33.33.67 eq 8010                                                    
access-list 1 permit tcp any host 123.33.33.67 eq 8100                                                    
access-list 1 permit tcp any host 123.33.33.68 eq 3389                                                    
access-list 1 permit tcp any host 123.33.33.68 eq pptp                                                    
access-list 1 permit tcp any host 123.33.33.67 eq 9010                                                    
access-list 1 permit tcp any host 123.33.33.66 eq 16                                                
access-list 10 permit ip 10.0.7.0 255.255.255.0 10.1.7.0 255.255.255.0                                                                      
pager lines 24              
logging on          
mtu outside 1500                
mtu inside 1500              
ip address outside 123.33.33.66 255.255.255.240                                              
ip address inside 10.0.7.1 255.255.255.0                                        
ip audit info action alarm                          
ip audit attack action alarm                            
ip local pool remote-users 10.1.7.50-10.1.7.200                                              
pdm history enable                  
arp timeout 14400                
global (outside) 1 interface                            
nat (inside) 0 access-list 10                            
nat (inside) 1 0.0.0.0 0.0.0.0 0 0                                  
static (inside,outside) tcp interface 1666 10.0.7.6 1666 netmask 25                                                                
 0 0    
static (inside,outside) 123.33.33.67 10.0.7.3 netmask 255.255.255.255 0 0                                                                        
static (inside,outside) 123.33.33.68 10.0.7.2 netmask 255.255.255.255 0 0                                                                        
access-group 1 in interface outside                                  
route outside 0.0.0.0 0.0.0.0 123.33.33.65 1                                          
timeout xlate 3:00:00                    
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00                                                                            
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00                                                              
timeout uauth 0:05:00 absolute                              
aaa-server TACACS+ protocol tacacs+                                  
aaa-server RADIUS protocol radius                                
aaa-server LOCAL proto                    
no snmp-server location                      
no snmp-server contact                      
snmp-server community public                            
no snmp-server enable traps                          
floodguard enable                
sysopt connection permit-ipsec                              
crypto ipsec transform-set myset esp-des esp-md5-hmac                                                    
crypto dynamic-map dynmap 10 set transform-set myset                                                    
crypto map ipsec-maps 10 ipsec-isakmp dynamic dynmap                            
crypto map ipsec-maps interface outside
isakmp enable outside
isakmp identity address
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup vpn3000 address-pool remote-users
vpngroup vpn3000 dns-server 10.0.7.2 10.0.7.4
vpngroup vpn3000 wins-server 10.0.7.2 10.0.7.4
vpngroup vpn3000 default-domain transmedics.com
vpngroup vpn3000 split-tunnel 10
vpngroup vpn3000 idle-time 1800
vpngroup vpn3000 password ********
telnet 10.0.7.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
terminal width 80
Cryptochecksum:2b640addac48eaa89736043dfa9d0946
: end
0
Comment
Question by:akita29
  • 3
  • 3
6 Comments
 
LVL 79

Expert Comment

by:lrmoore
ID: 12304947
>static (inside,outside) 123.33.33.68 10.0.7.2 netmask 255.255.255.255 0 0              
That one line takes care of the nat for all ports.
Now you just need to create an access-line entry:

  access-list 1 permit tcp any host 123.33.33.68 range 25000-25010

Then re-apply the access-list to the interface (required step when changing the acl)

  access-group 1 in interface outside                                  
0
 

Author Comment

by:akita29
ID: 12306613
OK.. when I enter the following from the config t


  access-list 1 permit tcp any host 123.33.33.68 range 25000-25010

i get  a error.

I did not enter the static (inside, outside) as it's in the config I started with the access-list 1 first
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 12306974
My bad. No "-" in the port range. Use a space instead:

    access-list 1 permit tcp any host 123.33.33.68 range 25000 25010
                                                                                        ^^
0
VMware Disaster Recovery and Data Protection

In this expert guide, you’ll learn about the components of a Modern Data Center. You will use cases for the value-added capabilities of Veeam®, including combining backup and replication for VMware disaster recovery and using replication for data center migration.

 

Author Comment

by:akita29
ID: 12307194
Lets give that a go...
0
 

Author Comment

by:akita29
ID: 12310681
so i assume that this is for tcp what about udp, what would the command be for udp (I expect replace tcp w/ udp) how about both does this require two lines
0
 
LVL 79

Accepted Solution

by:
lrmoore earned 250 total points
ID: 12311585
If you want both, then two lines:

   access-list 1 permit tcp any host 123.33.33.68 range 25000 25010
   access-list 1 permit udp any host 123.33.33.68 range 25000 25010
0

Featured Post

What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Overview The Cisco PIX 501, PIX 506e, ASA 5505 and ASA 5510 (most if not all of this information will be relevant to the PIX 515e but I do not have a working configuration handy to verify the validity) are primarily used within small to medium busi…
The DROP (Spamhaus Don't Route Or Peer List) is a small list of IP address ranges that have been stolen or hijacked from their rightful owners. The DROP list is not a DNS based list.  It is designed to be downloaded as a file, with primary intention…
Both in life and business – not all partnerships are created equal. As the demand for cloud services increases, so do the number of self-proclaimed cloud partners. Asking the right questions up front in the partnership, will enable both parties …
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…

772 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question