Solved

Can not get OMA (Outlook Mobile Access) Web Application to work

Posted on 2004-10-13
6
901 Views
Last Modified: 2008-01-16
Hello All,

I have a server running Windows 2003 with all patches installed from Windows Update.  On this server I am running Exchange 2003 SP1.  The issue I am having is I can not seem to get the OMA aplication to work.  My OWA works perfectly, and I do not have any issues via outlook, pop3, imap4.  The error I am getting when I try to access the OMA site is this:

Server Application Unavailable
The web application you are attempting to access on this web server is currently unavailable.  Please hit the "Refresh" button in your web browser to retry your request.

Administrator Note: An error message detailing the cause of this specific request failure can be found in the application event log of the web server. Please review this log entry to discover what caused this error to occur.

The URL I am using is as follows:

https://apollo/oma

I am getting this on IE as well as on my t616, t68i, Sony Clie, everything I try to access this application with this is all I get.  

I have tried the system with and without SSL in place.  

The server is also a domain controler for a small domain.  

Also when I check the Event log I do not have any entry in it from IIS or Exchange.  The only entry I have in my IIS access log is a standard access request.

Server specs:
Pentium 4 2.53Ghz.
Memory = 2.0Gig
Drives = 3 x 100Gig

Please let me know if I have left anything out or if I need to provide additional information.  

This is my 2nd question on this board, the first one was the sam question but I think I goofed and put in the wrong topic, sorry!!  but I have heard it is the best.

Thank You All
Scott
0
Comment
Question by:Scott_Vandiver
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
6 Comments
 
LVL 104

Expert Comment

by:Sembee
ID: 12310127
Silly question - but have you enabled OMA? It isn't enabled by default.
You also need to enable the clients and probably support for "unsupported devices".

ESM, Global Settings, Mobile Services. Right click on Mobile Services and choose Properties. Select the last two boxes.

You should be able to browse to /oma so do that in testing before moving on.

Simon.
0
 

Author Comment

by:Scott_Vandiver
ID: 12311298
Good Question, but I have enabled the feature in both the ESM, and for each one of the users.  I have also enabled suppoprt for "unsupported devices".

This is a good starting point.  It is always good to get the easy stuff out of the way first.

Scott
0
 
LVL 104

Expert Comment

by:Sembee
ID: 12312647
You might want to look at this article from Microsoft. Do the technique only for the /OMA sub folder:

http://support.microsoft.com/default.aspx?kbid=883380

Simon.
0
SharePoint Admin?

Enable Your Employees To Focus On The Core With Intuitive Onscreen Guidance That is With You At The Moment of Need.

 

Author Comment

by:Scott_Vandiver
ID: 12316180
Simon,

Thank you for the link.  I tried the suggestion and this did not remove the error message.

Scott
0
 
LVL 104

Accepted Solution

by:
Sembee earned 500 total points
ID: 12324223
Try turning off friendly error messages in Internet Explorer on your desktop and browse to the /oma folder. See what error is thrown up.

Also check Authentication on the /oma virtual directory in IIS Manager. It should be basic and Integrated only. You should also pay attention to the default domain and default realm boxes.
If there is a domain listed, change it to be / only.
If it is currently / change it so that your domain is listed.
I cannot remember which way round it is and don't have access to a working system at the moment.

Anything else installed on this machine? Sharepoint for example?
Are you trying to use a non-standard port?

Simon.
0
 

Author Comment

by:Scott_Vandiver
ID: 12338402
No non standard port, and I do hav sharepoint on the machine.  It seems that the issue was the following:

Search for the following in the web.config in the \Program
Files\Exchsrvr\OMA\browse directory

<sessionState mode="InProc"

Then add the following on a new line above the <sessionState mode="InProc" line.

  <pages enableSessionState="true"/>
I had to restart the entire system for the changes to be taken, but after that it worked fine.

Scott
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
EXCHANGE, SPF 2 55
Add GoToMeeting Invites Rooms to Exchange Conference Rooms 2 56
exchange, IIS, AUTODISCOVER, OWA 18 64
Office 365 Spam 3 31
Marketers need statistics and metrics like everybody else needs oxygen. In this article we explain how to enable marketing campaign statistics for Microsoft Exchange mail.
Unified and professional email signatures help maintain a consistent company brand image to the outside world. This article shows how to create an email signature in Exchange Server 2010 using a transport rule and how to overcome native limitations …
In this video we show how to create a Resource Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: Navigate to the Recipients >> Resources tab.: "Recipients" is our default selection …
Exchange organizations may use the Journaling Agent of the Transport Service to archive messages going through Exchange. However, if the Transport Service is integrated with some email content management application (such as an antispam), the admini…

734 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question