Commands ignored by PDM


These commands are ignored by the PDM. I assume they are the reason I can’t use Windows VPN (Routing and Remote Access), Terminal Services and Remote administrator?

What is the correct syntax?

fixup protocol dns maximum-length 512
fixup protocol tftp 69
access-list outside_access_in permit tcp any host 192.168.227.210 eq pptp
access-list outside_access_in permit gre any host 192.168.227.210
access-list outside_access_in permit tcp any host 192.168.227.210 eq 3389
access-list outside_access_in permit tcp any host 192.168.227.210 eq 4899
dsl77Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

lrmooreCommented:
No, the fact that they are ignored by the PDM just means that you need to update your PDM. Latest version is 3.02
Being ignored by PDM has no bearing on the functionality of the PIX itself.

You are referencing a private IP address in your acl. Do you have a public IP-private IP address static mapping?
Is this in relation to the configuration you have posted here?
http://www.experts-exchange.com/Security/Firewalls/Q_21160129.html

If you are trying to do Windows VPN to a RRAS server inside the PIX, then you need an additional Public IP address that you can static nat to the RRAS server.



0
dsl77Author Commented:
Okay.. so theres i no need to update the PDM at the moment.

What must i do to make sure the Terminal Services and Radmin works?

I didn't know i needed an additional public IP to make RRAS work.. i don't recall haveing read about that one :(

Here the config:

interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password b4YMiQWlhCQP5KZD encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname vatican
domain-name thepope
clock timezone CEST 1
clock summer-time CEDT recurring last Sun Mar 2:00 last Sun Oct 3:00
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
no fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list outside_in permit tcp any interface outside eq smtp
access-list outside_in permit tcp any interface outside eq www
access-list outside_in permit tcp any interface outside eq ftp
access-list outside_in permit tcp any interface outside eq ftp-data
access-list outside_access_in permit tcp any host 192.168.227.210 eq pptp
access-list outside_access_in permit gre any host 192.168.227.210
access-list outside_access_in permit tcp any host 192.168.227.210 eq 3389
access-list outside_access_in permit tcp any host 192.168.227.210 eq 4899
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 195.184.116.126 255.255.255.252
ip address inside 192.168.227.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm location 192.168.227.0 255.255.255.0 inside
pdm location 192.168.227.210 255.255.255.255 inside
pdm location 192.168.1.0 255.255.255.0 inside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp interface smtp 192.168.227.210 smtp netmask 255.255.255.255 0 0
static (inside,outside) tcp interface www 192.168.227.210 www netmask 255.255.255.255 0 0
static (inside,outside) tcp interface ftp 192.168.227.210 ftp netmask 255.255.255.255 0 0
static (inside,outside) tcp interface ftp-data 192.168.227.210 ftp-data netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 3389 192.168.227.210 3389 netmask 255.255.255.255 0 0
access-group outside_in in interface outside
route outside 0.0.0.0 0.0.0.0 195.184.116.125 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http 192.168.1.0 255.255.255.0 inside
http 192.168.227.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-pptp
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
terminal width 80
Cryptochecksum:48b0160968686084a872139cafe4d8f0
0
lrmooreCommented:
> didn't know i needed an additional public IP to make RRAS work.. i don't recall haveing read about that one :(
It's because PPTP uses GRE which cannot be port-forwarded because it does not use ports..

Because the connection is initiated as TCP on one port and the response is GRE protocol, it is necessary to configure ACLs to allow the return traffic into the PIX, as the PIX Adaptive Security Algorithm (ASA) does not know the traffic flows are related. PPTP through the PIX with NAT (one-to-one address mapping) works because the PIX uses the port information in the TCP or User Datagram Protocol (UDP) header to keep track of translation. PPTP through the PIX with Port Address Translation (PAT) does not work because there is no concept of ports in GRE.


Forget these entries:
 no access-list outside_access_in permit tcp any host 192.168.227.210 eq pptp
 no access-list outside_access_in permit gre any host 192.168.227.210
 no access-list outside_access_in permit tcp any host 192.168.227.210 eq 3389
 no access-list outside_access_in permit tcp any host 192.168.227.210 eq 4899

add these entries to your existing acl:

    access-list outside_in permit tcp any interface outside eq 3389
    access-list outside_in permit tcp any interface outside eq 4899

re-apply the acl as always:

   access-group outsid_in in interface outside

Create a static for port 4899 just like you did for 3389 if you are using that:

    static (inside,outside) tcp interface 4899 192.168.227.210 4899 netmask 255.255.255.255 0 0

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
dsl77Author Commented:
Thanks lrmoore..

Can i use the 'clear' command inside the PDM to remove the wrong entries - if yes, how? :)
0
lrmooreCommented:
If they show up in the access rules page, just highlight them and delete each line, then apply..
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Software Firewalls

From novice to tech pro — start learning today.