Solved

XP Recovery Console and SP2

Posted on 2004-10-14
8
509 Views
Last Modified: 2010-04-03
Ok, the other night my computer blue screened and would no longer boot up.  Not sure why it blue screened, I and just started a search for a file and nothing else was running, so I assumed it was an overheating issue since I haven't cleaned the CPU heat sync in a while.  Anyway, I tried to use "Last Known Good Configuration" without any luck.  I then removed all hardware from the computer except the video card and one 512MB memory card.  Then I tried Safe Mode and Safe Mode Command Prompt, but it died right after Mup.sys loaded.  Now comes the wierd part, I boot to the Recovery Console using the XP Pro CD and it doesn't ask for the admin password, first clue something is terribly wrong.  I tried to LOGON Administrator, but it told me there may be a registry problem.  I then try to CD to the \WINDOWS directory, but it isn't there, second clue.  Then I DIR and notice the C: is actually mapped to my D:, so I run MAP, my C and D are swapped, normally I have my 20GB partition as the C and my 56GB partition as drive D.  BTW, both partitions are on the same 80GB HDD, with the 20GB partition being the boot.  So, I try to DIR the D: (which is suppose to be the C: and the boot partition), but it failed, basically telling me the directory format is unrecognized.  Ok, now I'm scared, so I run a chkdsk on both partitions and the C: passed, but the D: failed with unrecoverable errors.  Now I'm really scared, so I run buy Norton System works, thinking the partition is damaged.  Norton Recovery is not what it used to be, it just told me the directory format was unrecognized and wouldn't offer any solution!  I had Norton replace the MBR, just in case there was a boot sector virus or something messed up, but that didn't help.  When I try to boot to safe mode, I see the files being read from the normal boot partition \WINDOWS directory, so I know they are there.  Does anyone know if there is some new security feature that encrypts the file allocation tables with SP2?  I just installed it about 2 weeks ago before this crash.  Does anyone have any advice for repairing it, I need some of the files on my original C:?
0
Comment
Question by:mrichards0
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
8 Comments
 
LVL 1

Accepted Solution

by:
trimixdiver earned 64 total points
ID: 12308253
The only thing I can offer is putting in a disk you have lying around to boot from. Once your running with that disk use the question disk as a slave and try to search for your files. If there is some issue with SP2 (I dont think) being at the same level with a good disk might get you into the question disk
0
 
LVL 92

Assisted Solution

by:nobus
nobus earned 62 total points
ID: 12308369
you can try ontrack for recover, or some other ; links :

http://www.pcinspector.de/file_recovery/UK/welcome.htm            disk recovery free
http://www.zdnet.nl/downl_inter.cfm?id=34916&did=4196&sit=2      restore partition
http://www.webattack.com/Freeware/system/fwdatarecovery.shtml      Data recovery
http://www.cgsecurity.org//index.html?testdisk.html            Disk recovery  TestDisk
http://www.finaldata.com/                              date recovery
http://www.runtime.org/                              GetDataBack:

another solution is hooking the drive on another installation (which you should do for recovery also) and working from there
0
 
LVL 11

Assisted Solution

by:huntersvcs
huntersvcs earned 62 total points
ID: 12310483
If you can boot from the CD and get into the console - AND - have access to the swapped drive (D?) then you could try:

(a) Add a new HDD to your controller (partitioned and formatted, of course) and from the console try copying the files you desparately need to this new drive.

(b) If you don't have another HDD, then from the console edit the boot.ini to select the second partition as your source.

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(2)\WINNT
[operating systems]
multi(0)disk(0)rdisk(0)partition(2)\WINNT=. . . .

It sounds as though you have a definite problem with the MBR and the allocation tables in the startup sectors of your HDD.  Sometimes a low-level format can correct this problem, but takes a lot of patience and time.

The first priority should be:  SAVE THE DATA
Second priority:  Repairing or replacing the OS
Third:  Take preventive measures to make sure it doesn't happen again.

To achieve Priority 1 - see above and other comments.
To achieve Priority 2 - you could try partition magic, but "unrepairable errors" may prevent this.  Your best bet would be using a new HDD.  Even if you are successful in repairing the old one, I would only use it for backup purposes.
To achieve Priority 3 - I only deliver PCs with 2 HDDs, and always recommend imaging on a regular basis (about once every 4-5 months).  An automatic backup program should be in place to COPY all private data on a separate, physically separate HDD every week.  I wrote a program to do this, but you can easily write up an XCOPY batch file and place it under scheduled tasks to do the same thing.

You've got a lot of work cut out for yourself.  Hope at least part of this helps.
Rick
0
What Is Blockchain Technology?

Blockchain is a technology that underpins the success of Bitcoin and other digital currencies, but it has uses far beyond finance. Learn how blockchain works and why it is proving disruptive to other areas of IT.

 

Author Comment

by:mrichards0
ID: 12311206
Thanks for the comments, tonight I'm going to try installing a second hdd and then installing XP with SP2.  I'll see if that get's me into the other partition.  The D drive isn't accessable from the recovery console after booting off the CD.  I'm still concerned that I could see XP boot in safe mode (just before it reboots after loading mups.sys) and it's using the files from the original partition \WINDOWS directory, but in the recovery console I can't access that partition.  It makes me think that there is some sort of security thing going on.  I'll try the partition magic idea if all else fails.  

Thanks,

- Matt
0
 

Assisted Solution

by:Swylen
Swylen earned 62 total points
ID: 12350129
Try using testdisk @ http://www.cgsecurity.org/

It's the right price and fixes bad MBR's.
0
 
LVL 11

Expert Comment

by:huntersvcs
ID: 12538994
After my last comment, mrichards0 indicated that he would "try out" the suggestions submitted so far.  Evidently at least one of them was of some use - otherwise I would expect some kind of feedback.  Perhaps it was forgotten that inquiries have to be closed / suggestions accepted.  If no further comments from mrichards0 are received, recommend a split in points.
0
 

Author Comment

by:mrichards0
ID: 12539285
I split the points, it turns out the hard drive failed completely before I was able to do anything.  I tried a few of the comments, but the hdd deteriated before anything could be done until it wouldn't even be recognized by the bios as a drive.  Thanks for the comments, though.
0

Featured Post

Enterprise Mobility and BYOD For Dummies

Like “For Dummies” books, you can read this in whatever order you choose and learn about mobility and BYOD; and how to put a competitive mobile infrastructure in place. Developed for SMBs and large enterprises alike, you will find helpful use cases, planning, and implementation.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Concerto Cloud Services, a provider of fully managed private, public and hybrid cloud solutions, announced today it was named to the 20 Coolest Cloud Infrastructure Vendors Of The 2017 Cloud  (http://www.concertocloud.com/about/in-the-news/2017/02/0…
When we purchase storage, we typically are advertised storage of 500GB, 1TB, 2TB and so on. However, when you actually install it into your computer, your 500GB HDD will actually show up as 465GB. Why? It has to do with the way people and computers…
This tutorial will walk an individual through the process of installing the necessary services and then configuring a Windows Server 2012 system as an iSCSI target. To install the necessary roles, go to Server Manager, and select Add Roles and Featu…
This Micro Tutorial will teach you how to reformat your flash drive. Sometimes your flash drive may have issues carrying files so this will completely restore it to manufacturing settings. Make sure to backup all files before reformatting. This w…
Suggested Courses

626 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question