Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 382
  • Last Modified:

Connecting XP Pro to W2000 Pro via Ethernet and TCP/IP

Hi. I have a laptop running XP Pro (SP1), and a desktop running W2000 Pro (SP4). I have a (working!) crossover cable connnecting the two NICs. I have the desktop NIC set up to use IP address 192.168.0.5 and the laptop to use IP address 192.168.0.4. Both NICs have file and printer sharing enabled. But when I try to map a share on one computer from the other, I can't get it to work (in either direction). It used to work when the laptop had W2000 with NetBEUI installed, but WinXP doesn't support that. I know I could install NetBEUI from the WinXP CD, but why doesn't the TCP/IP connection work? What have I missed? (I'm new to XP).
0
charl39
Asked:
charl39
  • 3
  • 2
  • 2
1 Solution
 
Lee W, MVPTechnology and Business Process AdvisorCommented:
Can you ping the machines?  Are you SURE it's a crossover cable?  Are you sure you've set the IPs correctly (I once used 192.168.1.1 and 192.168.0.2 and it didn't work because I used a subnet mask of 255.255.255.0 but I thought both systems were on the same 0 (not 1) network.
0
 
charl39Author Commented:
No, pinging times out. The status of the connection says on moth sides that many packets have been sent but very few received (but greater than zero). And yes, I'm sure it's a crossover cable; I used it up till this morning on the W2000 laptop!
0
 
charl39Author Commented:
Actually if I bring up the NIC status window on the one box, and ping it from the other, I can see the byte count going up as the pings arrive, but the sender still times out. This is driving me insane!!!
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
adamdrayerCommented:

Goto the properties of the Network Connection and click the advanced tab.  See if you have "Protect my computer ..." checked.  This is a built-in firewall that comes with XP SP1.  It can often block pings and sharing with other computers.  For testing purporses you can turn it off for now.

Now go back to the General tab and into the TCP/IP properties.  Click the Advanced Button and goto the WINS tab.  Make sure that "NetBIOS over TCP/IP" is enabled.

You'll need to do this last bit on both computers.
0
 
Lee W, MVPTechnology and Business Process AdvisorCommented:
EXCELLENT point adam - I totally forgot about that - I had similar problems with a client that were caused by the XP Firewall.
0
 
adamdrayerCommented:
yeah, you think that Microsoft would alert its users that it is now blocking access to peer-to-peer networking.

thanks.
0
 
charl39Author Commented:
That's it! Turned off the firewall, worked immediately... thanks.
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 3
  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now