Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3489
  • Last Modified:

Cisco Router Model #3640 CRC/Frame Errors on Ethernet Int, major packet loss

I have a class c split up into two subnets. Ethernet0/1 (Subnet #1) is also displaying the same kind of errors you see below but we are not experiencing the same kind of packet loss there. It seems to be functioning properly. The second ethernet interface (Subnet #2) below Ethernet1/0, we are seeing 60% packet loss all across the board.

I have seen this before, as far as symptoms anyway. My prior experience>I went onsite to troubleshoot the same symptoms for a client and found that he had the switch crossed over to itself. That obviously was causing the problem, voila easy fix. Not the case here. Doesn't seem like a layer 1 problem. I've tried to rule out the obvious but I could be missing something for sure.  

 I haven't had a lot of time to dive into this. I know a lot of you are smarter then I and may be able to give me a few ideas as to some things I could try. I will post any further information any of you need in the way of router configuration, network configuration.

Everything on the wan side/serial is clean. No erros. Everything looks good from theirs to ours.

Ethernet1/0 is up, line protocol is up
  Hardware is AmdP2, address is xxxx.xxxx.xxxx (bia xxxx.xxxx.xxxx)
  Internet address is 6x.xxx.xxx.xxx/25
  MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
     reliability 255/255, txload 11/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:03, output 00:00:00, output hang never
  Last clearing of "show interface" counters 12:20:09
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 3000 bits/sec, 4 packets/sec
  5 minute output rate 447000 bits/sec, 461 packets/sec
     203956 packets input, 73643721 bytes, 0 no buffer
     Received 595 broadcasts, 0 runts, 0 giants, 0 throttles
     10013 input errors, 10013 CRC, 5043 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     9460395 packets output, 1225723073 bytes, 0 underruns
     94 output errors, 0 collisions, 0 interface resets
     0 babbles, 0 late collision, 0 deferred
     94 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
0
coleresources
Asked:
coleresources
  • 3
  • 3
1 Solution
 
JFrederick29Commented:
You should start by replacing the patch cable from the interfaces.  You'll also want to make sure speed and duplex settings are set properly.  Make sure the interface speed and duplex match the other end of the connection, either auto negotiation or 10 half.  Both ends of the connection need to be the same.
0
 
coleresourcesAuthor Commented:
I did replace patch cables.

Switch is not managed but the led readouts verify (as much as they can) that itself and the router are on the same page as far as duplexing is concerned.

I had to replace their prior router with this other because we needed another serial port. Everything was working fine before, makes me think the module may be problematic? Man I hope not! I know some of you are probably rolling your eyes at the fact that the switch is not managed because it would make the most sense to have one but it has not become feasible yet. So I am trying to make their existing setup work.

As far as the router's ether interfaces duplex=10 full.

Thank you for your response and any further help would be greatly appreciated.

Best Regards
0
 
JFrederick29Commented:
If the switch is unmanaged, make sure the router's ethernet interfaces are set to:

interface ethernet0/1
speed auto
duplex auto

Can you post a "show run int e0/1"

0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
coleresourcesAuthor Commented:
Yes Sir...Here goes...It is actually Ether1/0 that is problematic or so it would seem. I will try setting to auto/auto but the functioning ethernet interface is configured the same way and seems to do ok. But each subnet has their own switch and they are not the same make and model. So it may be reacting differently.  

Current configuration : 134 bytes
!
interface Ethernet1/0
 ip address 66.208.187.126 255.255.255.128
 ip access-group 110 in
 ip access-group 110 out
 full-duplex
0
 
JFrederick29Commented:
Your Ethernet1/0 interface is configured with full-duplex, this is probably the reason your are experiencing errors.  Most likely, the other end of the switch (being unmanaged) is running auto negotiation.  You want to run auto negotiate on the Ethernet interface as well.  Try auto, then clear the counters on the Ethernet interface and see if they begin to rise.
0
 
happythedogCommented:
auto negotiation causes some congestion , both sides must send frames to set speed  try full/full
0
 
coleresourcesAuthor Commented:
I set it to half and I am not seeing nearly as much loss now, not nearly 60%. The more I thought about it, the switch that the problematic interface terminates to is older and not quite as smart. It seems to be ok at half right now. I hate that I am seeing any loss but this will buy me some time seeing as how it is at least functioning. Thank's for your time.
0

Featured Post

Become an Android App Developer

Ready to kick start your career in 2018? Learn how to build an Android app in January’s Course of the Month and open the door to new opportunities.

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now