How can I open Outlook without login prompt when profile is configured for RPC over HTTPS

Hey guys. I got RPC over HTTPs working fine on my network. I am using a single Exchange server as both the proxy and back-end server. I have also configured an SSL certificate from Verisign. Outlook connects using either HTTPs or TPC/IP depending on my location.

So all works well but i have a simple question.
Everytime i start an Outlook profile configured for RPCoHTTPS, I get a login prompt for my Exchange server.  I log in fine upon entering the proper credentials. Is there a way i can save the login information so it won't prompt me everytime i start Outlook? Apparently the Rember this password option doesn't appear. Any thoughts?
, Thanks
hshaalanAsked:
Who is Participating?
 
SembeeCommented:
The prompt can be removed if the machine is a member of the same domain. If it didn't then I think that the deployment of RPC/HTTPS would be very low - the users would revolt.
Instead I now set it as standard for all laptops on sites with the feature enabled - heck the machine I am using right now is using RPC/HTTPS and doesn't get the second prompt.
It is just a matter of getting the authentication process correct - and that article explains what you need to do to allow pass through authenication to work.

Simon.
0
 
SembeeCommented:
If the machine is a member of the same domain as the Exchange server then you can adjust some settings to get rid of the prompts: http://support.microsoft.com/?kbid=820281

If the machine is not a member of the domain then you will get a prompt - which is by design and cannot be changed.

Simon.
0
 
marc_nivensCommented:
I don't think you can get rid of the prompt when using RPC/HTTP.
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
hshaalanAuthor Commented:
You were right Simon. I read the KB article and realized that I have IIS configured for Basic Autentication. I cleared that option. Tried again still got prompted. Then i changed Outlook proxy settings to use NTLM instead of Bais authetnication. Tried again still got prompted. Then i saw in the article that i have to chagne my registery settings and a value of 2 or 3 for the LPS key under Current control set. Tried again and this time Did not get prompted. So all is well. Now i have to see how non-domain client machines can bypass the login prompt.
Thanks again Simon
0
 
marc_nivensCommented:
Nice one Simon :-)
0
 
SembeeCommented:
Did you manage to get this working correctly?
If so, then you should close the question and award the points.
If you still need assistance then please post back so that the issue can be resolved.

Simon.
0
 
primarionCommented:
your fix was great. It worked for me too. i had the same issue of prompting for password on workstations that are part of the domain. the problem is now fixed.
0
 
hshaalanAuthor Commented:
Sembee:
i can't find a way to close the question. I had accepted your answer on 10/14/2004 and belive the points were awarded then. If not, then tell me how to close it. I am logged in and can't see a button to do that.
, Thanks
0
 
SembeeCommented:
The question was closed and the points awarded.
One of the features of EE is that other people can post on a question even after it has been closed.

Simon.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.