Solved

Viewsonic A91f+ Monitor Setup

Posted on 2004-10-14
8
825 Views
Last Modified: 2013-12-15
I would appreciate help setting up a Viewsonic UltraBrite A91f+ monitor in either Suse 9.1 or Fedora Core 1.  X refuses to run at any resolution higher than 640 by 480. Display is spread much wider than monitor at higher resolutions.  Attempts at configuring using SaX2 in Suse and manual editing of the xfree86 config file in Fedora have both failed.  Link to monitor specs is at http://www.viewsonic.com/products/desktopdisplays/crtmonitors/aseries/a91f/
0
Comment
Question by:slow1000
  • 4
  • 2
  • 2
8 Comments
 
LVL 40

Expert Comment

by:jlevie
ID: 12315015
The monitor specs would tend to suggest that it shouldn't have any problems with any res your video card can support. I'd guess your problem is more likely related to the card. What do you have?
0
 
LVL 8

Author Comment

by:slow1000
ID: 12315662
The graphics card is a 64mb 350 mhz Radeon 7000.  As an aside, this setup does work fine with Windows XP.  My first suspicion is that something about this monitor which just came out is a bit special, and both my and Suse's configuration failed to take that into account.  
0
 
LVL 40

Expert Comment

by:jlevie
ID: 12315830
I'm pretty sure that it is your video card that's the problem. Try a web search for 'radeon 7000 linux' and you see a number of people having problems with that card, even on Fedora Core 2. Given that FC2 is right at the "bleeding edge" in development it is even less likely that the card will work with FC1 or SuSE.
0
 
LVL 8

Author Comment

by:slow1000
ID: 12316121
While you may be right, I have had this same system with a previous 17" monitor work well with both Linux operating systems.  The Fedora Core 1 installation is the same, but Suse 9.1 has been installed since switching to the Viewsonic monitor.

Here is the relevant current XF86Config file info from Fedora:

Section "Monitor"
      Identifier   "Monitor0"
      VendorName   "ViewSonic"
      ModelName    "Monitor a91f+"
      DisplaySize  1024      768
      HorizSync    30.0 - 86.0
      VertRefresh  50.0 - 180.0
      Option          "dpms"
EndSection

Section "Device"
      Identifier  "Videocard0"
      Driver      "radeon"
      VendorName  "Videocard vendor"
      BoardName   "ATI Radeon 7000"
EndSection

Section "Screen"
      Identifier "Screen0"
      Device     "Videocard0"
      Monitor    "Monitor0"
      DefaultDepth     24
      SubSection "Display"
            Depth     24
            Modes    "1024x768" "800x600" "640x480"
      EndSubSection
      SubSection "Display"
            Depth     16
            Modes    "1024x768" "800x600" "640x480"
      EndSubSection
EndSection
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 
LVL 9

Accepted Solution

by:
gtkfreak earned 500 total points
ID: 12378060
Try out the following:
# cp /etc/X11/XF86Config /etc/X11/XF86Config.mybkup

# vi /etc/X11/XF86Config
You will then see something like this i.e. Section "Monitor". Check the HorizSync and VertRefresh Values with those in your monitor manual and change the range to that supported by your monitor. My monitor got detected correctly and the values are correct, as per the monitor manual. Also, do not put 1024 768 display Size with your Monitor Section.

Section "Monitor"
     Identifier   "Monitor0"
     VendorName   "Monitor Vendor"
     ModelName    "SyncMaster"
     DisplaySize  280     210
     HorizSync    30.0 - 55.0
     VertRefresh  50.0 - 120.0
     Option         "dpms"
EndSection

Then at Section "Screen", look for 1024x768 and remove it.

Section "Screen"
     Identifier "Screen0"
     Device     "Videocard0"
     Monitor    "Monitor0"
     DefaultDepth     24
     SubSection "Display"
          Depth     24
          Modes    "1024x768" "800x600" "640x480"
     EndSubSection
EndSection

After you make the changes indicated, save your XF86Config file and start up X. To start X from command prompt, type startx.

In case you have a problem after this, then you can restore back the original XF86Config by:
# cp /etc/X11/XF86Config.mybkup /etc/X11/XF86Config
and restart X again

You can try out the various resolutions by pressing Ctrl+Alt+ + or - to see which one works for you.
0
 
LVL 9

Expert Comment

by:gtkfreak
ID: 12378076
The XF86Config file is not there in FC2. You can check out /etc/X11/xorg.config in the same path. Before doing anything, please backup the xorg.config file, so that you are able to restore it back in case of problem.

0
 
LVL 8

Author Comment

by:slow1000
ID: 12455012
gtkfreak, thank you for your input.  Unfortunately, your suggestion did not work, but I think your solution would have worked with almost all monitors. Also, I did try removing the section from the monitor that specified a 1024 x 768 resolution, but I don't think this was the problem.  My monitor is running at 640 x 480, and I would be satisfied if it were to run at 1024 x 768.   This monitor seems to be especially stubborn.  I plan on trying it with Mandrake on a completely different system to see if I have better results.
0
 
LVL 8

Author Comment

by:slow1000
ID: 15325086
I appologize for not closing this earlier.  Unfortunately, I never did resolve the issue, but upgrading to FC3 and Suse 9.3 made the problem go away.  Gtkfreak provided the info that seemed most germane (the problem apparently was X), hence the accepted answer.
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Daily system administration tasks often require administrators to connect remote systems. But allowing these remote systems to accept passwords makes these systems vulnerable to the risk of brute-force password guessing attacks. Furthermore there ar…
It’s 2016. Password authentication should be dead — or at least close to dying. But, unfortunately, it has not traversed Quagga stage yet. Using password authentication is like laundering hotel guest linens with a washboard — it’s Passé.
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

23 Experts available now in Live!

Get 1:1 Help Now