Solved

excessive and consistent crc errors on ethernet interfaces on a cisco 3640

Posted on 2004-10-14
6
1,334 Views
Last Modified: 2008-01-09
I've just replaced a cisco 4500 with a multilink ppp config that had 4 T1's bonded with a cisco 3640 with 5 T1's bonded in the same mlppp config. Everything works but I am getting excessive errors on the two ethernet interfaces. I have posted the sho int here in the body. I will post the sho run at the end of the post. This is a very high traffic router and performance is suffering. Any idea's  or suggestions would be greatly appreciated.

The 4500 had some minimal packet loss, but it has been attributed to high cpu usage (80% and above most of the time). The class c is divided into two subnets /25. We have one eth port going to each switch connected on the network. We are running a LVS linux cluster that has an arp problem, so we placed each real server cluster on a different subnet to resolve it.

eth0/0
  Keepalive set (10 sec)
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters 20:02:49
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 5843000 bits/sec, 572 packets/sec
  5 minute output rate 3000 bits/sec, 7 packets/sec
     27515912 packets input, 924950385 bytes, 0 no buffer
     Received 4346 broadcasts, 0 runts, 0 giants, 0 throttles
     7450 input errors, 7429 CRC, 3650 frame, 0 overrun, 21 ignored
     0 input packets with dribble condition detected
     580746 packets output, 101271934 bytes, 0 underruns
     699 output errors, 194428 collisions, 1 interface resets
     0 babbles, 0 late collision, 25813 deferred
     33 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
Serial0/0 is up, line protocol is up
  Hardware is QUICC with integrated T1 CSU/DSU
  Description: KMC T1/5 to unitnet.com
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
     reliability 255/255, txload 220/255, rxload 18/255
  Encapsulation PPP, LCP Open, multilink Open, loopback not set
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters 22:04:08
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  30 second input rate 109000 bits/sec, 126 packets/sec
  30 second output rate 1334000 bits/sec, 484 packets/sec
     5633898 packets input, 556375929 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     16 input errors, 0 CRC, 16 frame, 0 overrun, 0 ignored, 0 abort
     21629956 packets output, 3124206619 bytes, 0 underruns
     0 output errors, 0 collisions, 38 interface resets
     0 output buffer failures, 0 output buffers swapped out
     1 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

Serial0/1 is up, line protocol is up
  Hardware is QUICC with integrated T1 CSU/DSU
  Description: KMC T2/5 to unitnet.com
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
     reliability 255/255, txload 220/255, rxload 18/255
  Encapsulation PPP, LCP Open, multilink Open, loopback not set
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters 22:04:10
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  30 second input rate 110000 bits/sec, 126 packets/sec
  30 second output rate 1334000 bits/sec, 483 packets/sec
     5634175 packets input, 556401050 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     2 input errors, 0 CRC, 2 frame, 0 overrun, 0 ignored, 0 abort
     21611356 packets output, 3118964339 bytes, 0 underruns
     0 output errors, 0 collisions, 5 interface resets
     0 output buffer failures, 0 output buffers swapped out
     1 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

Ethernet1/0 is up, line protocol is up
  Hardware is AmdP2, address is 00b0.64e9.e111 (bia 00b0.64e9.e111)
  Internet address is xx.xx.xx.xx/25
  MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
     reliability 255/255, txload 12/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:07, output 00:00:00, output hang never
  Last clearing of "show interface" counters 20:02:50
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 12000 bits/sec, 14 packets/sec
  5 minute output rate 478000 bits/sec, 417 packets/sec
     560840 packets input, 139637730 bytes, 0 no buffer
     Received 1496 broadcasts, 0 runts, 0 giants, 0 throttles
     25348 input errors, 25348 CRC, 12724 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     19350152 packets output, 2651298099 bytes, 0 underruns
     94 output errors, 0 collisions, 0 interface resets
     0 babbles, 0 late collision, 0 deferred
     94 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
Serial1/0 is up, line protocol is up
  Hardware is QUICC with integrated T1 CSU/DSU
  Description: KMC T3/5 to unitnet.com
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
     reliability 255/255, txload 220/255, rxload 17/255
  Encapsulation PPP, LCP Open, multilink Open, loopback not set
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters 22:04:12
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  30 second input rate 104000 bits/sec, 125 packets/sec
  30 second output rate 1338000 bits/sec, 486 packets/sec
     5632817 packets input, 556067550 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     21657142 packets output, 3132671755 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 output buffer failures, 0 output buffers swapped out
     1 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

Serial1/1 is up, line protocol is up
  Hardware is QUICC with integrated T1 CSU/DSU
  Description: KMC T4/5 to unitnet.com
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
     reliability 255/255, txload 221/255, rxload 17/255
  Encapsulation PPP, LCP Open, multilink Open, loopback not set
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters 22:04:13
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 1/40 (size/max)
  30 second input rate 106000 bits/sec, 126 packets/sec
  30 second output rate 1340000 bits/sec, 485 packets/sec
     5631851 packets input, 555821580 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     21635956 packets output, 3126147730 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 output buffer failures, 0 output buffers swapped out
     1 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

Ethernet2/0 is administratively down, line protocol is down
  Hardware is AmdP2, address is 00b0.64e9.e121 (bia 00b0.64e9.e121)
  Internet address is xx.xx.xx.xx/25
  MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
     reliability 128/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output 10:01:57, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     4406 packets output, 265859 bytes, 0 underruns
     4406 output errors, 0 collisions, 2 interface resets
     0 babbles, 0 late collision, 0 deferred
     4406 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
Serial2/0 is up, line protocol is up
  Hardware is QUICC with integrated T1 CSU/DSU
  Description: KMC T5/5 to unitnet.com
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
     reliability 255/255, txload 221/255, rxload 17/255
  Encapsulation PPP, LCP Open, multilink Open, loopback not set
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters 22:04:15
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  30 second input rate 104000 bits/sec, 126 packets/sec
  30 second output rate 1340000 bits/sec, 485 packets/sec
     5629969 packets input, 555911719 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     21634640 packets output, 3125201820 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 output buffer failures, 0 output buffers swapped out
     1 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

Virtual-Access1 is down, line protocol is down
  Hardware is Virtual Access interface
  MTU 1500 bytes, BW 100000 Kbit, DLY 100000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, LCP Closed
  Base VtMgr vaccess
  Vaccess status 0x0, loopback not set
  DTR is pulsed for 5 seconds on reset
  Last input never, output never, output hang never
  Last clearing of "show interface" counters 22:04:12
  Input queue: 0/4096/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions
Virtual-Template1 is down, line protocol is down
  Hardware is Virtual Template interface
  Internet address is xx.xx.xx.xx/30
  MTU 1500 bytes, BW 100000 Kbit, DLY 100000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, LCP Closed, multilink Closed
  Closed: BACP, loopback not set
  DTR is pulsed for 5 seconds on reset
  Last input never, output never, output hang never
  Last clearing of "show interface" counters 22:04:16
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions
Virtual-Access2 is up, line protocol is up
  Hardware is Virtual Access interface
  Internet address is xx.xx.xx.xx/30
  MTU 1500 bytes, BW 7720 Kbit, DLY 100000 usec,
     reliability 255/255, txload 191/255, rxload 14/255
  Encapsulation PPP, LCP Open, multilink Open
  Open: IPCP
  MLP Bundle vaccess, cloned from Virtual-Template1
  Vaccess status 0x40, loopback not set
  DTR is pulsed for 5 seconds on reset
  Last input 00:00:00, output never, output hang never
  Last clearing of "show interface" counters 21:24:53
  Input queue: 0/75/1695/0 (size/max/drops/flushes); Total output drops: 321167
  Queueing strategy: fifo
  Output queue: 40/40 (size/max)
  5 minute input rate 433000 bits/sec, 417 packets/sec
  5 minute output rate 5800000 bits/sec, 578 packets/sec
     20621032 packets input, 2596451495 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 696 ignored, 0 abort
     28873724 packets output, 1881009883 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions
Building configuration...

Current configuration : 2561 bytes
!
! Last configuration change at 17:00:58 CDT Thu Oct 14 2004
! NVRAM config last updated at 15:37:59 CDT Thu Oct 14 2004
!
version 12.3
no service pad
service timestamps debug datetime localtime
service timestamps log datetime localtime
service password-encryption
!
hostname unitnet_3640
!
boot-start-marker
boot-end-marker
!
enable password 7 131607005A02032C7A212437
!
clock timezone CST -6
clock summer-time CDT recurring
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
ip domain name unitnet.com
ip name-server 66.208.187.129
ip name-server 66.208.187.132
!
ip audit notify log
ip audit po max-events 100
virtual-profile virtual-template 1
multilink virtual-template 1
no ftp-server write-enable!
!
interface Ethernet0/0
 ip address xx.xx.xx.xx 255.255.255.128
 ip access-group 110 in
 ip access-group 110 out
 half-duplex
!
interface Serial0/0
 description KMC T1/5 to unitnet.com
 no ip address
 encapsulation ppp
 no ip route-cache
 no ip mroute-cache
 load-interval 30
 no fair-queue
 ppp multilink
!
interface Serial0/1
 description KMC T2/5 to unitnet.com
 no ip address
 encapsulation ppp
 no ip route-cache
 no ip mroute-cache
 load-interval 30
 no fair-queue
 ppp multilink
!
interface Ethernet1/0
 ip address xx.xx.xx.xx 255.255.255.128
 ip access-group 110 in
 ip access-group 110 out
 full-duplex
!
interface Serial1/0
 description KMC T3/5 to unitnet.com
 no ip address
 encapsulation ppp
 no ip route-cache
 no ip mroute-cache
 load-interval 30
 no fair-queue
 ppp multilink
!
interface Serial1/1
 description KMC T4/5 to unitnet.com
 no ip address
 encapsulation ppp
 no ip route-cache
 no ip mroute-cache
 load-interval 30
 no fair-queue
 ppp multilink
!
interface Ethernet2/0
 ip address xx.xx.xx.xx 255.255.255.128
 shutdown
 half-duplex
!
interface Serial2/0
 description KMC T5/5 to unitnet.com
 no ip address
 encapsulation ppp
 no ip route-cache
 no ip mroute-cache
 load-interval 30
 no fair-queue
 ppp multilink
!
interface Virtual-Template1
 ip address xx.xx.xx.xx 255.255.255.252
 ip access-group 110 in
 ip access-group 110 out
 ppp multilink
!
ip default-gateway xx.xx.xx.xx
no ip http server
no ip http secure-server
ip classless
ip route 0.0.0.0 0.0.0.0 xx.xx.xx.xx
!
!
access-list 110 deny   tcp any any eq 135
access-list 110 permit ip any any
!
!
snmp-server community unitnet_3640 RO
snmp-server enable traps tty
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
 password 7 130847065B1E067A2A30
 login
!
ntp clock-period 17180058
ntp server 192.43.244.18
!
!
end

unitnet_3640#
0
Comment
Question by:sittnduck
6 Comments
 
LVL 13

Expert Comment

by:Dr-IP
ID: 12315372
You are overloading the Ethernet interface; you simply can’t run that much bandwidth through a 10 Meg half duplex connection. The only fix it’s to replace the Ethernet interface with a fast Ethernet interface, or reduce the load on it.
0
 
LVL 13

Expert Comment

by:Dr-IP
ID: 12315413
Just noticed it’s a full duplex 10 megabyte connection, but really makes no difference on the load being too much for it, but some of the errors might be coming from a duplex mismatch. Does the other side support full duplex Ethernet, and do you have it locked to full duplex?
0
 

Author Comment

by:sittnduck
ID: 12315474
when i put it to full duplex the input errors start incrementing, and packet loss becomes worse, but the collisions stop. They are both plugged in to 10/100 ports on 2 different non-manged linksys switches. I agree on the need for an FE port, working on that, but even in low traffic hours the crc errors keep increasing.
0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 
LVL 13

Assisted Solution

by:Dr-IP
Dr-IP earned 300 total points
ID: 12315707
The problem is most unmanaged switches only do half duplex on 10M Ethernet, so seeing the error count climb when locked to full duplex is not unexpected. One thing I did notice is you have a second Ethernet interface, and that it was shut down when you did a show IP interfaces. Why don’t you split the /25 network in two /26’s instead. You will only lose a few address from the subnetting, and unless all the bandwidth is going to one address, it could bring the loads down to acceptable levels for 10M Ethernet interfaces.    
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 12315836
> 25348 input errors, 25348 CRC, 12724 frame, 0 overrun, 0 ignored
Have you tried replacing the patch cable on this interface with a good CAT5 cable?
0
 
LVL 5

Accepted Solution

by:
AutoSponge earned 200 total points
ID: 12328457
 5 minute input rate 12000 bits/sec, 14 packets/sec
  5 minute output rate 478000 bits/sec, 417 packets/sec

That looks like a DOS attack from the LAN to me.  I'd run some ip accounting and look for the top-talkers.  Shut down the worst offender(s) and see if the problem resolves.  I saw something like this recently where an old version of SKUL was loaded on the SQL servers (and a designer's workstation running SQL server) and caused high output like this which killed the interface.

Another possibility is if you have any switches or traffic consolidators that you have plugged in twice to the same network they can loop traffic and cause this (usually kills the CPU as much as the interface though).

Don't set to full-duplex, your interface is only capable of half.  You may limit the collissions but that's just going to halt retransmits which will kill the performance for the user application.

Double check any routing that you're doing and any VLANS you have setup to make sure only traffic destined for that router is hitting the interface.  I'm guessing that you have a lot more traffic hitting it than is really needed and you can save yourself some headaches by using bettter gateway definitions, routing, switching, and WINS to keep bogus traffic to a minimum.
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

Suggested Solutions

This article is a guide to configure bridging on Cisco Routers.  This is something I never knew was possible until after making a few phone calls to Cisco.  Using bridging saved our company money by not requiring us to purchase a new switch.  Bridgi…
I have seen some questions on problems with SSH/telnet access to Cisco routers that may occur despite the fact that from a PC connected to your LAN, Internet connectivity is in place and users can access Internet sites without any issues.  There are…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

757 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now