• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 265
  • Last Modified:

connecting Linux PC to a Linksys WRT54GS wireless router

Just installed Redhat Fedora Core 1 on an old PC and it appears to be correctly installed.

Ultimately, I want to get this connected via the wireless card, but for now I'm just focussing on connecting directly to the router.

Haven't been able to connect to the Internet yet.  Am able to connect to the router via ethernet cable and get to the admin page, but still no Internet.

I know the router's working, as I have two laptops that are connecting to the Internet through it wirelessly.

What else to I need to do to get this working?  (I'm assuming that the router can provide access via both wireless and ethernet at the same time.)  Is there something I need to enable in the router admin page?

Thanks.

Leprechaun

0
Leprechaun
Asked:
Leprechaun
  • 2
  • 2
1 Solution
 
TRobertsonCommented:
Is fedora recognizing your wireless card.
Do you have any type of WEP turned on?
0
 
de2ZotjesCommented:
Most likely you do not have a default route set.

type netstat -rn
check the output for a line starting with 0.0.0.0
if the line is there check that the destination for that line is the ip-address for the router. if not start of with deleting the existing default route:
 route del -net default gw <ip-address>

if there is no default route line :
 route add -net default gw <ip-address-router>

If you do have a proper default route, then my next check would be the firewall functionality of the router, perhaps the ip-address of your new laptop is not allowed to pass the firewall?
0
 
LeprechaunAuthor Commented:
Thanks for the suggestions, folks.  Sorry for the delay in responding, but the PC's at home and Ive been working late, so I haven't been around it much.

Well, now my PC is now longer booting!  After I enter my user name & pwd, I get a blue screen.  The mouse cursor is there (and moves), but nothing else happens.

What should I do, start a new thread?  Or can we change topics?

Thanks.

Leprechaun
0
 
de2ZotjesCommented:
What bootmanager do you use? Grub or Lilo ?

LILO: start the regular kernel image(linux probably), but append single to the end. So at the prompt type:
linux single

GRUB: bit more involved. It probably shows a menu. Select the boot option you want and press "e" (I think, check the help line at the bottom of the menu)
After that, you can edit the line that loads the kernel, append single to the end of the line. and boot

If you get to single mode, step up to runlevel 3 by entering: init 3 on the prompt.

Runlevel 3 is a fully functional system, exept for that graphical goodies. Try to start those from the promtp by issuing: startx

Let us know where you are getting..
0
 
LeprechaunAuthor Commented:
Thanks, de2Zotjes.  Am not sure what boot mgr I use. Will try your instructions when I get home tonight.
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now