SBS 2003, Exchange OMA and Active sync problem

I'm trying to set up mobile access on our Exchange server (SBS 2003). When I try to access the https://my domain/oma, I get the following error:

"Outlook(R) Mobile Access is supported only on Microsoft(R) Exchange Server 2003. Currently your mailbox is stored on an older version of Exchange server. Please contact your system administrator for additional assistance."

Also, when I try to sync a pda with the server, I get the http_500 error in active sync. Help!
HavelandAsked:
Who is Participating?
 
ee_ai_constructConnect With a Mentor Commented:
Question answered by asker or dialog valuable.
Closed, 500 points refunded.
ee_ai_construct (replacement part #xm34)
Community Support Admin
0
 
scampgbCommented:
Hi Haveland,

I've not been able to recreate this myself, but I found an article about it : http://www.eggheadcafe.com/ng/microsoft.public.exchange.mobility/post177284.asp

Here's an excerpt:
make sure the the exchangevdir  registry value under  
 
"HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MasSync\Parameters"  
 
is present and correct.  
 
It should be set to the following if its an SBS Server.  
 
ExchangeVDir  Type: Reg_SZ  
 
Data: /exchange-oma  
 
Make sure that the virtual directory specified in the registry value is  present under the default website in IIS Manager.  



Hope this helps
0
 
HavelandAuthor Commented:
Hi scampgb,
I've already checked this and the values are correct.
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
HavelandAuthor Commented:
One more thing, I recieve this error in the event log when I try to access the OMA web.

EventID: 1802
Source: MSExchangeOMA
Description:
User [user]@[domain] has Microsoft(R) Exchange server [Servername], which is not running Exchange Server 2003. That server is not accessible by Outlook(R) Mobile Access.

The oma web has worked before, but after I created a new certificate for SSL connection, it doesn't. I don't think the certificate is the problem though, because it looks ok and I can connect to the server through SSL.
0
 
scampgbCommented:
Haveland:
Do you have more than one Exchange server in your domain?

Is [Servername] above the name of the only Exchange server you have, and that one is running OMA?
The message seems to suggest that the mailbox for this user is on a different server.
0
 
HavelandAuthor Commented:
I followed Microsoft article: 817379, and created a secondary virtual directory for Exchange, and then added a registry value to point to the new virtual directory. It's now working correctly.
0
 
scampgbCommented:
RomMod:  Fine with me.
Haveland: Glad you got it sorted :)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.