Need two network XP Pro Dual NICs to two seperate Networks

I have an XP Pro system with Dual NICs  connected to separate networks each with different IP schemes.  One is  a 192.168.X.X and the other is 2.1.X.X  I need computers from both networks to talk to the system however I need all outbound traffic to route to the 192.168.X.X network first before trying to go out the 2.1.X.X network.  Is there a way to make this happen?
infutechAsked:
Who is Participating?
 
TannerManConnect With a Mentor Commented:
I know the spacing may be difficult to view if your not familiar with route table edits. The below example has an UNDERSCORE where each space should be in the command.

route_add_0.0.0.0_mask_255.255.0.0_2.1.x.x_metric_2_-p

Hope that helps
0
 
TannerManCommented:
This can be accomplished by manipulating your route table. Dangerous, if not familiar with route tables. Open up your XP Control Panel and then the Network Connections applet. In the opening window click the  advanced option on the horizontal menu, then choose Advanced Options. In the connections section move your NIC utilizing 192.168.x.x to the top of the list if not thre.

From an command line type "route print" and see your table. You should see that the defaullt 0.0.0.0 route is set to use 192.168.x.x STOP right now and make a screen shot of your route table in case you have to revert back and don't remember any static routes already there.

Then type the following command and excute. Make sure my examples are changed to valid IP's and Network MAsk. If not familiar with the syntax, make sure you type with spaces just like listed below.

route add 0.0.0.0 mask 255.255.0.0 2.1.x.x metric 2 -p

What has been accomplished is the first path data will travel, if a specific path is not known, is the 192.168.x.x NIC. Then, if that destination can not be found there, it will then send the data to the secondary default path of 2.1.x.x. Just to explain, the "0.0.0.0" represents any address that is no known by this system, the "metirc -2" makes it the secondar path of choice and the "-p" makes it persistent so the route will stay after you reboot.

I hope this helps.
0
 
infutechAuthor Commented:
Should I remove the 2.1.X.X defaualt gateway? I saw that in another post
0
What Kind of Coding Program is Right for You?

There are many ways to learn to code these days. From coding bootcamps like Flatiron School to online courses to totally free beginner resources. The best way to learn to code depends on many factors, but the most important one is you. See what course is best for you.

 
lrmooreCommented:
TannerMan has the right idea, but you may have to adjust the metric, especially if you let XP set automatic metrics.
Using "route print" look at the metrics that you already have assigned with the two defaults. Using the syntax from TannerMan, put the "higher cost" route entry in with a higher metric than the one you want as a primary default.
0
 
FrabbleCommented:
If you're going to change the default route, you also need a zero mask, i.e.
route add 0.0.0.0 mask 0.0.0.0 <next hop>

If the 2.1.X.X gateway provides a route to other networks, then leave it in.

You should be able to modify the metric values without having to enter static routes. In advanced TCP/IP properties of the LAN connection, just untick Automatic metric and enter the value in the box provided.
0
 
TannerManCommented:
Frabble is dead on right. I don't knwo what I was thinking with the 16 bit mask on a default entry.....brain freeze.
0
 
infutechAuthor Commented:
Please forgive me, however I am a litte confused. I should now delete what tannerman has suggested and add the additional 0.0.0.0 route?
0
 
lrmooreCommented:
Yes, you can delete what you entered and add the proper gateway entry with all zeros...
0
 
infutechAuthor Commented:
One more time for clarification...
I need to: route add 0.0.0.0 mask 0.0.0.0 2.1.X.X metric 2 -p
Is that correct?  This way the traffic would attempt the 192.168.0.X route first?
0
 
lrmooreConnect With a Mentor Commented:
That depends. Look at the result of "route print" first.
What is the current metric for your default gateway? XP Defaults mine to '10'
Just make sure that the new route to 2.x.x.x has a higher metric than the existing default '2' might not be high enough.


0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.